PDA

View Full Version : [SOLVED] Latex Texlive: "No hyphenation patterns were loaded"



enaut
17th January 2012, 11:06 AM
Hi,

I have a Latex problem with the texlive distribution http://fedoraproject.org/wiki/Features/TeXLive I installed it and I think everything works fine but somehow the latex system does not find the hyphenation patterns.

When Compiling I allways get a message like:


Package babel Warning: No hyphenation patterns were loaded for
(babel) the language `ngerman'
(babel) I will use the patterns loaded for \language=0 instead.

and the hyphenation is weired!

I have texlive-hyphen-german.noarch installed but it does not recognize this package.

My document compiles just fine with Ubuntu!

Is there anything I overlooked? Any workaround for the problem?

RupertPupkin
17th January 2012, 09:33 PM
I have a Latex problem with the texlive distribution http://fedoraproject.org/wiki/Features/TeXLive
That's likely the problem; those TeX Live packages for Fedora are messed up and have caused all sorts of problems for users. I'd recommend uninstalling them and then installing TeX Live 2011 from the official iso image file as described here: http://tug.org/texlive/acquire-iso.html

With the official TeX Live 2011 installed on my F16 system I get the hyphenation patterns for ngerman:

This is pdfTeX, Version 3.1415926-2.3-1.40.12 (TeX Live 2011)
restricted \write18 enabled.
entering extended mode
(./xfigtest.tex
LaTeX2e <2011/06/27>
Babel <v3.8m> and hyphenation patterns for english, dumylang, nohyphenation, ge
rman-x-2011-07-01, ngerman-x-2011-07-01, ancientgreek, ibycus, arabic, basque,
bulgarian, catalan, pinyin, croatian, czech, danish, dutch, ukenglish, usenglis
hmax, farsi, finnish, french, galician, german, ngerman, swissgerman, monogreek
, greek, hungarian, italian, bokmal, nynorsk, polish, portuguese, russian, slov
ak, spanish, swedish, ukrainian, loaded.

enaut
18th January 2012, 05:28 PM
Hi,
I was able to solve the problem using this howto:

http://www.informatik.uni-oldenburg.de/~sos/latex/latexFAQ.html#babel

basically:

edit with root
/usr/share/texlive/texmf/tex/generic/config/language.dat and add "ngerman loadhyph-de-1996.tex" at the end.
execute
sudo fmtutil-sys --all
remove ~/.texlive2011 if any.