PDA

View Full Version : Broken NVidia Driver!



KitchiRUs
9th January 2012, 12:29 PM
So I was trying to install the proprietary drivers for my NVidia graphics card, and I was following the instructions on this (http://forums.fedoraforum.org/showthread.php?t=204752) link.

Since I've got a 64-bit machine, I followed the instructions for the regular kernel (not PAE).
I updated to latest kernel, and then I installed the akmod driver and blacklisted nouveau and everything, and now my Fedora hangs on bootup. The symbol of the 'f' loads and right at the end, when the desktop is supposed to show up, it freezes.

I can't paste the exact error message, since I've only got one computer at the moment. I shall the moment I can.

I've tried booting through the older kernels as well, and they hang at the same place.
Any help on how I can do this?

duffman128
9th January 2012, 03:01 PM
From what I've seen, the 'f' load screen means that the nouvea drivers are still 'active' in the boot image (initramfs-<kernel version>.img). One thing that indicates that it's safe to install the nvidia drivers is the dark blue, blue and white bars load screen and not the 'f' load screen.

The way I installed them (after a clean install I'm afraid) was to
-remove the nouveau drivers, that is
[CODE]sudo yum remove *nouveau*[CODE]
-restart x-screen (ctrl+alt+backspace). Gnome 3 should load in fallback mode.
-backup boot img, rebuild it and restart the system.
[CODE]sudo mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
sudo dracut /boot/initramfs-$(uname -r).img $(uname -r)
sudo shutdown -r now[CODE]
The fedora should load a dull load screen after this. Now it's safe to install the drivers.

NOTE: Before you update the kernel in the future you need to uninstall the nvidia drivers, reactivate the nouveau bool img and restart

KitchiRUs
9th January 2012, 06:15 PM
So there's no way I can recover this without a clean install? I was on the XFCE Spin... I assume there isn't any difference between that and Gnome 3 when it comes to installing the Nvidia driver.

Basically, even if I don't manage to install the drivers, I'm hoping to disable discrete graphics in Fedora, since it's sucking up battery life. But I was hoping to get it in full working order as first priority.

Now I guess I'll have to reinstall and reattempt. :(

duffman128
9th January 2012, 08:10 PM
I didn't try to recover my system since it had too many problems. This forced me to create a local repo so don't have to redownload the updates and programs. Anyway, the installation procedure should be the same for all desktop managers.

As for saving power, you can try underclocking the graphics card using coolbits and setting the cpu frequency to its lowest using cpupower. Whenever you want to use the full power just return the settings to the defaults. The problem is that you might void the warranty of the graphics card if you use coolbits.

KitchiRUs
10th January 2012, 07:23 PM
Okay... so what happened was the kernel was booting up all the way, but seemed to fail when trying to initialize the graphics on the older kernel (this is on the 3.1.6.x kernel, I had already updated to the 3.1.7.x kernel when my computer bonked). I was still able to get access to the tty2 shell, so I uninstalled the nvidia driver and un-blacklisted the nouveau driver, so now my 3.1.6.x kernel is back to great working condition.

My only worry is - Can I delete the newer kernel? And clearly the instructions to install the driver didn't work... is there any way I can get them to work?

duffman128
11th January 2012, 10:44 AM
If you installed them through updates then yes you can.
sudo yum remove kernel*3.1.7*
The above should work while using kernel 3.1.6.

Ok. I guess there's a difference in procedure between installing the original nvidia drivers and the rpmfusion nvidia drivers.

Try following this guide(which you probably did) if you want to use the rpmfusion drivers.
forums.fedoraforum.org/showthread.php?
t=204752

Otherwise try this. I'll start from scratch. I can only use one kernel. The other kernel fails to load after this.

-Download the propriety drivers for linux from the nvidia website (www.nvidia.com)
-Uninstall nouveau drivers
sudo yum remove *nouveau*
-Reboot the system just to be safe (ctrl+alt+backspace should be enough)
sudo shutdown -r now
-Log in and switch to tty3 or atleast kill x-server
sudo init 3
-Log in again and change directory(cd) to the drivers (probably in downloads)
cd <drivers directory>
-Run the nvidia drivers installer to blacklist the nouveau ones.
sudo sh NVIDIA*
-Choose 'Accept', 'yes', 'ok', etc until the installer unloads and then reboot
sudo shutdown -r now
-Backup the boot image
sudo mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
-Rebuild the boot image
dracut /boot/initramfs-$(uname -r).img $(uname -r)
-Reboot
shutdown -r now
-Switch to tty3, cd and run the installer
sudo init 3
cd <drivers directory>
sudo sh NVi*
-Reboot
shutdown -r now

This works on my system, so it should work on yours. To make things shorter you can switch to root (su). But, again, I could only use one kernel.

-To uninstall them.
sudo nvidia-uninstall
sudo rm /etc/X11/xorg.conf

By the way, what's wrong with kernel 3.1.7?

KitchiRUs
11th January 2012, 05:24 PM
Duffman128,

For some reason, when I installed the RPMFusion Nvidia driver (akmod driver), my 3.1.7 kernel was giving me a different error to my 3.1.6 kernel. I wasn't able to drop into tty3 or tty2 with 3.1.7, but I was with 3.1.6. So what I DID do, was go to 3.1.6, fix it like I said in my previous post, and then uninstall and reinstall the 3.1.7 kernel. So that's working okay now.

I did some more reading, and I figured out since I've got two graphics cards (a discrete card, NVIDIA, and my integrated Intel graphics) that the RPMFusion drivers wouldn't have worked anyway. But other forums have mentioned "Bumblebee" or "Ironhide". I'm still not too clear whether these will work or not. I don't want to try them immediately, since I've got a couple of projects to finish by the end of the week, so I might try this then.

Do you know if the proprietary Nvidia driver handles the optimus switching on Linux?

duffman128
11th January 2012, 07:02 PM
I'm not sure what you mean by optimum switching. If you mean switch between the two GPUs then I doubt it. You'll most probably have to disable the intel chip through the bios. It's easy to switch between them on a pc. As for a laptop, I have little experience, so I don't know.

KitchiRUs
11th January 2012, 07:57 PM
No... Optimus Switching is Nvidia's way of switching between discrete and integrated graphics to save power and optimize performance.

As far as I know, there's no stable way of doing that on a linux machine.

duffman128
11th January 2012, 08:34 PM
Oh. I learned something new. I would guess that's available if you have an nvidia integrated GPU.

Anyway, did you manage to get the drivers to work?

---------- Post added at 09:34 PM ---------- Previous post was at 09:23 PM ----------

I just did some research on Nvidia Optimus. My mistake, it's compatible with intel chips. I guess you'll have to wait till it's stable on linux.

duffman128
13th January 2012, 11:40 PM
I just updated to kernel 3.1.7 and installed the nvidia drivers. It seems smoother than 3.1.6.