PDA

View Full Version : [SOLVED] Smplayer2 Hi10P artifacts



raccoon
1st January 2012, 02:58 PM
Hello,

I've been using Smplayer2 for a while now and everything worked perfect, when I tried it with a 10 bit encoded H.264 file I can reproduce and Watch it (almost) perfectly.

The problem is that often artifacts(I don't really know if that's what they are) pop up, especially when the is a big change in the scene. What should look like the first image ends up looking like this.

http://i.imgur.com/V3Bjl.jpg

The artifacts disappear after a few seconds but its really annoying.
I'm using F15 with a ATI 5670 card if it's any help.

This is my first post so I apologize for any mistake and also I thank you in advance.

smr54
1st January 2012, 03:42 PM
A couple of guesses--but note these are just guesses, and not to be taken as definite statement.

Did you compile mplayer2 yourself? Have you tried with smplayer, as opposed to smplayer2? (Easily installed from rpmfusion.)

I don't have anything with an ATI card these days, so I don't know if that's an issue or not. You can poke around the forums and see if there's any useful information about ATI cards--I vaguely remember some issues, but I don't know if they're new issues or old issues.

Sorry to be of such little help--with the holiday, the forums will probably be a bit slow, but hopefully, you'll get a more useful answer shortly.

raccoon
1st January 2012, 03:47 PM
Did you compile mplayer2 yourself? Have you tried with smplayer, as opposed to smplayer2? (Easily installed from rpmfusion.)

No, its a bin.

Running mplayer2 from the terminal gives me the same result in the video playback.

Thanks

David Batson
1st January 2012, 04:08 PM
Try putting the following in /etc/environment as per https://bugzilla.gnome.org/show_bug.cgi?id=657071 comment #1. A logout/login or reboot may be required -not sure.


CLUTTER_PAINT=disable-clipped-redraws:disable-culling

raccoon
1st January 2012, 04:29 PM
Try putting the following in /etc/environment as per https://bugzilla.gnome.org/show_bug.cgi?id=657071 comment #1. A logout/login or reboot may be required -not sure.


CLUTTER_PAINT=disable-clipped-redraws:disable-culling

Doesn't seem to work.

Thanks

smr54
1st January 2012, 04:41 PM
I meant mplayer, instead of mplayer2. (Or smplayer, as opposed smplayer2--both mplayer and smplayer are provided by rpmfusion)

raccoon
1st January 2012, 05:07 PM
I meant mplayer, instead of mplayer2. (Or smplayer, as opposed smplayer2--both mplayer and smplayer are provided by rpmfusion)

Thanks a lot!
Last time I tried Mplayer it didn't have Hi10p support, it works perfectly now.

smr54
1st January 2012, 05:53 PM
Excellent. If you feel the problem is solved, you can click the thread tools things at the top, and since you're the starter of the thread, mark it solved. (However, you might want to wait to see if anyone has a suggestion to fix the issue in smplayer2.)