PDA

View Full Version : Fdisk command not found? NTFS/FAT32 Not supported?



Dewey
20th November 2004, 01:19 AM
I'm trying to mount my windows partitions under linux, and it's not going too well :)
I have a primary NTFS win2k partition, with an extended partition/logical drive D:, then my FC3 install.

I want to atleast mount my D drive (FAT32) which I assume is /dev/hda2. I wanted to use fdisk or cfdisk to double check my partition table, but This is all I get.

[root@localhost dewey]# fdisk
bash: fdisk: command not found

And I even tried to mount /dev/hda2 to /mnt/test hoping that it was my D: drive, and here's what I got.

[root@localhost dewey]# mount -t fat32 /dev/hda2 /mnt/test
mount: fs type fat32 not supported by kernel

I get a similar problem when trying to mount /dev/hda1.

If anyone could link me on information to get fdisk (or cfdisk) working, or even adding NTFS/FAT32 support, it would be well appreciated.

Thankyou.

imdeemvp
20th November 2004, 01:39 AM
the correct command is (type as root): /sbin/fdisk -l

mcg
20th November 2004, 01:40 AM
It is mount -t vfat!

Dewey
20th November 2004, 01:49 AM
Thanks a bunch!

Just switched from gentoo, so I'm used to using fdisk as a command.

I had to mount /dev/hda5 instead of hda2, because hda5 was the actual logical partition. Worked like a charm.

Edit:
VFAT doesn't work for NTFS does it? Here's what I got.

[root@localhost dewey]# mount -t vfat /dev/hda1 /mnt/windows
mount: wrong fs type, bad option, bad superblock on /dev/hda1,
or too many mounted file systems
Is it even possible to mount an NTFS partition with read+write permissions anyway?

mcg
20th November 2004, 02:09 AM
VFAT doesn't work for NTFS does it?

No, for NTFS partitions you have to write mount -t ntfs ;)

Shadow Skill
20th November 2004, 02:36 AM
You can have full read/write ntfs support if you use captive ntfs....but don't be surprised if your ntfs drives/partitions get nuked; full ntfs write support is still very much experimental in nature. Read support however is totally safe. linux-ntfs.sf.net should have rpm's for your fedora version just install those for your kernel and mount your ntfs drives as mcg indicated.

imdeemvp
20th November 2004, 02:56 AM
Read the instructions: http://linux-ntfs.sourceforge.net/rpm/index.html

Dewey
20th November 2004, 03:45 AM
All works like a charm now, thanks.

imdeemvp
20th November 2004, 05:15 AM
All works like a charm now, thanks.
Post your fstab to compare notes....I always like to see how other people solve their problems.

StoneBrooks
12th January 2005, 07:17 PM
I read on another post that you can resolve path issues with su -
I think I'll start using that instead of plain su