PDA

View Full Version : Issue with 3D games



LinuxNewb
19th November 2004, 11:22 PM
ok well i by no means have a very slow computer and yes my gfx card is only 32mb but i can play games like enemy territory and americas army fine on it when i had it on my windos box but now that i have linux on ne game that is 3D lags REALLY bad, i cant play neverball, bzflag, tuxracer, torcs, etc.

can some help me figure out why these games are lagging so bad

sailor
19th November 2004, 11:35 PM
Have you installed the nvidia drivers?Have you edited your xorg.conf file....
Here are instructions for FC3:
http://www.fedoraforum.org/forum/showthread.php?t=26260&highlight=fc3+nvidia

LinuxNewb
20th November 2004, 02:04 AM
k well i read that thread and started following the instructions

as soon as i typed 'telinit 3' into the console it shut off gnome and proceded to say alot of stuff on the screen that i can remember to type

but it said sumthing about free pages and high mem and at the bottom it said

Out of Memory: Killed process <a number> (hotplug) and the number kept changing for about half an hour now it seems like it stalled

what did i do wrong? am i missing sumthing?

pbtpu40
20th November 2004, 03:04 AM
Once you type init 3 gnome will turn off and you will be sent to the console. Once here hit ctrl-alt-f1 and you will be sent to a "virtual terminal". You need to log in as root, and then run the nvidia installer following the instructions in this how to.
http://www.fedoraforum.org/forum/showthread.php?t=26260&highlight=fc3+nvidia

Hope this helps some.

LinuxNewb
20th November 2004, 03:25 AM
ahh it was the ctrl-alt-f1 to get to the virtual terminal that i was missing... sorry guys i know virtually nothing about command line im still learning it using linuxcommand.org

thanx pbtu40 :D

LinuxNewb
20th November 2004, 03:37 AM
ok new problem..

got to the virtual terminal, loged in as root, ran the sh command and entered the Nvidia setup, then said this
' No precompiled kernel interface found, would you like to download a kernel interface from the Nvidia FTP site'

i said yes then it said this

'No matching precompiled kernel interface was found on the Nvidia ftp site, this means that the install will need to compile a kernel interface for your kernel'

i clicked ok and then this

'Error: unable to find devlopment tool 'cc' in your path, please make sure that you have the package 'gcc' installed. if gcc is installed on your system, then please check that 'cc' is in your path'

then it takes me back to the virtual terminal.


what is going on? ill try and get gcc and try again but im very lost

woland
20th November 2004, 03:56 AM
install gcc
'yum -y install gcc'

LinuxNewb
20th November 2004, 05:07 PM
k i have installed gcc using synaptic, during the installation it said sumthing abouthaving a conflict with 'rivafb' and to remove that from startup process's , how do i go about doing that?

also during the installation it said sumthing that im not sure was good or bad

"NVIDIA 'Taints' kernel" should i worry bout that or is that normal? the kernel im running is 2.6.9-1.667

macemoneta
20th November 2004, 05:27 PM
The rivafb warning is just a notice that you don't want to be using the kernel's frame buffer support at the same time as the Nvidia driver. You won't be, so that's nothing to worry about.

The "taints kernel" message is just letting you know that the Nvidia driver isn't licensed under GPL. The kernel sets a flag when you use non-GPL kernel modules (like the Nvidia driver), so that the kernel developers can tell quickly whether or not a problem is debuggable by them. A tainted kernel problem has to be debugged by the vendor of the tainted module (Nvidia, in this case). Again, it's nothing that you need to worry about.

You should be good to go.

LinuxNewb
20th November 2004, 05:38 PM
ok thanks :D just wanted to know if i actally had to turn off the frame buffer support :D

you guys are such a help :D

LinuxNewb
21st November 2004, 01:21 AM
k, ive installed the drivers and done everything correct i think

ive edited the /etc/rc.sysinit file to read 'other "nvidia"' on line 152

now when i load up it gives me a Nvidia logo screen and just kinda lags there and stalls... what did i do wrong?

ive even tried removing the nvidia from line 152 in rc.sysinit so it reads "" again but i still stall on the nvidia logo screen at boot up. any ideas guys?


it is also my understanding that i need nvidia-glx, but i cant find that where do i get that?

pbtpu40
21st November 2004, 09:21 AM
Did you also remove load dri from the Section "Module" by commeting or deleting in /etc/X11/xorg.conf.
Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
# Load "dri"
EndSection
This is a copy of my section, note that Load dri is commented out by a #. If dri isn't commented that could be the source of your problem.

LinuxNewb
21st November 2004, 03:18 PM
yes i added the #

i also changed the Driver "nv" to read Driver "nvidia",

i ran the modprobe nvidia command

also ran the cp -a command and the chown command

do i need java or sumthing like that on my machine??

also in other posts it mentions to remove conflicting files, is xorg-x11-Mesa-libGL the only file that would conflict or are there others i should remove as well?

LinuxNewb
24th November 2004, 05:42 PM
k ive finally got it working, using the patched 6111 driver that vipergts450 posted :)