View Full Version : eeepc 1015B issues

27th December 2011, 07:20 AM

I've got the Asus Eee PC 1015B netbook and running Fedora 16. And I am facing the following problems:

function keys aren't working at all
The Fn-Keys for adjusting speakers, brightness of the screen and such stuff aren't responding at all. They work on the (pre-installed Windows 7) and do what they should do under Open SuSe.

sound issues
I had no sound - the system found both sound-devices and the appropriate drivers were loaded. Only in VLC player I was able to get any sound because only there I was able to definitely select *this* or *that* soundcard.
After installing *Battle for Wesnoth* and giving it a frustrated try to play it without sound I suddenly got the whole soundsystem blasting at full level. Now everything works fine - but don't ask me how.
Which is somehow frustrating because I was really trying to figure this out - and then it worked by itself. Which might bear the risk that it also might begone another moment.

screen brightness
As mentioned above - I can't adjust the brightness of the LCD screen. I already installed *Jupiter* and it does what it should do, like en-/disabling power-save modes etc, - though the FN keys still don't work. And the screen at full brightness becomes really painful over some time.

I looked-up this issues in different forums and internet-searches, and it seems to be a common problem.

My guess also is that this problems are quite independent from the Desktop Environment - at least they are present in LXDE and XFCE4 and dwm,

So my question is:

where can I adjust the screen brightness via shell?
I don't need to raise or lower it very often, because I really like to work with a dimmed screen, don't watch much video on this and don't work in the graphics field on this netbook.

Thanks in advance for your support and all your efforts!

27th December 2011, 09:05 AM
Servus Dweler, and welcome to the forum.
Those named DE's are/were hardly mainstream.
Thus, they might not be fully configured for all systems yet. LXDE for example needs to be configured manualy in ~/.config/openbox/lxde-rc.xml, dont know much about XFCE.
You might have better chances for working FN keys with either Gnome or KDE.

For your sound issues, you might want to try the yellow link on top of this page... Fedora Setup Guide, thought they might be not applicable for SuSe.

Hope this helps.
Happy holidays :)

3rd January 2012, 07:27 PM
Ungrateful me - sorry for that late reply, sea!

So, AutoPlus (available via Fedora Set-Up Guide, the yellow link on top of this page) solved some issues - like missing CoDecs for .mp3 and AdobeFlash.

I guess I might gain good karma when I convert all my audio/video to non-proprietary CoDecs like .flac, .ogg and so on.

The Fn-Keys trouble is also available for Debian - just to serve all and everyone. Here, no audio function whatsoever via these keys, but at least the screen brightness can be altered (also with some issues, but stable results).

In other news: I got some distros recommended that are more or less custom made for Eee PC - namely Leeenux and Fuduntu (Fedora meets Ubuntu). So changing the whole Distro/OS for such issues might be an option but not mine. I came over to Linux for the freedom of choice, but this way it's heading for the choice of the least harrasment. Which can't be the final solution.

Meanwhile, I'll give it a break concerning the sound/light issues. VLC player plays my music, Debian at least doesn't hurt my eyes and Fedora will be the solution, But as it seems, another time. Sigh.

I'll be glad and thankful for every hint how to overcome this trouble and thereby support those who also get into this problems.

19th June 2012, 07:19 PM
Hei there!

Looks like these issues have been hanging for quite a while. I've just bought an Asus 1015BX and went for Fedora 16 LXDE, to spare the resources. The OS is running flawless, however, I still have this FnKeys issue. Sound, video, net, all is good. Even the Fn keys for brightness are working. But the Fn keys for sound, pad, wireless and sleep do not work. And this would be the most used keys in my case... shame having to use the mouse for every volume adjust.

Lately I've being looking for a solution to this issue but nothing yet...


so, just to add something: I've just installed KDE desktop in the very same PC and the FnKeys are working :) Also, the eeePC is not struggling with KDE as I thought it would. So, guess I'm using KDE from now on on this little guy here.

Dubious Dave
24th November 2012, 05:10 PM
You should read this link.


You need to see if eeepc_laptop is not loaded. Follow the on page link. However the fix assumes you use grub vs grub2.

If you use grub2 then fix it via:

For Fn-keys, add 'acpi_osi=Linux' to GRUB_CMDLINE_LINUX in /etc/default/grub . Then run 'grub2-mkconfig -o /boot/grub2/grub.cfg' . (This enables the eeepc_laptop module to load, which happens at boot time. It fixes issues with brightness and wifi Fn-keys, and maybe some other stuff...)

24th November 2012, 10:36 PM
It would be interesting if someone using this machine could post whether F17, or even F18, fixed the remaining issues. What happens is that a machine comes out, and several things don't work, then, a few updates later, e.g., F16-F18, Ubuntu 10 whatever to 11 whatever, the issues will be fixed.