PDA

View Full Version : Get a login problem in f16



hypeboyz
19th December 2011, 03:33 AM
i'm a user since f13, but this time the problem i got is unbearable
after Dec 18's update (GMT +8) of kernel and something like login software i failed to use the desktop anymore. the kernel are loaded okay so as the login. but it does a bite after that: the gui are frozen without any reaction -- only the desktop background and mouse are displayed, and nothing else
i'm wondering if i can switch to the fallback mode in the text mode so that i can get rid of gnome3 stuff or have this problem solved
thanks

sea
19th December 2011, 12:07 PM
Can you switch to terminal view while your login GUI is frozen?
You'd need to press ctrl+alt+Fx (x = 1-7), where you hopefully can log into root and do the maintanance.

AlFrugal
20th December 2011, 10:08 PM
I'd just like to add that I experienced the identical login problem with Gnome 3 on the same day as the OP.

I normally use KDE but I had been using Gnome 3 since December 14 after I became unable to log-in to KDE. On December 6 I used preupgrade to upgrade from F15 to F16. From December 6 until December 13 or 14 I was able to boot-up F16/KDE daily with no problem. Starting December 13 or 14 I became unable to log-in to KDE. The KDE startup sequence displayed the hard-drive icon and then reverted to the login screen. My daily logwatch report indicated one segmentation fault in kded4 and one in ksmserver per failed KDE login attempt. So I began using Gnome 3.

Since I now can't login to KDE or Gnome 3, I'm using Ubuntu on my multiboot desktop. I too am a long term Fedora user, since FC5.

I would appreciate any tips on how to debug the KDE or Gnome 3 problems.

AlFrugal
23rd December 2011, 02:22 AM
Yesterday I tried again to log-in to KDE and Gnome and both logins again failed. In the logwatch report for yesterday there was mention of an selinux error regarding dbus process context.

Today, I logged in to failsafe mode and set selinux to permissive mode (selinux remains enabled but selinux failures are ignored). I then restarted X Window system. I was subsequently able to log in to both KDE and Gnome.

Any suggestions on how I can further debug this to get a permanent fix. (I don't want selinux disabled as a permanent fix.)