PDA

View Full Version : Amarok cannot play



fedoguille
7th December 2011, 01:33 AM
Hi, I have read what was an user's problem and I think mine is likely, but when I try to hear a song a message pops up and says"MPEG 1 layer 3 is necessary to play this song",and it looks for that application but it doesn't find it.I don't know how to solve it. please maybe you can give me a tip or a knowledge you have.Thank you very much.:(

Dors
14th December 2011, 01:33 PM
Try to install gstreamer-plugins

fedoguille
8th January 2012, 09:17 PM
a message pops up and says MPEG-1 layer3 (MP3) is necessary to play songs and I don't know how to install it because where you can mannage Fedora's sofware it doesn't exist.Thank you for your message!!!

marriedto51
9th January 2012, 01:19 PM
There are a few possible routes to getting mp3 playback to work. One way is to use DangerMouse's Autoplus script, which you can get via the yellow "Fedora Set-Up Guides" link at the top of this page.

Here is what I have done, using KDE. (I guess you might be, too, since you are using Amarok.)

Click on the yellow "Fedora Set-Up Guides" above, and then follow the link for RPMFusion. Now click on the link "RPM Fusion Free for Fedora 15 and 16" and ask to open with Apper. Do the same for "RPM Fusion nonfree for Fedora 15 and 16". This will give you access to lots of software that is not supplied directly by Fedora.

Now use System Settings (from your main KDE/Fedora menu) and click Software Management. Type "gstreamer-plugins" into the search box and press return. With luck you should have a list of around 20 packages to choose from. Click the Install button for each of: gstreamer-plugins-bad, gstreamer-plugins-bad-free, gstreamer-plugins-bad-nonfree, gstreamer-plugins-good, and gstreamer-plugins-ugly.

With those packages installed, you should have most audio codecs available for use. You might need to log out and back in again to get them recognized.

Hope that gets you started.

fedoguille
9th January 2012, 08:42 PM
Thank you very much, I'll get to do this and sure, as you say, everything will be ok.!!!!. Thank you again