View Full Version : can't boot after fresh fc16 install, linux raid-5

5th December 2011, 04:46 PM
as title says, system won't boot after fresh install of fc16 to software raid 5. The install completes without error but during subsequent boot, I get "no boot device error". I've tried to install grub from the live cd (installsl w/o error) but it doesn't help.During fc install partitioninbg step FC prompted me to add a bios boot partition because the disk had a gpt label. I'm sure this related however not sure how to fix. it's an older motherboard too. any help?

20th December 2011, 07:05 AM

I have too having the same problem. May I know if you have solved the problem already?

5th January 2012, 11:06 PM
/boot needs to be located on a non-raid partition. / can be on a software RAID5 partition though. If the RAID5 is created through a controller, /boot can be create from it, but make sure the RAID5 is marked as bootable in the controller.

Gareth Jones
6th January 2012, 03:13 AM
Yes, /boot and the BIOS boot partition (if using GPT with BIOS) must both be outside of software RAID, as they need to be accessible by BIOS and GRUB before the RAID software is loaded.


6th January 2012, 08:35 AM
You can try inserting the modules for RAID into the core.img file that grub2 uses.

boot from the DVD and select rescue mode, this should mount your installed system under /mnt/sysimage

edit your /mnt/sysimage/boot/grub2/grub.cfg and add the lines:

insmod raid
insmod mdraid09
insmod mdraid1x

Then (If you are using the first 2 disks in your system for your RAID)

chroot /mnt/sysimage
grub2-install /dev/sda
grub2-install /dev/sdb

/boot does not have to be a non-RAID partition, but sometimes even with inserting the modules manually it doesn't work properly. So it is stilll recommended to have /boot on a non-RAID partition.