PDA

View Full Version : [SOLVED] Nautilus doesn't open via terminal



karthikp
2nd December 2011, 06:40 PM
I tried opening nautilus via the terminal and I'm getting this weird error. When i try this command :


nautilus

it gives me an error saying :


Connection is closed

I tried searching for it, but couldn't find anything. Anybody know what the problem might be?

PS: I'm using F15

Gareth Jones
2nd December 2011, 07:14 PM
Are you trying to run it as root? If so, use sudo or "su -c", not "su".

Gareth

Dan
2nd December 2011, 07:27 PM
Try this, too. (Providing you're trying this from a terminal in a GUI and are trying to start the file browser.)



su -
(provide password)

nautilus --no-desktop


As Gareth said, that little minus sign/dash is critical.

karthikp
2nd December 2011, 07:33 PM
It worked like a charm! Thanks. I was running it as a root, but I never knew about the '-' sign. Can you tell me why it is important?

Dan
2nd December 2011, 07:57 PM
Essentially, it provides access to the root user's default paths when it logs you into the root account. Without it, you get to have all the phenomenal cosmic powers ... but you've got no flippin' clue where the executable goodies toolbox is unless you provide the path yourself.