PDA

View Full Version : Unexpected inconsistency



Scony
23rd November 2011, 02:27 PM
I have started my journey with fedora14. I updated to 15, recently to 16.

Today I turned on my OS and after choosing fedora from GRUB list, I recived :

_Fedora14(..): Unexpected inconsistency: run fsck manually

(...) unattached inode 40

etc. etc.

Interesting is, why string contains 14 if i have 16 ?

I tried to fsck /dev/sda but its busy (tried to umount but it is already un-mounted)

I typed "exit" and fedora 16 verne booted well, however error is showing every time I turn on my notebook.

What to do ?

JEO
23rd November 2011, 03:44 PM
The volume label was created at the time you installed Fedora 14. When you upgrade and it sees you already have a label it doesn't change it.

If it says to run fsck manually and before you hit exit try to determine which device and partition number it is by "cat /proc/mounts" or the "blkid" command. Then lets say it is /dev/sda2 for example. Change it to a read only mount with "mount -o remount,ro /dev/sda2 /". Then you can "fsck.ext4 /dev/sda2"

Scony
23rd November 2011, 05:20 PM
Okay.

blkcd returned 4 rows... one contained "_Fedora14" in label, so I guess here is problem
it was /dev/mapper/vg_xxxxx-lv_root
so
fsck -y /dev/mapper/vg_xxxxx-lv_root
fixed my problem

Huge thanks and free hug for you m8 !

lambcutlet
25th November 2011, 05:37 PM
scony
I'm happy i found your post your fix worked for me also
f15 to f16
cheers