PDA

View Full Version : gnome 3 thinks I have two monitors when I have only one



beckerde
23rd November 2011, 02:33 PM
I have a strange problem with a new computer with intel atom in a very small case.

I installed F16 with no problem (almost) but when it boots, it thinks I have two screens.

I was able to login typing by memory the appropriate keys. The only screen I see is the secondary one.

I ran gnome-control-center with Alt+F2 to adjust my selections with respect to screens, I shut down the primary one, and after applying I've got the desktop with one screen back.

But now the problem is when I log out. It goes back to two screen configurations. My settings apply only to me, not for the login screen.

How do I setup only one monitor, or copy my screen configuration to the login screen one?

Fedora 16, Gnome 3.
My smolt:
http://www.smolts.org/client/show/pub_f793a360-effc-47ac-9a82-c8eae6c20e5c

thanks in advance.

---------- Post added 23rd November 2011 at 10:33 AM ---------- Previous post was 22nd November 2011 at 11:17 PM ----------

I found a workaround (lateral thinking). :-)

I enabled automatic login to the only user that will be using this computer. I added a couple of lines to the [daemon] section at the /etc/gdm/custom.conf file:

AutomaticLoginEnable=true
AutomaticLogin=myusername

And that's it.

JEO
23rd November 2011, 03:34 PM
Another workaround: When you are at the login screen make sure the mouse cursor is visible then hit enter. That usually causes the login window to jump to the screen with the cursor.