View Full Version : X server does not start anymore

14th November 2011, 08:48 PM
Hi all,
I have problems with X server. After installing some packages (I don't remember all of them, examples are freetype, graphviz) the X server does not start anymore. I can only access the Single User mode.

The X.org.0.log file does not report any Error (namely, "EE") but some Warnings are present, saying:
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(WW) `/unix/' not found (or not valid).
Entry deleted from font path.

I can't post the file, because presently I'm using another linux PC.

I am not an expert user, I' wondering if installing the packages could have "destroyed" something.
Anyone could help me????



14th November 2011, 08:57 PM
No need to remember everything!

You can use "yum history", with various options, or, perhaps more conveniently, use the yumex gui to find out what you installed (or upgraded) recently, and hence what you might try uninstalling (or downgrading).


14th November 2011, 08:59 PM
Also look through /var/log/messages for any errors around the time that the X server is trying to start.

More information would help. What Fedora version are you running? What model video card do you have and are you using a proprietary driver or the one that came with Fedora?

The usual reason for X server breakage would be if you install 3rd party packages (not from the fedora or fedora-updates repositories). You can review /var/log/yum.log to see what you installed recently. It may also be possible to use yum history and undo options to fix it. See man yum, the section about history.

14th November 2011, 09:10 PM
Thank you for your suggestion.
Tomorrow morning I'll use the yum history..I can't use the gui since no graphic.. :-(


---------- Post added at 09:10 PM ---------- Previous post was at 09:05 PM ----------

All started when I tried to install PyMOL. I could not use yum.. so I had to use rpm with manually resolving all dependencies (many....). Everything seems to go ok..
Then I tried to install Imagemagick to create movies from PyMOL pictures.. and I had to install many other packages for all the dependencies.. Finally, when restarting, the X server did not start anymore..

As I said, tomorrow morning I will check all installed packages.. in the meanwhile.. any other suggestion?

Thanks, Gea

14th November 2011, 09:50 PM
Hi Gea,

All started when I tried to install PyMOL. I could not use yum.. so I had to use rpm with manually resolving all dependencies (many....). ...
It may not help in this case but for future reference note that you can use:
yum localinstall some_rpm_file
to resolve dependencies.


15th November 2011, 08:42 PM
It was the nvidia driver..
I really don't know why.. but the configuration changed, and the "rdblacklist=nouveau" disappeared during packages installation!
Indeed, just adding it the X server started again!!!

Thanks a lot for your suggestions