PDA

View Full Version : F15 SSH & Telnet go to sleep



fieldmonkey
7th November 2011, 03:30 PM
I installed Fedora and did some minimal configuration settings. For the most part I installed Fedora with the defaults and configured DNS BIND, SSH, Telnet and firewalld.

I am just trying to have it available to me over the WAN link so I can play and learn more about linux.

The problem is while all of them work over the WAN and LAN, the machine falls asleep and I can't access it. so that my first problem, and question ... How do I keep the machine from falling into a sleep mode?

Furthermore I have configured the GUI firewall to allow connections on those ports, but I always need to stop the firewalld service first on the CL before it's accessible over the WAN/LAN. So my second question is how can I add these port configuration into the firewalld service?

katykat
8th November 2011, 09:52 AM
I do not permit remote desktop on my systems so cannot assist there.

However the machine BIOS *may* have settings that can help such as WAKE ON LAN, or disabling system sleep functions.

You should also be able to use a simple script in a loop to emulate key presses and have it start at bootup, or as a cron job.