View Full Version : F15 BCM43224 stopped working after update

16th October 2011, 12:06 AM
A year ago I set up the BCM43224 wireless on my laptop. It has worked fine after each kernel update until the most recent. I have seen many threads on here about bcm43224 support, but I think my problem is different.

I have blacklisted bcma, and kmod-wl was working until the most recent kernel update. I suspect an update to something else (other than the kernel and kmod-wl) may be causing the problem, but I can't figure out what.

Some details:

$ uname -r

$ lsmod | grep wl
wl 1960208 0
lib80211 4999 2 lib80211_crypt_tkip,wl

$ dmesg | grep "wl\|eth"
[ 16.493422] wl 0000:12:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 16.493433] wl 0000:12:00.0: setting latency timer to 64
[ 16.514607] eth1: Broadcom BCM4353 802.11 Hybrid Wireless Controller

$ iwconfig
eth1 IEEE 802.11abgn ESSID:"" Nickname:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Bit Rate:44 Mb/s Tx-Power:24 dBm
Retry min limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Managementmode:All packets received
Link Quality=5/5 Signal level=0 dBm Noise level=0 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

$ iwlist eth1 scan
eth1 Failed to read scan data : Invalid argument

I have no idea why the scan is failing. I tried compiling the broadcom-wl driver from source instead of using kmod-wl, and I get the same problem: nothing unusual in the logs and the scan is failing.