View Full Version : Endless cycle of asking for WPA passphrase

15th October 2011, 12:17 AM
Hi folks, recently migrated from BSD.

I've just finished installing F15 on my venerable Inspiron 600m (LXDE spin). Currently networking is working correctly if I use a hard line, but I cannot get my wireless to connect.

Chipset is Intel PRO/Wireless 2100. Firmware package is installed, according to yum.

When I try to connect using the gui, the little circle icon spins for a while and then it asks for my WPA passphrase. When I enter it it seems to consider connecting for a while and then just asks for my password again. This happens forever and so far I have not been able to connect wirelessly.

Please help!


---------- Post added at 06:17 PM ---------- Previous post was at 05:38 PM ----------

Wow... feel like a moron.

Rebooting fixed it. Looks like the NW session was timing out and wouldn't clear its status until I did a power cycle.

Didn't even think to try rebooting since this isn't windows, lol.

15th October 2011, 01:17 AM
Probably this would have worked too (no reboot needed)

systemctl restart NetworkManager.service

Also try to confirm that your wpa_supplicant service is set to run too