PDA

View Full Version : How to mount NTFS partions for win2k, and XP.



imdeemvp
16th November 2004, 04:19 AM
How to mount NTFS partitions for windows 2000, XP, 2003.
This will help a lot of our new comer to mount those partitions. You must begin here:
http://linux-ntfs.sourceforge.net/rpm/index.html and download according to your kernel.

Get your kernel version:
[imdeemvp@myfc3 ~]$ uname -r
2.6.10-1.741_FC3 and installed the package downloaded according to your kernel version:
[root@myfc3 imdeemvp]# rpm -ivh kernel-module-ntfs-2.6.10-1.741_FC3-2.1.22-0.rr.4.3.i686.rpm
Preparing... ########################################### [100%]
1:kernel-module-ntfs-2.6.########################################### [100%]
[root@myfc3 imdeemvp]# /sbin/modprobe ntfs
[root@myfc3 imdeemvp]# dmesg | grep NTFS
NTFS driver 2.1.22 [Flags: R/W MODULE].
[root@myfc3 imdeemvp]# cat /proc/filesystems
nodev sysfs
nodev rootfs
nodev bdev
nodev proc
nodev sockfs
nodev binfmt_misc
nodev usbfs
nodev pipefs
nodev futexfs
nodev tmpfs
nodev eventpollfs
nodev devpts
ext2
nodev ramfs
nodev hugetlbfs
iso9660
nodev mqueue
ext3
vfat
nodev rpc_pipefs
nodev autofs
ntfs

If you need to see your hard drives table partitions, open terminal, become root and type:
/sbin/fdisk -lyou will this result:
[imdeemvp@myfc3 ~]$ su
Password:
[root@myfc3 imdeemvp]# /sbin/fdisk -l
Disk /dev/hda: 81.9 GB, 81964302336 bytes
255 heads, 63 sectors/track, 9964 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 1 3057 24555321 c W95 FAT32 (LBA)
/dev/hda2 * 3058 3070 104422+ 83 Linux
/dev/hda3 3071 9964 55376055 8e Linux LVM

Disk /dev/hdb: 122.9 GB, 122942324736 bytes
255 heads, 63 sectors/track, 14946 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 * 1 9561 76798701 7 HPFS/NTFS
/dev/hdb2 9562 14946 43255012+ c W95 FAT32 (LBA)

Now mount your partitions:
mount /dev/hdb1 /mnt/win2k -t ntfs -r -o umask=0222
[root@myfc3 imdeemvp]# ls -l /mnt/win2k
total 379716
-r-xr-xr-x 1 root root 150528 Jun 19 2003 arcldr.exe
-r-xr-xr-x 1 root root 163840 Jun 19 2003 arcsetup.exe
-r-xr-xr-x 1 root root 0 Jan 30 00:08 AUTOEXEC.BAT
-r-xr-xr-x 1 root root 5418606 Jan 31 00:42 AVG7DB_F.DAT
-r-xr-xr-x 1 root root 5226033 Jan 30 23:50 AVG7QT.DAT
dr-xr-xr-x 1 root root 0 Jan 30 21:50 BJPrinter
-r-xr-xr-x 1 root root 192 Jan 29 16:04 boot.ini
-r-xr-xr-x 1 root root 0 Jan 30 00:08 CONFIG.SYS
-r-xr-xr-x 1 root root 8 Jan 30 22:52 DFIMB.DAT
dr-xr-xr-x 1 root root 4096 Feb 1 15:18 Documents and Sett



Read the instructions given. They are easy to understand. Here is my /etc/fstab:

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
/dev/hda6 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/hdb1 /mnt/win2k -t ntfs -r -o auto,umask=0222 My NTFS aoutmounting.
/dev/hda2 /mnt/windows vfat users,rw,owner,umask=000 0 0
/dev/sda1 /mnt/usbflash vfat noauto,users,rw,umask=0 0 0

This is also shortly explained at http://www.fedorafaq.org/#ntfs
I did not see a how to in the forum so I created one. Most of the info posted here was taken from the link provided but done in my terminal so it works. So post your questions here if you have problems...:D


HOW TO MOUNT FAT32 PARTITIONS IN FEDORA:
Now if you have Windows 95, 98 or ME and want to mount a FAT32 partition this is how is done:
First you have to make a mounting point in the mount directory. Open terminal become root and type this:
cd /mnt/now create windows directory:
mkdir windowsfat32 and now add it to fstab.
type:
gedit /etc/fstab and add this line:

/dev/hda3 /mnt/windowsfat32 vfat users,rw,owner,umask=000 0 0

NOTE /dev/hda3 is my fat32 partition....

NeoRevan
16th November 2004, 02:59 PM
I have not gotten this method of automounting to work, so I decided to piss about with it myself. Here is the method that works for me, running FC3:

Open /etc/fstab
-------------------------------
Place this on a line of its own:

/dev/hda$i /mnt/$name ntfs umask=0222 0 0
REMEMBER! Replace $i with the number of your NTFS partition (to figure this one out, check out the Linux-NTFS project linked to in the above), and replace $name with the name of the mount point you created on abovementioned page (usually "windows").
________________________________

To show an example, here's my fstab file:

# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/ / ext3 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda7 /opt vfat defaults 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
LABEL=SWAP-hda6 swap swap defaults 0 0
/dev/hda5 /mnt/windows ntfs umask=0222 0 0
/dev/hdd /media/cdrecorder auto pamconsole,fscontext=system_u:object_r:removable_t ,ro,exec,noauto,managed 0 0
/dev/hdc /media/cdrom auto pamconsole,fscontext=system_u:object_r:removable_t ,ro,exec,noauto,managed 0 0
/dev/fd0 /media/floppy auto pamconsole,fscontext=system_u:object_r:removable_t ,exec,noauto,managed 0 0
PLEASE DO NOT COPY/PASTE THIS INFO! If the mount info is not 100 % equal to your own setup (very unlikely), then you risk making your system unbootable. The above is only for reference. You have been warned.

Hope this helped someone :)

imdeemvp
17th November 2004, 10:46 AM
/dev/hda1 /mnt/winxp -t ntfs -r -o auto,umask=0222
You have to use "auto" and my fstab sample is for fc1 and fc2.

NeoRevan
18th November 2004, 05:30 PM
I cannot see this specified anywhere in your guide, hence I and other newbies have no way of knowing this....
And in FC3 you do not need to use auto, or any of the other options you (apparently) need in FC1/2.

brlmedia
19th November 2004, 07:32 PM
great how-to, after about 30 minutes i got it to work, thank you

dmarinos
23rd November 2004, 11:35 AM
I have tryied everything but my kernel doen't support this FS . I have to compile my kernel but where is that /usr/src/linux on 64-bit FC3 ?

FreeEagle
23rd November 2004, 01:16 PM
I simple question , but i am a newbie. HOw can i know which no. has this NTFS Partion ?


Best Regards,
FreeEagle

rpaller
23rd November 2004, 02:39 PM
1. Click on your "Red Hat" or Gnome Menu
2. Select System Tools
3. Select Hardware Browser
4. Enter root password when prompted
5. After window appears, select hard drives
6. It should display the available partitions on all your hard drives and removable media. Locate the one with the Type column.
7. Find the entry where Type equals ntfs. The device name will be something like "hdan" where n is a number.

imdeemvp
24th November 2004, 04:09 AM
I simple question , but i am a newbie. HOw can i know which no. has this NTFS Partion ?


Best Regards,
FreeEagle
open terminal and become root (su + password) and type:

/sbin/fdisk -l
this command will show your partitions table in terminal

Deathshroud
24th November 2004, 05:36 PM
I am able to browse through my drives now, but I have 1 problem. All my MP3's are on one of the NTFS drives, and XMMS for some reason will not load them. Anyone else have this problem?

imdeemvp
25th November 2004, 04:19 AM
Copy them to your linux partitions and re-try to load them there.

topa
18th January 2005, 08:53 PM
You are talking about /mnt/.... but this is for the fc1 and fc2. FC3 normally mounts under /media if I'm not mistaken, because I can't find a /mnt on my system.

OpteronGuy
1st February 2005, 04:26 AM
Ok, I have been reading through this thread and have gotten my NTFS to mount automatically, but I can get my user to see the files. I know the command is uid=(something) and gid=(something) but I don't know if I should put 500, my user name, user, etc. Which one should I go with???

imdeemvp
2nd February 2005, 09:20 PM
What is the line you are using in your fstab?

jlah
20th February 2005, 08:40 PM
Ok, step two and this newbie is shocked...again :)

[root@localhost ~]# uname -r
2.6.9-1.667


[root@localhost ~]# /sbin/modprobe ntfs
FATAL: Error inserting ntfs (/lib/modules/2.6.9-1.667/kernel/fs/ntfs/ntfs.ko): I nvalid module format

Anybody?

_Michael_
6th March 2005, 09:10 AM
Gday people i have a Serial ATA hard drive and it is listed as /dev/sda.
I am trying to mount a fat32 partition on it and o cannot mount it with write access.
I have tried all of the above fstab entries with /dev/sda2 (my fat32 partition) instead of /dev/hda with no luck.

any help would be great.

regards,
Michael

imdeemvp
6th March 2005, 09:12 AM
Unfortunally I dont have a sata drive yet....have you tried www.google.com/linux

.sAm.
6th March 2005, 04:51 PM
_Michael_ have you tried this:

mount -t vfat /dev/sda$ /mnt/sata

$ = the number of the fat32 partition.

sata = the name of your folder it is mounted under.

If it doen't show up in devices go to the folder /mnt/sata and try writing to it there. This worked for me, hopefully it should work for you.

dickinsd
12th March 2005, 01:45 AM
Ok, I have been reading through this thread and have gotten my NTFS to mount automatically, but I can get my user to see the files. I know the command is uid=(something) and gid=(something) but I don't know if I should put 500, my user name, user, etc. Which one should I go with???

I have a similar problem, did you ever get this figured OpteronGuy?

Dave

EDIT: Perhaps I should just give a little more info.

I have followed the instructions at
http://linux-ntfs.sourceforge.net/

I can mount my Windows XP partition, and I can get access to all of my files, my problem is arrising from trying to get the auto mount to work. I can open my folder for the XP mount, but I cant access any of the files? and I can not open any of the folders.
Basically all I can see is a windows full of folders (and some files) such as Windows and Documnets and Settings and Autoexec.bat

dickinsd
12th March 2005, 02:11 AM
Ok I knew I neede to add the uid=me, I have since added gid=500 and I now have access to the files etc.

Sorry :D

Dave

alphonsebrown
25th March 2005, 09:37 AM
some one to have captive ntfs working RW? with current kernel FC3

alphonsebrown
25th March 2005, 05:44 PM
I happen to have a strange issue if I tri to change in fstab /dev/hdc /media/dvdrecorder (from /cdrecorder1) and /dev/hdd /media/cdrecorder (from /cdrecorder2) after reboot fstab restores to the previous state... ??? any ideas?

awdac
25th March 2005, 05:52 PM
I happen to have a strange issue if I tri to change in fstab /dev/hdc /media/dvdrecorder (from /cdrecorder1) and /dev/hdd /media/cdrecorder (from /cdrecorder2) after reboot fstab restores to the previous state... ??? any ideas?
If you left 'managed' in those fstab lines, then they are getting overwritten by fstab-sync. You have to remove that word from your fstab lines that you want permanent.

alphonsebrown
25th March 2005, 05:55 PM
thanks I had that line woowowow

some managed to use captive-ntfs? RW?
it's not working for me with that setup:
-bash-3.00$ cat /etc/fstab
# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/ / ext3 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
LABEL=SWAP-hda8 swap swap defaults 0 0
#/dev/hda1 /mnt/system ntfs ro,exec,uid=0,gid=808,umask
=0027 0 0
#/dev/hda5 /mnt/media ntfs ro,exec,uid=0,gid=808,umask
=0027 0 0
#/dev/hda6 /mnt/data ntfs ro,exec,uid=0,gid=808,umask
=0027 0 0
# /dev/hda6 /mnt/data ntfs rw,exec,uid=0,gid=808,showe
xec,umask=0027 0 0
/dev/hda5 /mnt/captive-joro_b captive-ntfs defaults,noauto 0 0
/dev/hda6 /mnt/captive-formula1 captive-ntfs defaults,noauto 0 0
/dev/hda1 /mnt/captive-winboze captive-ntfs defaults,noauto 0 0
/dev/hdd /media/cdrecorder auto pamconsole,exec,noauto,f
scontext=system_u:object_r:removable_t,managed 0 0
/dev/hdc /media/cdrecorder2 auto pamconsole,exec,noauto,f
scontext=system_u:object_r:removable_t,managed 0 0
any suggestion will be highly appreciated

pdk001
28th March 2005, 05:35 AM
/dev/hdb1 /mnt/win ntfs umask=0222 0 0

i put above option in etc/fstab, and mount is work as well
but when i booting my computer, mount shows [fault] instead of [OK]
error messange is 0 doesnt exit
what does 0 0 mean?

thanks in advance

Maverick-23feb
29th June 2005, 08:38 AM
I want to access data from my NTFS partition. When I give cat /proc/filesystem I don't see ntfs ... does this mean my kernel does not support reading ntfs partitions???

[root@UNIFIED root]# fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 2040 16386268+ 7 HPFS/NTFS
/dev/sda2 2041 9728 61753860 f W95 Ext'd (LBA)
/dev/sda5 2041 4590 20482843+ 7 HPFS/NTFS
/dev/sda6 7141 9728 20788078+ 7 HPFS/NTFS
/dev/sda7 4591 4603 104391 83 Linux
/dev/sda8 4604 5878 10241406 83 Linux
/dev/sda9 5879 6009 1052226 82 Linux swap

Partition table entries are not in disk order
[root@UNIFIED root]# dmesg | grep -i ntfs
NTFS driver 2.1.22 [Flags: R/W MODULE].
[root@UNIFIED root]# grep -i ntfs /var/log/messages
Jun 29 12:29:43 localhost kernel: NTFS driver 2.1.22 [Flags: R/W MODULE].
[root@UNIFIED root]# cat /proc/filesystems
nodev sysfs
nodev rootfs
nodev bdev
nodev proc
nodev sockfs
nodev binfmt_misc
nodev usbfs
nodev pipefs
nodev futexfs
nodev tmpfs
nodev eventpollfs
nodev devpts
ext2
nodev ramfs
nodev hugetlbfs
iso9660
nodev mqueue
ext3
nodev rpc_pipefs
nodev autofs
nodev nfsd
[root@UNIFIED root]#

alphonsebrown
29th June 2005, 06:13 PM
you need a module for that Livna repo has it just have to match your kernel no problem with .69 kernel, and do a modprobe ntfs after installing the module of course then cat again

Maverick-23feb
30th June 2005, 05:48 AM
It works now... :D But cannot play mp3 from that partition :(

imdeemvp
30th June 2005, 08:12 AM
It works now... :D But cannot play mp3 from that partition :(
Move them to your linux partitions.

alphonsebrown
1st July 2005, 07:42 AM
no mount with read rights for your user no need to move them and to you have mp3 support in general?

Maverick-23feb
1st July 2005, 08:00 AM
no mount with read rights for your user no need to move them I login as root... no user created yet


and to you have mp3 support in general?No. But real player plays it for me :-)

alphonsebrown
1st July 2005, 09:00 AM
so what's the deally?

bryant
5th July 2005, 11:40 AM
i'm having a problem:

[root@localhost Jorge]# /sbin/modprobe ntfs
FATAL: Error inserting ntfs (/lib/modules/2.6.11-1.1369_FC4/kernel/fs/ntfs/ntfs.ko): Invalid module format

and i have already installed the package:
[root@localhost Jorge]# rpm -ivh kernel-module-ntfs-2.6.11-1.1369_FC4-2.1.22-0.r r.6.4.i586.rpm
Preparing... ########################################### [100%]
The package kernel-module-ntfs-2.6.11-1.1369_FC4-2.1.22-0.rr.6.4 is already installed.

can anyone help me?
thanks

alphonsebrown
5th July 2005, 12:17 PM
where did you get the module from and what's your `uname -r`

bryant
5th July 2005, 12:29 PM
never mind...i got the wrong package. i had installed the i586 cause i didn't knew the difference between i586 and i686 and the answer i found was wrong.
now i removed i586 and installed i686 and everything is working properly.

tks anyway :)

robshan
10th July 2005, 06:05 AM
first of all guys let me just say thanks to all you legends out there who post solutions for all us noobiex with problems!!
I've only been running linux since last week after many years of being a windows user and so far I'm loving the change but I'm still really noob at using it. I have multiple ntfs partitions on my HDD and I'mk trying to follow the instructions described earlier in this post to get my FC3 to read them...the process starts off all good but comes to a halt when I get to

mount /dev/hdb1 /mnt/win2k -t ntfs -r -o umask=0222 (of course I change the values to be relevant to my system ie. hda1)

to which I get the response "mount point does not exist"......not exactly sure what name to put in to replace "win2k"....my partition is called "local" in XP

I also cannot open fstab without it being read only to try the other approach

alphonsebrown
12th July 2005, 01:52 AM
wow you need "mount point" do you have a directory called /mnt/win2k? did you use 2k till now? I can't beleave that it's actually about 7-8 years old(2k)

alphonsebrown
12th July 2005, 01:53 AM
how to mount LVMs under windows?? what is ext3's maximum partition size?

robshan
12th July 2005, 08:54 AM
lol...sorry...I sussed out that I need to mkdir just after I posted that problem, and I have never run win2k I just pasted from the first topic in the thread I run XP......I get the message that I'm trying to mount an incompatible or invalid fs

alphonsebrown
12th July 2005, 09:05 AM
I'd recommend you to switch all ntfs volumes to ext3 or reiser but with reiser AFAIK it's too difficult to get some stuff working like SELinux and I don't know actually what else.. fedora setup doesn't support reiser (anymore?)

robshan
12th July 2005, 11:34 PM
I would if linux was my only OS but my main OS in winXP

alphonsebrown
13th July 2005, 12:03 PM
well it's up to you, pay or not to pay - that is the question

robshan
23rd July 2005, 01:34 PM
well I got it all happening by editing /etc/fstab, creating folders in /mnt, and by running

mount -t ntfs /dev/hda1 /mnt/windows

bit of a hassle but at least it works

alphonsebrown
24th July 2005, 09:46 PM
well, usually that's the way to make it happen or use captive auto config for read only

AnaQ
29th July 2005, 08:43 PM
Hi, i am new in linux, FC4 is my first. i tried to mount NTFS partitions, but it did not work.
I installed the packetage for my version succsefull, but /sbin/modprobe ntfs shows, that no ntfs module is in the system! so i installed module for i586, but that is not the correct version, because /sbin/modprobe ntfs shows
FATAL: Error inserting ntfs (/lib/modules/2.6.11-1.1369_FC4/kernel/fs/ntfs/ntfs.ko): Invalid module format
OK, so i want to remove it, but it is not easy :
[root@localhost download]# rpm -e kernel-module-ntfs-2.6.11-1.1369_FC4-2.1.22-0.rr.6.4.i586.rpm
error: package kernel-module-ntfs-2.6.11-1.1369_FC4-2.1.22-0.rr.6.4.i586.rpm is not installed
but it is installed!!!
[root@localhost download]# rpm -ivh kernel-module-ntfs-2.6.12-1.1398_FC4-2.1.22-0.rr.7.4.i686.rpm
Preparing... ########################################### [100%]
package kernel-module-ntfs-2.6.12-1.1398_FC4-2.1.22-0.rr.7.4 is already installed
i can not remove it and i can not install the right module... what to do?
im sorry for my english and for dumb questions :-)

Sicily1918
29th July 2005, 11:36 PM
Hi, i am new in linux, FC4 is my first. i tried to mount NTFS partitions, but it did not work.
I installed the packetage for my version succsefull, but /sbin/modprobe ntfs shows, that no ntfs module is in the system! so i installed module for i586, but that is not the correct version, because /sbin/modprobe ntfs shows
FATAL: Error inserting ntfs (/lib/modules/2.6.11-1.1369_FC4/kernel/fs/ntfs/ntfs.ko): Invalid module formatYou're installing the i586 version -- is that right for you? I install the i686 version in mine because I'm using Pentium 4s -- run "uname -p" to see which version of ntfs you need (my guess is it'll output "i686").
OK, so i want to remove it, but it is not easy :
[root@localhost download]# rpm -e kernel-module-ntfs-2.6.11-1.1369_FC4-2.1.22-0.rr.6.4.i586.rpm
error: package kernel-module-ntfs-2.6.11-1.1369_FC4-2.1.22-0.rr.6.4.i586.rpm is not installed
but it is installed!!!
[root@localhost download]# rpm -ivh kernel-module-ntfs-2.6.12-1.1398_FC4-2.1.22-0.rr.7.4.i686.rpm
Preparing... ########################################### [100%]
package kernel-module-ntfs-2.6.12-1.1398_FC4-2.1.22-0.rr.7.4 is already installed
i can not remove it and i can not install the right module... what to do?
im sorry for my english and for dumb questions :-)Run:
#rpm -qa | grep ntfs
find the real name of the rpm package (kernel-module-ntfs-2.6.11-1.1369_FC4-2.1.22-0.rr.6.4.i586.rpm is the human name -- once installed it's different. Mine's called kernel-ntfs-2.6.10-1.771_FC2.i686.rpm but the installed rpm (when I run rpm -qa) is kernel-ntfs-2.6.10-1.771_FC2).
Then run:
rpm -e [rpm name]

After that, make sure not only to get the right processor RPM, but the right kernel, too (#uname -rp will give you both).

In my instance (I have FC4 at home... too lazy to change it here at work), I run:
#uname -rp
and get:
2.6.10-1.771_FC2 i686
So I need the 2.6.10-1.771_FC2 NTFS Kernel patch for an i686 processor.

AnaQ
30th July 2005, 11:51 AM
Thanks, i have done it successfully :-) The problem was in the versions.

lintolis
10th August 2005, 07:42 PM
Hi everyone
i tried to follow imdeemnp's instructions but where his he says to #/sbin/modprobe ntfs after i have installed the ntfs kernel rpm i get amessage
"FATAL: Error inserting ntfs (/lib/modules/2.6.11-1.1369_FC4/kernel/fs/ntfs/ntfs.ko): Invalid module format
"
Can anyone help?
thanks!

imdeemvp
11th August 2005, 03:10 AM
Hi everyone
i tried to follow imdeemnp's instructions but where his he says to #/sbin/modprobe ntfs after i have installed the ntfs kernel rpm i get amessage
"FATAL: Error inserting ntfs (/lib/modules/2.6.11-1.1369_FC4/kernel/fs/ntfs/ntfs.ko): Invalid module format
"
Can anyone help?
thanks!
Did you downlaod the correct version for your kernel and chip structure?

lintolis
11th August 2005, 07:52 AM
Actually what i did from scratch was to
#uname -r
#2.6.11-1.1369_FC4
So i went to the site you suggested and downloaded the link for this kernel type from the first list of rpms (not the contributed ones).I installed it and the problem is as you know it.What i wanted to ask you is if an ypgrade of kernel to 2.6.12 would solve the problem ?
Also in the site that i doenloaded the above rpm there are also some files .ko like the one i mention and i downloaded it.Would it help me
Thanks very much for your time

mxstylez
6th October 2005, 09:40 AM
HAHAHA OMFG you should tell us ""NOOB"" that we have to mkdir into /mnt/name-we-wanted
Lol piece of cake Ty :P

Ive done everything imdeemvp said but when i try to mount its tell:

[root@localhost mxtech]# /sbin/fdisk -l

Disk /dev/hda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 3864 31037548+ 7 HPFS/NTFS
/dev/hda2 3865 9729 47110612+ f W95 Ext'd (LBA)
/dev/hda5 3865 7051 25599546 7 HPFS/NTFS
/dev/hda6 7052 7064 104391 83 Linux
/dev/hda7 7065 9729 21406581 8e Linux LVM

Disk /dev/hdb: 20.4 GB, 20411080704 bytes
16 heads, 63 sectors/track, 39549 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 * 2 39549 19932192 f W95 Ext'd (LBA)
/dev/hdb5 2 39549 19932160+ 7 HPFS/NTFS
[root@localhost mxtech]# mount /dev/hda1 /mnt/winxp -t ntfs -r -o auto,umask=0222
mount: mount point /mnt/winxp does not exist
[root@localhost ~]#

i got my package installed corectly for my kernel type all worked great except i can mount my freaking parition NO FREAKING MOUNT POINT EXIST

HUH?! Help me out

alphonsebrown
6th October 2005, 10:16 AM
does the directory wnxp exist?

mxstylez
6th October 2005, 10:28 AM
i got another probleme ive write my mount points into /etc/fstab

but when i boot up linux its tell me that bad mount point Bleeeeeh
i realy dont know what ive made wrong on it =D
my fstab look like that:

# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
/dev/devpts /dev/pts devpts gid=5,mode=620 0 0
/dev/shm /dev/shm tmpfs defaults 0 0
/dev/proc /proc proc defaults 0 0
/dev/sys /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
/dev/hda1 /mnt/winxp -t ntfs -r -o auto,umask=0222
/dev/hda5 /mnt/winxp2 -t ntfs -r -o auto,umask=0222
/dev/hdb5 /mnt/winxp3 -t ntfs -r -o auto,umask=0222

/dev/fd0 /media/floppy auto pamconsole,exec,noauto,managed 0 0
/dev/hdc /media/cdrecorder auto pamconsole,exec,noauto,managed 0 0

alphonsebrown
6th October 2005, 12:37 PM
remove the -t and -o and -r :)

pay attention how ext3 is specified, not like -t ext3 - this is not command line parameter anyway..... use linux-ntfs.sourceforge.net for further referece

mxstylez
6th October 2005, 01:10 PM
alphonsebrown

thx alot dude thats worked great ^^

arpadh
15th October 2005, 01:47 AM
Hi!

I mounted my 2 NTFS partitions with success as ROOT.
But as a 'simple' user I couldn't mount it! :confused:

The error messages were:

1. [mntent] line 9 in etc/fstab is bad
2. mount: can't find /mnt/SEAGATE_USR in /etc/fstab or /etc/mtab

and

3. [mntent] line 10 in etc/fstab is bad
4. mount: can't find /mnt/SEAGATE_SYS in /etc/fstab or /etc/mtab

The same error messages (line 1. and 3.) appear when the system is shutting down or booting.

Does anybody have an idea what should I do?

(I have created /mnt/SEAGATE_USR & /mnt/SEAGATE_SYS directories!)

Here is my /etc/fstab :

# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
/dev/devpts /dev/pts devpts gid=5,mode=620 0 0
/dev/shm /dev/shm tmpfs defaults 0 0
/dev/proc /proc proc defaults 0 0
/dev/sys /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
/dev/hda5 /mnt/SEAGATE_USR -t ntfs -r -o auto,umask=0222
/dev/hda1 /mnt/SEAGATE_SYS -t ntfs -r -o auto,umask=0222
/dev/sda1 /media/HUMSIRC vfat pamconsole,exec,noauto,managed 0 0
/dev/fd0 /media/floppy auto pamconsole,exec,noauto,managed 0 0
/dev/hdd /media/cdrecorder auto pamconsole,exec,noauto,managed 0 0
/dev/hdc /media/cdrecorder1 auto pamconsole,exec,noauto,managed 0 0

alphonsebrown
15th October 2005, 05:12 PM
don't use -t or -r -o... sh@t I just posted that a couple of posts above... look

arpadh
15th October 2005, 11:46 PM
WHY?

/dev/hdb1 /mnt/win2k -t ntfs -r -o auto,umask=0222 :confused:

Why do you use -t -r and -o ?

You get an error message if doing so!

The correct line in fstab is (in this case):

/dev/hdb1 /mnt/win2k ntfs auto,umask=0222

arpadh
15th October 2005, 11:52 PM
don't use -t or -r -o... sh@t I just posted that a couple of posts above... look
:) (see above)

sameeh
27th October 2005, 09:04 AM
well i followed the guide and were able to mount NTFS partiotions only with read support
can anyone help me with the how to mount it with READ/WRITE support pls ??

prosen
27th October 2005, 09:15 AM
no write support as of now .. from that site ..
if u want WRITE support .. u can use a 3rd party ntfs driver : captive NTFS
For more info .. visit http://www.jankratochvil.net/project/captive
btw .. its not fully developed so I give no guarantee whatsoever about that driver . U better make a backup of ur NTFS partition b4 using it .. it may screw up your partition .. it may also work well for you .. I refrained from installing it .. but one of my frnd has got it installed all rite ..
WARNING : USE IT AT YOUR OWN RISK !!!

MetalPrincess
3rd November 2005, 03:36 AM
Tried this and got this when I tried to install the rpm :(



# rpm -Uvh kernel-ntfs-smp-2.6.5-1.358.i586.rpm
Preparing... ########################################### [100%]
1:kernel-ntfs-smp ########################################### [100%]
__________________________________________________ _____________________________

ERROR: Cannot load the NTFS kernel module.

RPM: kernel-smp-2.6.5-1.358.i586.rpm

PLEASE: Report this error to rpm@flatcap.org
__________________________________________________ _____________________________

error: %post(kernel-ntfs-smp-2.6.5-1.358) scriptlet failed, exit status 1

Any ideas? I did see that someone above me there tried a 686 package rpm since they were on a Pent 4 I'll try that because I'm on the pent 4 :D


MP

MetalPrincess
3rd November 2005, 03:52 AM
Then I get this :(


FATAL: Error inserting ntfs (/lib/modules/2.6.5-1.358smp/kernel/fs/ntfs/ntfs.ko): Invalid module format

I want to see my hard drives! :( :( :(


MP

MetalPrincess
3rd November 2005, 03:58 AM
Can this all be related to my hard drives being on a promise card Ultra 100 Tx2? I don't know if theres a driver for it on the system or not :(

MP

alphonsebrown
3rd November 2005, 08:01 AM
are you sure you have smp kernel i586? and NEVER triple post - there's EDIT button

MetalPrincess
3rd November 2005, 11:56 AM
I have a similar problem, did you ever get this figured OpteronGuy?

Dave

EDIT: Perhaps I should just give a little more info.

I have followed the instructions at
http://linux-ntfs.sourceforge.net/

I can mount my Windows XP partition, and I can get access to all of my files, my problem is arrising from trying to get the auto mount to work. I can open my folder for the XP mount, but I cant access any of the files? and I can not open any of the folders.
Basically all I can see is a windows full of folders (and some files) such as Windows and Documnets and Settings and Autoexec.bat

Thank you for the help link. :D I was able to get everything up and going again :D

MP

thugpoet22
7th January 2006, 01:11 PM
Hi, i installed the necessary program to have ntfs support, now i just need to figure out how to actually mount my hard drives so that everytime i start up my system i will be able to acces them. I also wanted to know if ACC format is support within Linux, i believe thats the format thats used by itunes besides the normal mp3, I will continue to search the forum, but if anybody has a solution to my problem pleace post. Thanks in advance.

I actually have two hard drives, the first is fully windows xp, and the second hard drive is also ntfs but on that same drive i made an partitions for ext3 to install linux. I hope this helps.

Just as a side note... the hard drives that i wanted mounted are

/dev/hdg1 and /dev/sda1 i just dont know the code to mount them properly. :confused:

I've been trying to mount this hard drive its but its not working for me for some reason, here what i got.


[thugpoet22@localhost ~]$ su
Password:
[root@localhost thugpoet22]# cd /mnt
[root@localhost mnt]# mkdir c_drive
[root@localhost mnt]# mount /dev/hda1 /mnt/c_drive -t ntfs -r -o umask=0222
mount: special device /dev/hda1 does not exist
[root@localhost mnt]# mount /dev/hdg1 /mnt/c_drive -t ntfs -r -o umask=0222
[root@localhost mnt]# /etc/fstab
bash: /etc/fstab: Permission denied
[root@localhost mnt]# /etc
bash: /etc: is a directory
[root@localhost mnt]# fstab
bash: fstab: command not found
[root@localhost mnt]# /etc/fstab
bash: /etc/fstab: Permission denied
[root@localhost mnt]# /dev/hda1 /mnt/c_drive ntfs ro,defaults,umask=0222 0 0
bash: /dev/hda1: No such file or directory
[root@localhost mnt]# /dev/hdg1 /mnt/c_drive ntfs ro,dafaults, umask=0222 0 0
bash: /dev/hdg1: Permission denied
[root@localhost mnt]#

why am i getting permission denied, and also when ever i try to do f

alphonsebrown
9th January 2006, 08:47 AM
Captive release 1.1.6.1

The new packages can be found at:
http://www.jankratochvil.net/project/captive/


Changes:
* New FUSE interface, deprecated LUFS - improve compatibility of Linux kernel
* Provided script for proper NTFS unmounts during GNU/Linux OS shutdown
* Updates for recent Microsoft installed binaries and files for download
* Hopefully survives reading of many small files like on XMMS scanning
* Improved recent GNU/Linux build environment compatibility

UnaX
28th May 2006, 02:17 AM
Thanks for the help, finally I got it working :)

ilbh
29th May 2006, 02:23 PM
hi
is this to browse your windows files at fedora ?

alphonsebrown
30th May 2006, 07:20 AM
hi
is this to browse your windows files at fedora ?
It is to open your NTFS file system (windows files) under fedora yes! :p :eek:

Dyus
2nd June 2006, 03:32 AM
this is where i get to, any idea what im doing wrong?

[root@localhost ~]# /sbin/modprobe ntfs
[root@localhost ~]# dmesg | grep NTFS
NTFS driver 2.1.26 [Flags: R/W MODULE].
[root@localhost ~]# cat /proc/filesystems
nodev sysfs
nodev rootfs
nodev bdev
nodev proc
nodev cpuset
nodev binfmt_misc
nodev debugfs
nodev securityfs
nodev sockfs
nodev usbfs
nodev pipefs
nodev futexfs
nodev tmpfs
nodev inotifyfs
nodev eventpollfs
nodev devpts
ext2
nodev ramfs
nodev hugetlbfs
iso9660
nodev mqueue
ext3
nodev rpc_pipefs
nodev autofs
ntfs
[root@localhost ~]# /sbin/fdisk -l

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 10199 81923436 7 HPFS/NTFS
/dev/sda2 10200 30401 162272565 f W95 Ext'd (LBA)
/dev/sda5 20399 30401 80349066 7 HPFS/NTFS
/dev/sda6 10200 10212 104359+ 83 Linux
/dev/sda7 10213 20398 81819013+ 8e Linux LVM

Partition table entries are not in disk order
[root@localhost ~]# mount /dev/sda5 /mnt/win2k -t ntfs -r -o umask=0222
mount: mount point /mnt/win2k does not exist

im trying to mount a partition i made in windows for my files, as to keep them safe incase something goes wrong with the OS. i think i edited properly from the example code you gave but i guess not since its not working...

someone help a noob out?

alphonsebrown
2nd June 2006, 10:39 AM
create the directory (mkdir /mnt/win2k) first... and no need to post all the above, the error was enough

jonniebigodes
12th June 2006, 04:03 AM
with this entry in fstab can i as normal user access the ntfs disk????

/dev/hdb1 /mnt/win2k ntfs auto,umask=0222
or is it this one
/dev/hda1 /mnt/windows ntfs umask=000,auto,user,ro,noexec 0 0

daemmon
28th June 2006, 10:00 AM
i was wondering if there's a way to show the mounted ntfs partitions in "My Computer" ?

jonniebigodes
29th June 2006, 08:10 PM
i've figured it out thanks.....

arpadh
21st November 2007, 02:11 PM
They are shown on your Desktop, if you enable it. Are you using KDE, GNOME or XFCE?

Sothea012
30th November 2007, 01:35 AM
Hi.

I have just install Fedora Linux and also a new guy to Fedora.

I have 2 partitions on my hard drive ( C and D ) before drive C is running on Windows XP. I delete partition C and setup Fedora and drive D still a data drive. I would like to mount drive D to Federo to get my data in it.

Please anybody can help me solve this problem?
Thanks in advance.


FrankyJohnson

Sothea012
30th November 2007, 01:56 AM
Hi.

before I have windows xp pro and I slit my hard drive iinto C and D. before I run windows xp on drive C and now I delete it and setup Fedora Linux. I would like to get data from my D drive, but I dunno how, please anybody can help me solve this problem.

Thanks

Sicily1918
30th November 2007, 06:49 AM
Hi.

I have just install Fedora Linux and also a new guy to Fedora.

I have 2 partitions on my hard drive ( C and D ) before drive C is running on Windows XP. I delete partition C and setup Fedora and drive D still a data drive. I would like to mount drive D to Federo to get my data in it.

Please anybody can help me solve this problem?
Thanks in advance.


FrankyJohnsonInstall the NTFS kernel mods and so forth:
As root:
# yum install ntfs-3g
And then:
# fdisk -l
It'll output either /dev/hda or /dev/sda and show you your partitions (e.g., /dev/sda1 /dev/sda2, etc.) plus the format type (e.g., Linux, HPFS, whatever). Once you know which is your "D" drive (the non-Linux partition -- probably sda3 or 4):
# mount -t ntfs-3g /dev/sda3 /mnt
And then you're done. If you want a different location, create a different directory and substitute the /mnt for that.

Beralus
13th December 2007, 08:49 PM
uname -r displays:
2.6.18-1.2798.fc6
please tell me direct link to download appropriate file.(i ve no experience in linux)
Thanks