PDA

View Full Version : Trouble with built in 3G in my Lenovo x121e



Lazze2k5
1st September 2011, 10:52 PM
Hello

I recently bought a Lenovo x121e and tried to get the built in mobile broadband to work without success. The guide for adding a mobile broadband showed up and I configured it like I used to, it shows up fine in the networks list but when I try to connect it fails immediately.

Here's my /var/log/messages:


Sep 1 23:36:38 Kazoum-IX NetworkManager[873]: <info> Activation (usb0) starting connection 'Telenor Mobilt Internet 1'
Sep 1 23:36:38 Kazoum-IX NetworkManager[873]: <info> (usb0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
Sep 1 23:36:38 Kazoum-IX NetworkManager[873]: <info> Activation (usb0) Stage 1 of 5 (Device Prepare) scheduled...
Sep 1 23:36:38 Kazoum-IX NetworkManager[873]: <info> Activation (usb0) Stage 1 of 5 (Device Prepare) started...
Sep 1 23:36:38 Kazoum-IX NetworkManager[873]: <info> Activation (usb0) Stage 1 of 5 (Device Prepare) complete.
Sep 1 23:36:38 Kazoum-IX modem-manager[905]: <info> (ttyACM1) opening serial port...
Sep 1 23:36:38 Kazoum-IX modem-manager[905]: <info> Modem /org/freedesktop/ModemManager/Modems/0: state changed (disabled -> enabling)
Sep 1 23:36:39 Kazoum-IX modem-manager[905]: Invalid error code: 276
Sep 1 23:36:39 Kazoum-IX modem-manager[905]: Invalid error code: 272
Sep 1 23:36:39 Kazoum-IX modem-manager[905]: <info> Modem /org/freedesktop/ModemManager/Modems/0: state changed (enabling -> disabled)
Sep 1 23:36:39 Kazoum-IX modem-manager[905]: <info> (ttyACM1) closing serial port...
Sep 1 23:36:39 Kazoum-IX modem-manager[905]: <info> (ttyACM1) serial port closed
Sep 1 23:36:39 Kazoum-IX NetworkManager[873]: <warn> GSM modem enable failed: (32) Unknown error
Sep 1 23:36:39 Kazoum-IX NetworkManager[873]: <info> (usb0): device state change: prepare -> failed (reason 'modem-init-failed') [40 120 28]
Sep 1 23:36:39 Kazoum-IX NetworkManager[873]: <warn> Activation (usb0) failed.
Sep 1 23:36:39 Kazoum-IX NetworkManager[873]: <info> (usb0): device state change: failed -> disconnected (reason 'none') [120 30 0]
Sep 1 23:36:39 Kazoum-IX NetworkManager[873]: <info> (usb0): deactivating device (reason: 0).

The built in wan card is a Ericsson/Lenovo F5521gw. I've also tried my huawei E1750 usb stick which works fine with the same settings and SIM card.

I'm running kernel 3.0.0 and ModemManager is version 0.4.998-1.git20110706 which should support the F5521gw.

Anyone have any ideas how to solve this?

Thanks

Lazze2k5
6th September 2011, 11:46 AM
No one else with the same kind of issues, I really haven't found any useful tips on how to solve this.

diocles
24th January 2012, 11:03 PM
Hi,

Go into the BIOS, and reset to default settings.

Worked for me (running Debian) - there shouldn't be any problems with ModemManager. This is the link I found the answer at, although it doesn't show up very high in most searches for this issue:

https://bugs.launchpad.net/modemmanager/+bug/894124

Hope that helps,

Tim