PDA

View Full Version : Urgent help needed!



Adrian719
29th August 2011, 06:03 PM
Hey guys,
I just used photorec to recover files from a 40GB laptop HDD. I saved the files to my video folder in my Home folder. Now my home folder is full.
When I login to my computer, in about 30 second I get this error:

Oh no! Something has gone wrong.
A problem has occurred and the system cant recover.
Please logout and try again

Now I tried logging out, restarting, etc etc. Still get the error. I also did

yum erase @gnome-desktop
yum install @gnome-desktop

Still getting the error. I did some googling and found nothing.
Any ideas?
thanks!




[Also, I cant delete the files from photorec because the are protected. And I cant start up firefox or thunderbird)

bluewanders
29th August 2011, 06:11 PM
Why would you immediately uninstall your desktop and then re-install it?

That sort of behavior might work in windows... but it is liable to make your day a little less pleasant in linux.

So... the only thing you changed was moving 40 gigs of files to your home folder? If thats the case, and the whole uninstall gnome desktop hasn't mucked you up, you could try booting into a live cd, and pulling the files back off your hard drive onto an external of some sort. Then try restarting. That would be my first step... the gnome shell crash screen is just an overlay that you can get around, if you need to... but let's start simple.

DBelton
29th August 2011, 06:14 PM
the files photorec recovered may have been saved as a different user.

try opening a terminal, su to root, and change the owner of the files to your user.

(substitute your user name for <your user> below: )


su -
(root password)

cd /home/<your user>/Videos

chown -hR <your user>:<your user> *


That will change all files in your /home/<your user>/Videos folder to your user so that you will be able to move/delete them if you wish to.

You may have to do it from a console screen instead of from terminal..



CTRL-ALT-F2 to open a console
user name: root
(root password)

cd /home/<your user>/Videos

chown -hR <your user>:<your user> *

logout
CTRL-ALT-F1 to get back to your Xserver (Gnome)

Adrian719
29th August 2011, 06:17 PM
Why would you immediately uninstall your desktop and then re-install it?

That sort of behavior might work in windows... but it is liable to make your day a little less pleasant in linux.

So... the only thing you changed was moving 40 gigs of files to your home folder? If thats the case, and the whole uninstall gnome desktop hasn't mucked you up, you could try booting into a live cd, and pulling the files back off your hard drive onto an external of some sort. Then try restarting. That would be my first step... the gnome shell crash screen is just an overlay that you can get around, if you need to... but let's start simple.

I found a bug page, and some did that and said it worked, so I tried it. Doesnt seem to have screwed anything else up lol. I'll try booting with my LiveUSB and see what I am able to do.


the files photorec recovered may have been saved as a different user.

try opening a terminal, su to root, and change the owner of the files to your user.

(substitute your user name for <your user> below: )


su -
(root password)

cd /home/<your user>/Videos

chown -hR <your user>:<your user> *


That will change all files in your /home/<your user>/Videos folder to your user so that you will be able to move/delete them if you wish to.

You may have to do it from a console screen instead of from terminal..



CTRL-ALT-F2 to open a console
user name: root
(root password)

cd /home/<your user>/Videos

chown -hR <your user>:<your user> *

logout
CTRL-ALT-F1 to get back to your Xserver (Gnome)


Thanks, hopefully I am able to do that with the liveUSB running it.

I will+ post my results

bluewanders
29th August 2011, 06:21 PM
I haven't mucked around with having any encrypted files in my favorites folders... so it might be possible that the encryption is what is crashing your shell...

Good luck!

giulix
30th August 2011, 08:50 AM
For future reference, if the problem is zero disk space, the correct way to solve this is to start the system in single user mode, login as root, move the file/make some room and change runlevel to multiuser/graphical. In fact, the root user has some extra disk space reserved just for this kind of situations. So, since Fedora does not allow a graphical root login, you should boot in single user mode, (i.e. specifying 1 or S on the grub kernel line), move the file, and then telinit to 5. This (http://www.freedesktop.org/wiki/Software/systemd/FrequentlyAskedQuestions) link explains how to change targets with systemd in F15. To boot in single user mode with systemd, use the following kernel command line option:


systemd.unit=rescue.target