PDA

View Full Version : quick question on Fedora 14 ALSA sound crackle pop



drainnz
28th August 2011, 02:21 AM
Hi all.:)

My first post. Let me know if I am in the wrong forum. Please redirect if I am.

Machine: Fedora 14 64bit on an HP Pavilion dv6 laptop.

Problem: sound works but it pops and crackles in all sound apps not just flash.

I have disabled pulse audio but problem remains so I assume it is ALSA. I have googled and tried many things but I don't understand ALSA and am now looking for a quick fix - clear music is a must for productivity! Surely, someone else must have had the same problem and fixed it ?

Can someone in the know point me to a solution ?

Many thanks in advance and looking forward to a solution,

David.

jpollard
28th August 2011, 03:15 AM
Are you using the flash player?

There is a known bug in flash that Adobe hasn't fixed. There is a workaround available. It is caused by the misuse of memcpy. The GNU Clib developers enhance (ie, speeded it up, but introduced incompatibility with applications that used it improperly before without problems) causing pops in the audio.

I have attached my tar file of the workaround. I put it in /usr/local/lib, and invoke the library via LD_PRELOAD. The workaround came from Linus who also complained about it.

BTW, the usage.sh is not really a shell script, but can be included into the scripts that are start firefox and google-chrome.

drainnz
28th August 2011, 04:58 AM
Hi.

Many thanks for that. I have tried Linus' solution but it doesn't solve my problem.

I am hearing crackles and pops in other sound applications as well (rythmbox, banshee, audacious, vlc, totem, etc.) so my problem isn't specific to flash. The crackles and pops are very rare when I start an application and then they seem to become more frequent. I have a triple boot system with Windows 7, Fedora 14, and Ubuntu 11.04. Both Windows and Ubuntu don't seem to have this sound problem. This is frustrating since I prefer Fedora 14 (I didn't enjoy working in Fedora 15 - Gnome 3 feels like handcuffs, even the fallback) over the others.

Anyone have other suggestions ? Is there some specific information I should post (ie: alsa-info, lspci, lsmod etc.) to help track this down ? (I didn't want to post too much information in case it is a simple problem to fix).
Is there a better forum to post this in ?

Thanks in advance :)


update: just checked Ubuntu and Windows again...all OK so this seems to be a Fedora problem. Until I get this sorted, I'll have to work in Ubuntu!!! :(

leigh123linux
28th August 2011, 08:33 AM
It took less than a minute to find this.

https://fedoraproject.org/wiki/Common_F12_bugs#hda-clicks

drainnz
28th August 2011, 11:14 AM
Thanks for that....but I have tried that already with no success. I have tried quite a few of the really obvious things, things one can find in less than a minute, things that take a little longer than a minute to find and even some fresh installs of Fedora 14 in case I really broke something. No go.

Alas, after reading some reviews of Gnome 3 and seeing that Gnome 2 is not going to be supported in the future, I decided to give Fedora 15 another go. And, I am happy to report there are no sound problems in Fedora 15. Now I just have to get used to the the new workflow Gnome 3 imposes on you...although I am learning how the fallback is closer to Gnome 2.x than I originally thought...just need the right key strokes.

Thanks for your suggestions.