PDA

View Full Version : [SOLVED] install libdvdcss once and for all



PiElle
17th August 2011, 04:51 PM
Now that Livna repository is not on line, once and for all, what's the better procedure to install libdvdcss? :confused:

DBelton
17th August 2011, 04:56 PM
you can get it from videolan site, or it's also in atrpms.

You can enable atrpms, install libdvdcss from there. (I wouldn't leave atrpms enabled, though. It has been known to cause some conflicts if you use rpmfusion)

Or if you wish, you can just download the rpm files from atrpms and do a localinstall with yum.

For F15:
http://packages.atrpms.net/dist/f15/libdvdcss/

glennzo
17th August 2011, 05:34 PM
I've finally downloaded it to a local "storage" partition and just do as DBelton suggests, yum localinstall, whenever I need to.

Dangermouse
17th August 2011, 05:59 PM
The atrpms libdvdcss also requires libdvdcss2 as a dep also:rolleyes:, so you need both files for yum, or you can just use autoplus (latest) as usual to do the work for you;)

PiElle
17th August 2011, 11:09 PM
I think I'll follow the advice of DBelton and Glenzo, so I don't have to depend from an external repository anymore.
So, in this way, it's sufficient to download libdvdcss and yum localinstall it for setting all the dependencies?
And, just in case I should need it for other purposes, I've read the documentation of the atrpms site, but, sincerely, I don't understand the way to enable the atrpms repository :confused: . Could you explain that procedure for me?
Many thanks ... :)

glennzo
17th August 2011, 11:20 PM
Dangermouse's autoplus is an excellent tool for installing all things Fedora, after the initial OS installation. And you can take his advice too. He know's what's up. Matter of fact, if he hadn't mentioned it I'd probably try to install my copy of libdvdcss and run into dependence issues with libdvdcss2! As far as atrpms is concerned, assuming you have the repository installed, edit the file /etc/yum.repos.d/atrpms.repo. Find the line that reads enabled=1 and change it to enabled=0. Now the repo is disabled. If you need something from the repository you can enable it on a one time only basis with

yum --enablerepo=atrpms install thepackageineed

PiElle
17th August 2011, 11:44 PM
Thanks Glenzo!
Surely Dangermouse's autoplus is an excellent tool, but I'd prefer to make things by myself to learn the use of Fedora.
As far as Atrpms is concerned, I knew the way to enable or disable a repository (excuse me if I wasn't clear), the thing I really don't understand is what I have to do to have the Atrpms repository installed in /etc/yum.repos.d/! :)

sea
18th August 2011, 12:02 AM
Have SU rights in order to creater/save a repo there.
You may use leafpad or gedit to modify the file.

JohnVV
18th August 2011, 03:39 AM
PiElle

well i normally point people to autoten ( no autoplus)
or Mjmwired's page
http://www.mjmwired.net/resources/mjm-fedora-f15.html
http://www.mjmwired.net/resources/mjm-fedora-f15.html#libdvdcss

Wayne
18th August 2011, 04:12 AM
Also available from the Remi repo....

http://rpms.famillecollet.com/fedora/15/

DBelton
18th August 2011, 05:13 AM
The atrpms libdvdcss also requires libdvdcss2 as a dep also:rolleyes:, so you need both files for yum, or you can just use autoplus (latest) as usual to do the work for you;)


I did forget to mention the libdvdcss2 dependency.. Thanks for thinking about that one :)

But it is on the same page I linked to above for the libdvdcss package in atrpms. Both libdvdcss and libdvdcss2 are on there. (It also has the 32 and 64 bit listed)


I usually use your nice autoplus script myself, so libdvdcss gets installed when I do the "install most codecs" option. Thanks for taking the time and effort to write and keep your script up to date. It sure makes a fresh install of Fedora much easier.

PiElle
18th August 2011, 07:54 AM
Thanks to all.
So now I can mark this post as solved.
If, for some reasons, I have to reinstall Fedora, I'll hold autoplus in due consideration too. :)

Dangermouse
18th August 2011, 09:51 AM
Just a side note autoplus doesnt install atrpms repo, it installs the rpms directly from the repos like it did before with livna, it never installed livna repo either.;)

Also for those who dont know, you should never have rpmfusion and atrpms enabled at the same time as you will get masses of dependency problems..;)