PDA

View Full Version : xchm for Fedora Core 3



sideways
13th November 2004, 12:40 PM
This has been tested on FC3 final, but should work for other distros

The wxWidgets install is same as for the comical-0.4 how-to (http://www.fedoraforum.org/forum/showthread.php?t=26664)

You'll need wxWidgets for GTK+, get wxGTK-2.4.2.tar.gz from here:
http://www.wxwindows.org/dl_gtk.htm
and also these two rpm packages from your Fedora Core 3 discs or the usual dowmload sites
(eg http://download.fedora.redhat.com/pub/fedora/linux/core/3/i386/os/Fedora/)
glib-devel-1.2.10-15.i386.rpm, gtk+-devel-1.2.10-33.i386.rpm


chmlib-0.35.tgz from here http://66.93.236.84/%7Ejedwin/projects/chmlib/

xchm-0.9.5.tar.gz from here http://sourceforge.net/project/showfiles.php?group_id=87007

copy all files to /tmp and login as root



su -
cd /tmp
rpm -ihv glib-devel-1.2.10-15.i386.rpm
rpm -ihv gtk+-devel-1.2.10-33.i386.rpm

tar zxvf wxGTK-2.4.2.tar.gz
tar zxvf chmlib-0.35.tgz
tar zxvf xchm-0.9.5.tar.gz

cd wxGTK-2.4.2
./configure --with-gtk
make
make install


Now you need to add the line '/usr/local/lib' to /etc/ld.so.conf using your favourite editor.
Then continue:




ldconfig

cd /tmp/chmlib-0.35
./configure
make
make install
ldconfig

cd /tmp/xchm-0.9.5
./configure
make
make install



Now just type 'xchm' to open the viewer

orbknives
8th February 2005, 04:28 AM
i like xchm, nice guide...

pgk3734
9th February 2005, 07:50 AM
Another easier way is to go to: http://www.kamasoftware.com and download their
free program called HelpExplorer for linux. Works very well.
pgk

bluedisel
23rd March 2005, 12:29 AM
I have the pb running Helpexplorer.
When i run starthelp, there was a quick flash screen and then the application was closed.
If i run the helpexplorer directly from bin/ directory, there was the fellow error message:

./helpexplorer: error while loading shared libraries: libViewerUI.so: cannot open shared object file: No such file or directory

Note: I use KDE

Thanx in Advance

hiren_bhatt
23rd October 2005, 01:55 PM
I had just tried to install xchm as instructions. Every thing goes fine up till the following instruction.

Cd /tmp/xchm-0.9.5
./configure

when I try to configure xchm it gives the following error

ecking for wx-config... no
configure: error:
wxWidgets must be installed on your system
but the wx-config script couldn't be found.

Please check that wx-config is in path, the directory
where wxWidgets libraries are installed (returned by
'wx-config --libs' command) is in LD_LIBRARY_PATH or
equivalent variable and wxWidgets version is 2.3.4 or above.

I tried few things but donít get any further clue what to do. If some one can help.

phoenyo
7th September 2007, 09:40 AM
Thanks sideways! u save my time and xchm is really nice one. :)

sideways
9th September 2007, 11:28 PM
Thanks sideways! u save my time and xchm is really nice one. :)

Thanks but ....
This was for FC3!! :D

In more recent fedoras you have the likes of gnochm in the repositories, which makes things a lot easier :)

yum install gnochm