PDA

View Full Version : [SOLVED] Cannot install vlc in fedora 14



Fednik
31st July 2011, 01:16 PM
hi everybody,
I'm currently using Fedora14.
For installing vlc player i searched the net and found a solution having commands as follows:



1)su -

2)rpm -ivh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm

3)yum install vlc


It all worked fine till the 2nd command but when i typed the 3rd command i.e.(yum install vlc).It showed me some couple of errors.
I don't know how to proceed ahead or how to remove these errors.
The error was


[root@summu ~]# yum install vlc
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package vlc.i686 0:1.1.11-1.fc16 set to be installed
--> Processing Dependency: vlc-core(x86-32) = 1.1.11-1.fc16 for package: vlc-1.1.11-1.fc16.i686
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15) for package: vlc-1.1.11-1.fc16.i686
--> Running transaction check
---> Package vlc.i686 0:1.1.11-1.fc16 set to be installed
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15) for package: vlc-1.1.11-1.fc16.i686
---> Package vlc-core.i686 0:1.1.11-1.fc16 set to be updated
--> Processing Dependency: live555date(x86-32) = 2011.01.24 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libva-x11.so.1 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libdvbpsi.so.7 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libva.so.1 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libthreadutil.so.6 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libx264.so.115 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libmatroska.so.4 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libebml.so.3 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15) for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libmtp.so.9 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libupnp.so.6 for package: vlc-core-1.1.11-1.fc16.i686
--> Running transaction check
---> Package libdvbpsi.i686 0:0.2.0-1.fc15 set to be updated
---> Package live555.i686 0:0-0.30.2011.01.24.fc15 set to be updated
---> Package vlc.i686 0:1.1.11-1.fc16 set to be installed
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15) for package: vlc-1.1.11-1.fc16.i686
---> Package vlc-core.i686 0:1.1.11-1.fc16 set to be updated
--> Processing Dependency: libva-x11.so.1 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libva.so.1 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libthreadutil.so.6 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libmatroska.so.4 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libebml.so.3 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15) for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libmtp.so.9 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libupnp.so.6 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libx264.so.102 for package: ffmpeg-libs-0.6.3-1.fc14.i686
---> Package x264-libs.i686 0:0.0.0-0.30.20110714.fc16 set to be updated
--> Running transaction check
---> Package ffmpeg-libs.i686 0:0.7.1-1.fc16 set to be updated
--> Processing Dependency: libopenjpeg.so.3 for package: ffmpeg-libs-0.7.1-1.fc16.i686
--> Processing Dependency: libva.so.1 for package: ffmpeg-libs-0.7.1-1.fc16.i686
---> Package vlc.i686 0:1.1.11-1.fc16 set to be installed
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15) for package: vlc-1.1.11-1.fc16.i686
---> Package vlc-core.i686 0:1.1.11-1.fc16 set to be updated
--> Processing Dependency: libva-x11.so.1 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libva.so.1 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libthreadutil.so.6 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libmatroska.so.4 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libebml.so.3 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15) for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libmtp.so.9 for package: vlc-core-1.1.11-1.fc16.i686
--> Processing Dependency: libupnp.so.6 for package: vlc-core-1.1.11-1.fc16.i686
--> Finished Dependency Resolution
Error: Package: vlc-core-1.1.11-1.fc16.i686 (rpmfusion-free-rawhide)
Requires: libva-x11.so.1
Error: Package: vlc-core-1.1.11-1.fc16.i686 (rpmfusion-free-rawhide)
Requires: libstdc++.so.6(GLIBCXX_3.4.15)
Error: Package: vlc-core-1.1.11-1.fc16.i686 (rpmfusion-free-rawhide)
Requires: libebml.so.3
Error: Package: vlc-core-1.1.11-1.fc16.i686 (rpmfusion-free-rawhide)
Requires: libmtp.so.9
Error: Package: vlc-1.1.11-1.fc16.i686 (rpmfusion-free-rawhide)
Requires: libstdc++.so.6(GLIBCXX_3.4.15)
Error: Package: ffmpeg-libs-0.7.1-1.fc16.i686 (rpmfusion-free-rawhide)
Requires: libopenjpeg.so.3
Error: Package: vlc-core-1.1.11-1.fc16.i686 (rpmfusion-free-rawhide)
Requires: libva.so.1
Error: Package: ffmpeg-libs-0.7.1-1.fc16.i686 (rpmfusion-free-rawhide)
Requires: libva.so.1
Error: Package: vlc-core-1.1.11-1.fc16.i686 (rpmfusion-free-rawhide)
Requires: libthreadutil.so.6
Error: Package: vlc-core-1.1.11-1.fc16.i686 (rpmfusion-free-rawhide)
Requires: libupnp.so.6
Error: Package: vlc-core-1.1.11-1.fc16.i686 (rpmfusion-free-rawhide)
Requires: libmatroska.so.4
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


Please suggest me some solutions.

Thank you all!

MysticalDice
31st July 2011, 01:43 PM
rpm -i http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm

yum install vlc

David Batson
31st July 2011, 02:17 PM
You're trying to install VLC for a future version of Fedora instead of for Fedora 14. You are getting your packages from the Rawhide repository (not sure why). You need to get them from the Fedora 14 repository. I am not familiar with setting up a repository from the command line, but if you choose the following, I believe it should work.

# yum install http://download1.rpmfusion.org/free/fedora/updates/14/i386/vlc-1.1.10-1.fc14.i686.rpm

Fednik
4th August 2011, 05:33 PM
Thank you MysticalDice and David Batson.

I think i've figured out what the problem is but still need your help and others too.

After typing the command given by MysticalDice,

It showed me this result:


root@summu ~]# rpm -i http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
warning: /var/tmp/rpm-tmp.MQFsm3: Header V3 RSA/SHA256 Signature, key ID a3780952: NOKEY
package rpmfusion-free-release-13-4.noarch is already installed
[root@summu ~]#


which says that i lack a key to proceed ,even if it is already installed.
I just need to figure out what the key is.
and i dont know how to get that key. may be i'm wrong judging this (about the lacking key).

@David Brown
Sir i've removed the rawhide which was meant for fedora 16. but still the problem exists.

thank you all

David Batson
4th August 2011, 06:20 PM
Why not install yumex and get VLC using yumex? yumex is a GUI tool that will appear in the menu (or can be started from terminal as regular user.

Fednik
16th August 2011, 12:29 PM
Thanks David,
I don't know how I first cleaned all the Unwanted repos.
Then installed yumex and it worked for me.

Thank you all guy!!!!