PDA

View Full Version : Gnome related error



kantor
27th July 2011, 12:55 AM
I am trying to start the Brainvisa software on a fedora 15 install using gnome and i get this error:
/home/Kantor/kits/brainvisa/bin/real-bin/anatomist: symbol lookup error: /usr/lib64/gtk-2.0/modules/libpk-gtk-module.so: undefined symbol: FcLangGetCharSet


It works if i log into a KDE session but it's alot of hassle since a barebones KDE is not very functional. It doesn't seem to use nautilus or in anycase most of the software KDE uses isn't installed when installing just the window manager.

This is a known issue on the brainvisa forums also but I am hoping someone can muster up a fix.

sapetnioc
20th June 2012, 11:35 AM
The problems comes from a Qt plugins that adds the GTK+ style to the application. This plugin is installed on some systems and is used for default style when a Qt application is started from a Gnome desktop. Using this plugin may crash the application because BrainVISA provides its own Qt that is different from the one installed on the system. We have not yet found a way to ask to Qt not to use this plugin, there must be some hard coded plugin path somewhere that cannot be removed even if the plugins paths is set in qt.conf.

The work around is to force the style of the application. You can do that by a command line option, for example :


anatomist -style Cleanlooks
brainvisa -style Windows


BrainVISA will complain about the parameters but you can ignore this message.

To make this permanent for a user, you can use the following program :

/path-to-brainvisa-pack/bin/qtconfig -style Cleanlooks

You can choose any style you want except GTK+ and then save. The problem of this method is that the style will be applied to all Qt applications. We will have to find a way to make it permanent for BrainVISA application only...

sapetnioc
3rd July 2012, 05:02 PM
There is now a possibility to apply a patch to BrainVISA to make Qt blind to Gtk. See this post on BrainVISA forum (http://brainvisa.info/forum/viewtopic.php?f=2&t=1533#p6087).