PDA

View Full Version : XMMS playlist advance fail



rab3481
24th July 2011, 02:26 PM
I've recently upgraded to Fedora 15 after a failed Fedora 11-12 upgrade (luckily all my data is on a seperate drive!) and have been re-installing all the applications i had before. One strange problem i've come across is with XMMS. When it gets to the end of a song it wont move onto the next one. I've tried checking and unchecking the 'No Playlist Advance' option and it has made no difference. I tried changing the output from ALSA to OSS but that didn't even play the tracks so i switched back. Does anybody know what could have caused this?

thanks for any help,
RAB3481

mschwendt
24th July 2011, 09:16 PM
There's a test update in the updates-testing repository:
https://admin.fedoraproject.org/updates/xmms-1.2.11-15.20071117cvs.fc15

Ancient XMMS hasn't been anything like well-maintained in Fedora. Recently, Tom Callaway from Red Hat has taken over the package(s) to keep it alive some more. While at it, he has revisited several bug reports, too.

Alternatively, consider Audacious as long as it still features a similar WinAmp style interface:
http://mschwendt.fedorapeople.org/XMMS-vs-Audacious_Screenshot.png

Luke M
24th July 2011, 09:38 PM
qmmp is another winamp clone.

mschwendt
25th July 2011, 12:35 PM
Well, XMMS2 is also packaged for Fedora (yum search xmms), but I don't know whether it and any similar player is supposed to be a Winamp clone or if at some point in time had started as a fork of XMMS, BMP, and similar players and still offers a few similar features. Audacious, for example, is not supposed to be a Winamp clone and has changed too much since its early releases, too.

QMMP: It would benefit from some fresh Fedora package contributors with interest in this player. Latest release in Fedora is 0.4.3 from Nov 2010. Meanwhile there have been multiple releases up to 0.5.1 on 2011-05-20. Upstream Release Monitoring in Fedora bugzilla has reported all those versions to the packager, and also some users have expressed interest in the newer releases, but he's been waiting for a game console music emulator library to be packaged first.

Silvino
12th March 2012, 06:02 AM
The same problem with xmms-1.2.11-40.fc14. It was solved downgrading to xmms-1.2.11-15.20071117cvs.fc14, xmms-esd-1.2.11-15.20071117cvs.fc14, xmms-libs-1.2.11-15.20071117cvs.fc14.x86_64 and installing the removed package xmms-mp3-1.2.11-3.20071117cvs.fc11.