PDA

View Full Version : latest Mesa stuff messing up some OpenGL applications in F15 x86_64?



Maryyy
24th July 2011, 02:25 PM
Specifically, Mesa* libs version 7.11-0.16.20110709.0.fc15. At least on Nvidia with their binary drivers.
These are the only ones in the last update I got which I think could be a possible reason for this.

Affected apps so far that I found crashing (usually simply segfault): Penumbra series, Darwinia, Caster (64bit). So it doesn't seem to be arch dependant, as Caster is 64bit and crashes like Penumbra and Darwinina, but these are 32bit. Many others work just fine as they did, both 32 and 64bit.

Drivers used are RPMfusion ones, 275.09.07. I also tried 275.21 from the rpmfusion testing repo, same result.
Then I went directly with upstream 280.04 betas, same problem.

Maybe worth mentioning is, that it happens in Gnome3 with both, mutter (shell) and metacity (fallback) mode, as well as in pure Openbox.

I may try to downgrade all the Mesa* libs, but before I do that, I'll try to figure out if it can't be solved by keeping the updated ones. If anyone has a clue, it would be appreciated. :cool:


EDIT:
It gets more interesting. I downgraded Mesa, but no, still the same.

After seeing the output of Penumbra, that it can't open /usr/lib/alsa-lib/libasound_module_pcm_pulse.so, I started to be a bit nervous. This file was present, as it belongs to alsa-plugins-pulseaudio package. This package was installed since the initial system install (for both, 32 and 64bit), but only now it's causing this. Sure enough, uninstalling the package (both, 32 and 64bit) fixed the problem for Penumbra and for Darwinia, but not for Caster (which is 64bit). But there is a difference in the way Caster doesn't work. It no longer segfaults, but says it can't open libGL.so.1. Again, it's nonsense. All other apps can open it and work just fine and the proper symlink exists..
Just out of curiosity, I installed alsa-plugins-pulseaudio again, nope, same crashes with Penumbra and Darwinia, again, uninstalling it fixed the problem.

All that started happening after I did updates at 23.7.2011. Mainly just Mesa was there. Alsa-plugins-pulseaudio hasn't seen an update at all, yet it coused crashes with Penumbra and Darwinia, both of which were working normally before. Till this update batch..

I'm puzzled and tired, need to sleep.

Ihatewindows
28th November 2012, 07:43 PM
Still having the problem?