PDA

View Full Version : Acer Aspire 5734z intel graphic



effigy
22nd July 2011, 06:32 PM
i have looked at a few posts on this issue, but no luck. i have an Acer Aspire 5734z that i can not get to run gnome 3 in anything but fallback mode.

Graphics Card
Mobile Intel® GL40 Express Chipset with integrated 3D graphics, featuring Intel® Graphics Media Accelerator 4500M (Intel® GMA 4500M) with up to 1759 MB of Intel® Dynamic Video Memory Technology 5.0 (64 MB of dedicated system memory, up to 1695 MB of shared system memory), supporting Microsoft® DirectX® 10
Dual independent display support
16.7 million colors
External resolution / refresh rate6:

VGA port up to 2560 x 1600: 60 Hz

MPEG-2/DVD decoding
WMV9 (VC-1) and H.264 (AVC) decoding

i have tried editing the grub.conf file to remove the nomodeset, with no luck. still using the vesa driver,(which is also effecting "blender")

is there any way to get the full gnome 3 working?

effigy
28th July 2011, 03:05 PM
after much searching and surfing i found this bug report:

https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=712180

"W.H. Kalpa Pathum 2011-06-11 02:30:35 EDT

I followed the discussion[1] and added "acpi_osi=Linux" at the end of the
kernel line at boot up (without nomodeset). Initially the screen was dim. Then
I tried to change the brightness with my keyboard shortcuts. And it worked. But
there was still an issue. When I press brightness up shortcut the brightness
went down and when I press brightness down shortcut the brightness went up.
However I managed to make it visible. And the GNOME3 functionality is there.
It's no more fail safe mode.

Then I restarted without nomodeset and acpi_osi=Linux, and it works fine now.

What I suspect is that at boot up system tries to give the maximum brightness.
For me that is the minimum brightness (because keyboard shortcuts worked
completely the opposite way). Earlier when the screen was dim I tried to adjust
the brightness with keyboard shortcuts but didn't work. So acpi_osi=Linux has
done something. And now the systems functions well even without acpi_osi=Linux.
Now (without acpi_osi=Linux) I can't change the screen brightness with keyboard
shortcuts, the progress bar in the popup works but the brightness is not
adjusted.

I hope this will give you some clues to figure out where things went wrong and
I am happy provide you any information and see this bug fixed.

1 - http://www.fedoraforum.org/forum/showthread.php?t=247355

Thanks" .... quoted from comment 18

this worked for me now i am able to use the full gnome 3.