PDA

View Full Version : kmod-compat-wireless-2.6.39-1.fc15.1.x86_64 requires kernel-uname-r = 2.6.38.8-32.fc1



sepoto
21st July 2011, 12:12 AM
kmod-compat-wireless-2.6.39-1.fc15.1.x86_64 requires kernel-uname-r = 2.6.38.8-32.fc15.x86_64. I am installing this package in order to use my rtl8192se wireless card. Does anyone know how I can resolve this error for this .rpm?

This is my kernel version for f15:

/lib/modules/2.6.38.6-27.fc15.x86_64/build: No such file or directory.

and the above is the error I get when I try to compile the driver from source.

I have tried 'yum install kernel-devel' which is no help at all for my x86_64 setup.

Thank you,

---------- Post added at 11:12 PM ---------- Previous post was at 06:37 PM ----------

I think the key to all this was to do:

yum install kernel-devel
yum groupinstall development-tools

and most importantly do a restart and then compile the drivers from source. I think I missed the reboot part earlier. In any event my wireless card is working now.

rihays
11th September 2011, 06:14 AM
Hi there, may I know, where do you download the kmod-compat-wireless-2.6.39-1.fc15.1.x86_64 source , i can't find it.

sepoto
11th September 2011, 06:17 AM
I don't know exactly. If this is in regards to the Realtek wireless card I think it is 8192SE then your best bet is to find a distro that supports the card naively. Compiling the kernel can be a complex issue and is very distro specific as to what files and packages you need. There are distros available that support the card without doing anything at all.

rihays
11th September 2011, 06:27 AM
i mean the .rpm, where do you download it. or you install it via yum?

sepoto
11th September 2011, 06:29 AM
I am trying to find the answer to that question also. It was an issue that I could never resolve.

tox
11th September 2011, 06:48 AM
is this where you got it from? http://people.redhat.com/sgruszka/compat-wireless-next/F-15/

---------- Post added at 03:48 PM ---------- Previous post was at 03:45 PM ----------

do you have the RPMFusion repo's installed?