PDA

View Full Version : Virtualbox 4.1 release



kkshethin
20th July 2011, 08:08 AM
I have Fedora14. I have added virtualbox repository. On going through virtualbox.org site, i learned that virtualbox-4.1 released. I tired to update by yum update on 19.0.2011. No new package.
I tried to download it from virtualbox.org (VirtualBox-4.1 Fedora14-i386). It failed on 19.0.2011 giving message that link is not operational.

Today i.e. on 20.07.2011, i tired once again yum update. no new package. I tried to download from virtualbox.org. download succeed but it did not installed giving error message regarding conflicting files.

Till not in repository?

glennzo
20th July 2011, 08:24 AM
What error messages are you seeing? I've just added the VirtualBox repository and am able to download VirtualBox-4.1-i686. I've also downloaded the 32Bit and 64Bit versions from the VirtualBox web site. This was all done on a Fedora 14 system.



[glenn@f14v ~]$ yum list VirtualBox*
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit, rpm-warm-cache
Adding en_US to language list
Loading mirror speeds from cached hostfile
* fedora: mirrors.med.harvard.edu
* rpmfusion-free: mirror.liberty.edu
* rpmfusion-free-updates: mirror.liberty.edu
* rpmfusion-nonfree: mirror.liberty.edu
* rpmfusion-nonfree-updates: mirror.liberty.edu
* updates: mirrors.med.harvard.edu
Available Packages
VirtualBox-3.2.i686 3.2.12_68302_fedora14-1 virtualbox
VirtualBox-4.0.i686 4.0.12_72916_fedora14-1 virtualbox
VirtualBox-4.1.i686 4.1.0_73009_fedora14-1 virtualbox
VirtualBox-OSE.i686 4.0.2-2.fc14 rpmfusion-free-updates
VirtualBox-OSE-devel.i686 4.0.2-2.fc14 rpmfusion-free-updates
VirtualBox-OSE-guest.i686 4.0.2-2.fc14 rpmfusion-free-updates
VirtualBox-OSE-kmodsrc.i686 4.0.2-2.fc14 rpmfusion-free-updates

kkshethin
20th July 2011, 01:38 PM
[kksheth@Fedora ~]$ sudo yum update
Loaded plugins: fastestmirror, langpacks, local, presto, refresh-packagekit,
: remove-with-leaves
Adding en_US to language list
Loading mirror speeds from cached hostfile
* fedora: ftp.riken.jp
* rpmfusion-free: mirror.cse.iitk.ac.in
* rpmfusion-free-updates: mirror.cse.iitk.ac.in
* rpmfusion-nonfree: mirror.cse.iitk.ac.in
* rpmfusion-nonfree-updates: mirror.cse.iitk.ac.in
* updates: ftp.riken.jp
_local | 3.0 kB 00:00 ...
Setting up Update Process
No Packages marked for Update
[root@Fedora ~]#


[root@Fedora ~]# yum list VirtualBox*
Loaded plugins: fastestmirror, langpacks, local, presto, refresh-packagekit,
: remove-with-leaves
Adding en_US to language list
Loading mirror speeds from cached hostfile
* fedora: ftp.riken.jp
* rpmfusion-free: mirror.cse.iitk.ac.in
* rpmfusion-free-updates: mirror.cse.iitk.ac.in
* rpmfusion-nonfree: mirror.cse.iitk.ac.in
* rpmfusion-nonfree-updates: mirror.cse.iitk.ac.in
* updates: ftp.riken.jp
Installed Packages
VirtualBox-4.0.i686 4.0.12_72916_fedora14-1 @virtualbox
Available Packages
VirtualBox-3.2.i686 3.2.12_68302_fedora14-1 virtualbox
VirtualBox-4.1.i686 4.1.0_73009_fedora14-1 _local
VirtualBox-OSE.i686 4.0.2-2.fc14 rpmfusion-free-updates
VirtualBox-OSE-devel.i686 4.0.2-2.fc14 rpmfusion-free-updates
VirtualBox-OSE-guest.i686 4.0.2-2.fc14 rpmfusion-free-updates
VirtualBox-OSE-kmodsrc.i686 4.0.2-2.fc14 rpmfusion-free-updates
[root@Fedora ~]#

When i tried to install from local repo, i got same error message (which i got earlier when tried to install directly from virtualbox.org site)


Test Transaction Errors: file /etc/rc.d/init.d/vboxdrv from install of VirtualBox-4.1-4.1.0_73009_fedora14-1.i686 conflicts with file from package VirtualBox-4.0-4.0.12_72916_fedora14-1.i686
file /usr/lib/virtualbox/VBoxBalloonCtrl from install of VirtualBox-4.1-4.1.0_73009_fedora14-1.i686 conflicts with file from package VirtualBox-4.0-4.0.12_72916_fedora14-1.i686
file /usr/lib/virtualbox/VBoxHeadless from install of VirtualBox-4.1-4.1.0_73009_fedora14-1.i686 conflicts with file from package VirtualBox-4.0-4.0.12_72916_fedora14-1.i686
file /usr/lib/virtualbox/VBoxManage from install of VirtualBox-4.1-4.1.0_73009_fedora14-1.i686 conflicts with file from package VirtualBox-4.0-4.0.12_72916_fedora14-1.i686
file /usr/lib/virtualbox/VBoxSDL from install of VirtualBox-4.1-4.1.0_73009_fedora14-1.i686 conflicts with file from package VirtualBox-4.0-4.0.12_72916_fedora14-1.i686
file /usr/bin/VBoxTunctl from install of VirtualBox-4.1-4.1.0_73009_fedora14-1.i686 conflicts with file from package VirtualBox-4...

failed to install file: Test Transaction Errors: file /etc/rc.d/init.d/vboxdrv from install of VirtualBox-4.1-4.1.0_73009_fedora14-1.i686 conflicts with file from package VirtualBox-4.0-4.0.12_72916_fedora14-1.i686
file /usr/lib/virtualbox/VBoxBalloonCtrl from install of VirtualBox-4.1-4.1.0_73009_fedora14-1.i686 conflicts with file from package VirtualBox-4.0-4.0.12_72916_fedora14-1.i686
file /usr/lib/virtualbox/VBoxHeadless from install of VirtualBox-4.1-4.1.0_73009_fedora14-1.i686 conflicts with file from package VirtualBox-4.0-4.0.12_72916_fedora14-1.i686
file /usr/lib/virtualbox/VBoxManage from install of VirtualBox-4.1-4.1.0_73009_fedora14-1.i686 conflicts with file from package VirtualBox-4.0-4.0.12_72916_fedora14-1.i686
file /usr/lib/virtualbox/VBoxSDL from install of VirtualBox-4.1-4.1.0_73009_fedora14-1.i686 conflicts with file from package VirtualBox-4.0-4.0.12_72916_fedora14-1.i686
file /usr/bin/VBoxTunctl from install of VirtualBox-4.1-4.1.0_73009_fedora14-1.i686 conflicts with file from package VirtualBox-4...

---------- Post added at 06:08 PM ---------- Previous post was at 06:02 PM ----------

[root@Fedora ~]# yum install VirtualBox-4.1.i686
Loaded plugins: fastestmirror, langpacks, local, presto, refresh-packagekit,
: remove-with-leaves
Adding en_US to language list
Loading mirror speeds from cached hostfile
* fedora: ftp.riken.jp
* rpmfusion-free: mirror.cse.iitk.ac.in
* rpmfusion-free-updates: mirror.cse.iitk.ac.in
* rpmfusion-nonfree: mirror.cse.iitk.ac.in
* rpmfusion-nonfree-updates: mirror.cse.iitk.ac.in
* updates: ftp.riken.jp
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package VirtualBox-4.1.i686 0:4.1.0_73009_fedora14-1 set to be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ==============================
Package Arch Version Repository Size
================================================== ==============================
Installing:
VirtualBox-4.1 i686 4.1.0_73009_fedora14-1 _local 58 M

Transaction Summary
================================================== ==============================
Install 1 Package(s)

Total download size: 58 M
Installed size: 117 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
Processing delta metadata
Package(s) data still to download: 58 M
Running rpm_check_debug
Running Transaction Test


Transaction Check Error:
file /etc/rc.d/init.d/vboxdrv from install of VirtualBox-4.1-4.1.0_73009_fedora14-1.i686 conflicts with file from package VirtualBox-4.0-4.0.12_72916_fedora14-1.i686
.................................................. ........................
file /usr/share/virtualbox/src/vboxhost/vboxnetflt/linux/VBoxNetFlt-linux.c from install of VirtualBox-4.1-4.1.0_73009_fedora14-1.i686 conflicts with file from package VirtualBox-4.0-4.0.12_72916_fedora14-1.i686

Error Summary
-------------

[root@Fedora ~]#

soleilpqd
20th July 2011, 07:50 PM
I install vbox by downloading rpm from vbox website. I can only install new version when the older was removed.
I see in your output that the new vbox package is full rpm (not drpm) => try remove the old vbox first.

cambam247
20th July 2011, 08:26 PM
I installed it today here's the commands I used..

First you need to download the repository file for yum located at http://download.virtualbox.org/virtualbox/rpm/fedora/virtualbox.repo
Then you need to copy the repo file to yum depository folder

$sudo cp virtualbox.repo /etc/yum.repos.d/

Install dkms using the command

$sudo yum install dkms

To install the latest version of VirtualBox use the command

$sudo yum install virtualbox-4.0

Worked great for me just installed mint 11 and its working fine... GL

kkshethin
21st July 2011, 10:22 AM
I removed old version and installed new version. Surprisingly it automatically showed all vm's created. End of the story.