PDA

View Full Version : [SOLVED] Arista Transcoder Fedora 15



hanks
15th July 2011, 01:56 PM
Hi Folks,

New to the forums, long time linux nerd but haven't touched Fedora in years. Recently back to Fedora from a "stint" with Ubuntu and I am having a bit of an issue.

Anyone get Arista Transcoder to work with Fed15? Seems like a Gnome issue to me, basically the UI loads but when I try to create a job I get nothing, click the button and nada.

Any help would be great, even if it's "Does not work in Gnome Shell" just need confirmation.

Cheers,

Hank

HeWhoWatches
19th July 2011, 09:57 AM
I've followed the instructions here and they work for me:
http://www.fedoraforum.org/forum/showthread.php?t=261884

Generally I'll have all the gstreamer plugins installed plus ffmpeg and mplayer/encoder... I believe something like this will do all that:


yum install gstreamer-plugins-good gstreamer-plugins-bad gstreamer-plugins-bad-free gstreamer-plugins-ugly gstreamer-ffmpeg ffmpeg mplayer mencoder mplayer-gui gecko-mediaplayer

I use these when setting up a machine for the first time:
http://rpmfusion.org/RPM%20Fusion
http://www.mjmwired.net/resources/mjm-fedora-f15.html

So yep, using the instructions from the first link above, Arista works. Just converted a flash video to webm...

Good luck! :D

hanks
21st July 2011, 09:24 AM
Thanks for the response, but no-go.

It is quite bizarre, not a codec problem as I can run the cli version without issue. Simply this, open the GUI, click "Create Conversion" and nada... Nothing... Zip.

No dialog opens at that point so I am assuming this is a GTK/Python issue.

Cheers,

Hank

HeWhoWatches
21st July 2011, 01:23 PM
How strange... I've installed it on a 64-bit and 32-bit machine with no problems...

I tried /usr/bin/arista-gtk from the terminal, does not give a lot of output, just:

** Message: pygobject_register_sinkfunc is deprecated (GstObject)

Also tried running it through pydb (python debugger) but that was no help either.
Using lsof, determined that no additional files seem to be opened when the dialogue box for Create Conversion is opened...

I'll assume you downloaded the arista-0.9.7.tar.gz archive rather than from trunk (which is what I did - use the archive that is).

Perhaps there's a dependency missing?
I've run yum list py* and attached the output as text...

It's a long shot but you could compare against what you have installed and see if anything jumps out at you?

hanks
21st July 2011, 02:57 PM
Thanks for working with me on this.

Yes, downloaded 0.9.7 as apposed to getting it from git.

When I launch arista-gtk from cli I get the same "pygobject" message, but when I click the create conversion I get this:


dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Hal was not provided by any .service files

A bit of googling and this does not seem to be correct, according to the release notes Arista should not be depending on the Hal?

Cheers,

Hank

HeWhoWatches
21st July 2011, 03:53 PM
Interesting... what packages do you have installed when you do yum list *hal*?

hanks
21st July 2011, 04:32 PM
Interesting... what packages do you have installed when you do yum list *hal*?


hal-libs.i686 0.5.14-6.fc15 @anaconda-InstallationRepo-201105131946.i686
Available Packages
ghc-chalmers-lava2000.i686 1.1.1-11.fc15 fedora
ghc-chalmers-lava2000-devel.i686 1.1.1-11.fc15 fedora
ghc-chalmers-lava2000-prof.i686 1.1.1-11.fc15 fedora
hal.i686 0.5.14-6.fc15 fedora
hal-devel.i686 0.5.14-6.fc15 fedora
hal-docs.i686 0.5.14-6.fc15 fedora
hal-filesystem.i686 0.5.14-6.fc15 fedora
hal-info.noarch 20090716-4.fc15 fedora
hal-storage-addon.i686 0.5.14-6.fc15 fedora
halberd.noarch 0.2.3-3.fc15 fedora
halevt.i686 0.1.6.2-4.fc15 fedora
halibut.i686 1.0-2.20100504svn8934.fc14 fedora
libmtp-hal.i686 1.0.6-3.fc15 updates
ns-tiza-chalk-fonts.noarch 20080210-3.fc15 fedora
nut-hal.i686 2.6.1-1.fc15 updates
synce-hal.i686 0.15-2.fc15 fedora
vim-halibut.noarch 1.0-2.20100504svn8934.fc14 fedora

Some obviously not relevant but I have no idea where to start!

Thanks for the help!

Hank

HeWhoWatches
21st July 2011, 06:19 PM
Please can you try this:


yum install hal-filesystem hal-info hal-libs hal-storage-addon

...and try again?

hanks
22nd July 2011, 12:30 PM
Please can you try this:


yum install hal-filesystem hal-info hal-libs hal-storage-addon

...and try again?

That did it!

Thanks a bunch. Going to take me a while to get used to Fedora again but I am committed to it.

I owe you a beer.

Hank

HeWhoWatches
12th December 2011, 10:10 PM
Funny how these things happen, I was trying to install Arista in Fedora 16 and had the same problem you had - of course, HAL has been removed in F16. So, I found the answer here:
https://github.com/danielgtaylor/arista/issues/80

"If you have python-gudev installed it will use udev rather than dbus/HAL for device discovery. HAL support is left in for older distros that don't have udev yet!"

So, to fix, we do the following as root:

yum install python-gudev

...then it works!
:doh:

Aaoii
26th February 2012, 09:06 PM
thank you the problem solved with me again , I almost lost hope ... thank you fedora forums :)

Valent
5th April 2012, 10:52 AM
This also works for me on Fedora 16, thanks! Just installed python-gudev and now it works. Cheers!

Kaiteybuggish
19th May 2012, 09:57 AM
I tried that with mine in terminal and it didn't work