PDA

View Full Version : PHP5.3.6 cross compiling problem in fc15



yangfanko
16th June 2011, 08:04 PM
i came about a problem -----cross compling php5.3.6 for arm-linux on fc15
i follow the tutorial from the internet,
i create a file yf_ins.sh
-----------------------------------------
#!/bin/bash
Dir=/usr/local/arm/4.3.2
export AR=$Dir/bin/arm-linux-ar
export CC=$Dir/bin/arm-linux-gcc
export LD=$Dir/bin/arm-linux-ld
export STRIP=$Dir/bin/arm-linux-strip
export NM=$Dir/bin/arm-linux-nm
export RANLIB=$Dir/bin/arm-linux-ranlib
export CC_FOR_BUILD=gcc
./configure --host=arm-linux --target=arm
make
-------------------------------------------------------
but when beginning compiling the compiler is gcc
rather than arm-linux-gcc (i prefer)

how to do ???

best regards

---------- Post added at 07:04 PM ---------- Previous post was at 06:06 PM ----------

after several hours trying-on-other linux ubuntu9.10

in the same way.

i solve the problem.

why ?????

the kernel version?