PDA

View Full Version : F15 Unable to play AAC files.. all plugins loaded



amyloid
15th June 2011, 11:11 PM
Folks, I would appreciate some help here...

Recently upgraded to F15 and now unable to play AAC files. All recommended gstreamer-plugins have been added from the RPMFusion repositories as you can see below..

[xxx@Demon ~]$ rpm -qa | grep gstreamer-plugin*
gstreamer-plugins-bad-0.10.21-3.fc15.x86_64
gstreamer-plugins-base-tools-0.10.33-1.fc15.x86_64
gstreamer-plugins-ugly-0.10.18-1.fc15.x86_64
PackageKit-gstreamer-plugin-0.6.15-1.fc15.x86_64
gstreamer-plugins-base-0.10.33-1.fc15.x86_64
gstreamer-plugins-good-0.10.29-1.fc15.x86_64
gstreamer-plugins-espeak-0.3.3-3.fc15.x86_64
gstreamer-plugins-bad-nonfree-0.10.21-2.fc15.x86_64
gstreamer-plugins-bad-free-0.10.22-1.fc15.x86_64
gstreamer-plugins-bad-free-extras-0.10.22-1.fc15.x86_64
gstreamer-plugins-fc-0.2-2.fc15.x86_64
[xxx@Demon ~]$

Tried various player (Amarok, Banshee, Rhythmbox) and none can find the MPEG-4 AAC plugin.
Tried xmms and it can play the AAC files

Tried removing the music player and re-installing them...no change
Tried removing the plugins and reinstalling them...no change. Error message from all players is generally the same: Following plugin is required: MPEG-4 AAC demuxer". When asked to search for it, none of the players can find it.

Could this be a problem with the path to the plugin files?

I would appreciate suggestions.

Thank you!

HeWhoWatches
15th June 2011, 11:36 PM
I wonder if faad2 might work?

http://download1.rpmfusion.org/free/fedora/releases/15/Everything/i386/os/repoview/faad2.html

Says it's an AAC MP4 decoder, gotta be worth a go :)

Also noted an encoder here:

http://download1.rpmfusion.org/nonfree/fedora/releases/15/Everything/i386/os/repoview/faac.html

Good luck!

amyloid
16th June 2011, 12:44 AM
Thanks...I forgot to add that I had already included faad2 as seen below...

[xxxd@Demon ~]$ rpm -qa | grep faad*
xmms2-faad-0.7-1.fc14.x86_64
faad2-libs-2.7-1.fc11.x86_64
faac-1.28-2.fc12.x86_64
xmms-faad2-2.7-1.fc11.x86_64
faac-1.28-2.fc12.i686
faad2-libs-2.7-1.fc11.i586
faad2-2.7-1.fc11.x86_64
[xxx@Demon ~]$

I also have faac included as well...

[xxx@Demon ~]$ rpm -qa | grep faac
faac-1.28-2.fc12.x86_64
faac-1.28-2.fc12.i686

Still does not seem to work...but I appreciate the suggestion!!

HeWhoWatches
16th June 2011, 12:59 AM
Hmmm... okay... on this bug report:
https://bugzilla.redhat.com/show_bug.cgi?id=675429

...the person who logged the bug used the syntax below to get some further command line output:


gst-launch-0.10 playbin2 uri=file:/home/thomas/Musik/Fanboys/FAN005.m4a

I wonder if you could try a file using the same syntax in case there's anything that screams out what the problem is...

Worth a shot I guess ;)

---------- Post added at 12:59 AM ---------- Previous post was at 12:51 AM ----------

Also, is gstreamer-ffmpeg installed?

amyloid
16th June 2011, 04:26 AM
Thanks again... trying to see if the updates on the rawhide repos make difference based on the bug report you sent me.
Yes..gstreamer-ffmpeg is also installed.
I will try the CLI command you sent to see if that generates some output that helps..

:)

---------- Post added at 11:26 PM ---------- Previous post was at 11:07 PM ----------

Solved!!

The solution was as follows:

1) Remove the gstreamer-plugins installed via RPMFusion for F15
2) Add the rawhide repos
3) Add the updated packages via 'yum install gstreamer-plugins*'
4) test on previously unplayable files

It appears there is a problem with the plugins under F15.

ebarcikowski
1st November 2011, 06:03 AM
I have this same problem with AAC files on two systems, bot were just recently moved both to Fedora 15. I also have all the gstreamer-plugins, but can't play m4a files. I've erase all the plugins and reinstalled them, but that hasn't helped.

I'm not totally sure that I understand the previous post, you added only the rawhide rpmfusion repos or you moved all the repos to rawhide? I suppose, I'll try that myself, but I'm worried about the rawhide repositories conflicting with the Fedora 15 ones.

Elliott

---------- Post added at 10:53 PM ---------- Previous post was at 07:01 PM ----------

If anyone's interested, here's the output of gst-launch...


[elliottb@notch ~]$ gst-launch playbin uri=file:///home/elliottb/Media/Music/Abigail\ Washburn\ \&\ The\ Sparrow\ Quartet/Abigail\ Washburn\ \&\ The\ Sparrow\ Quartet/01\ Overture.m4a
Setting pipeline to PAUSED ...
** Message: don't know how to handle audio/x-m4a
Pipeline is PREROLLING ...
ERROR: from element /GstPlayBin:playbin0/GstDecodeBin:decodebin0: A MPEG-4 AAC demuxer plugin is required to play this stream, but not installed.
Additional debug info:
gstdecodebin.c(997): close_pad_link (): /GstPlayBin:playbin0/GstDecodeBin:decodebin0:
No decoder to handle media type 'audio/x-m4a'
ERROR: pipeline doesn't want to preroll.
Setting pipeline to NULL ...
Freeing pipeline ...


Also, gst-inspect does seem to have a "m4a" line, but I don't really understand the output of this command.


typefindfunctions: application/x-3gp: 3gp
typefindfunctions: audio/x-m4a: m4a
typefindfunctions: video/x-nuv: nuv


---------- Post added at 11:03 PM ---------- Previous post was at 10:53 PM ----------

Hi all,

I actually found a solution to my problem in this thread:

thread (http://forums.fedoraforum.org/showthread.php?p=1522863#post1522863)

Basically, remove the file: $HOME/.gstreamer-0.10/registry.x89_64.bin

Solved...

Elliott

themarkg
18th February 2012, 12:57 AM
---------- Post added at 11:03 PM ---------- Previous post was at 10:53 PM ----------

...
Basically, remove the file: $HOME/.gstreamer-0.10/registry.x89_64.bin

Solved...

Elliott

Thanks Elliot this helped me on an install of FC16. Not sure if I was missing something originally, or my copied home dir had something outdated. I deleted the .gstreamer* dir and was back in business.

Mark