View Full Version : Samsung/Splix printer no longer works after F14-F15 upgrade

15th June 2011, 02:45 PM
I have a Samsung CLP-500, which was working using the Splix driver under F14.

I upgraded to F15 and now it doesn't print. Cups has an error message:

E [15/Jun/2011:13:56:49 +0100] [Job 189] SpliX Cannot open CMS file /opt/OpenPrinting-SpliX/ppds/samsung/cms/CLP-500cms (2)
E [15/Jun/2011:13:56:49 +0100] [Job 189] SpliX Cannot open CMS file /opt/OpenPrinting-SpliX/ppds/samsung/cms/CLP-500cms2 (2)
W [15/Jun/2011:13:56:49 +0100] [Job 189] SpliX CMS data are missing. Color correction aborted
E [15/Jun/2011:13:56:49 +0100] [Job 189] SpliX Cannot execute pstoraster (2)
E [15/Jun/2011:13:56:49 +0100] [Job 189] SpliX Cannot get input slot information.
E [15/Jun/2011:13:56:49 +0100] [Job 189] SpliX Cannot open job
E [15/Jun/2011:13:56:49 +0100] [Job 189] SpliX Error while rendering the request. Check the previous message

SELinux is in permissive mode.

Any ideas what the problem might be? What has changed F14-15 that might cause this?


---------- Post added at 05:45 AM ---------- Previous post was at 05:09 AM ----------

More info:

Splix has a file pstoraster that is a symlink to /usr/lib/cups/filters/pstoraster

However /usr/lib/cups/filters/pstoraster doesn't exist on my F15 system.

As i understand, pstoraster is a shell script that call's ghostscript. I have ghostscript installed, so why wouldn't pstoraster be included?

yum whatprovides */pstoraster

doesn't give any output.

Is this likely to be something to do with it? Or am I barking up the wrong tree?


---------- Post added at 05:45 AM ---------- Previous post was at 05:09 AM ----------

Ok, sorted it:

According to the ghostscript changelog (http://www.ghostscript.com/doc/current/History9.htm) the *toraster commands were replaced by one binary gstoraster.

so solved by symlinking the splix pstoraster to gstoraster:

cd /usr/lib/cups/filter
ln -s gstoraster pstoraster

Printer works fine now, but MAN that was a waste of a few hours.

HTH someone else!

11th May 2012, 11:19 AM
Hi M,

Your solution worked for me too - so thank you for posting it.

I too had a Samsung, and I was using SpliX. No problem with the older Fedora, but on upgrading to FC16 I just could not print.

Only when I googled:

SpliX Cannot open CMS file /opt/OpenPrinting-SpliX/ppds/samsung/cms/CLP-500cms (2)

I found your post, and hey presto it worked.

Thanks :)