PDA

View Full Version : autostart nbm. Bug or im doin something wrong?



Benzin
11th June 2011, 08:59 PM
what is the proper way to make the smb and nmb services start (and keep runing) automatically?

I have successfully configured samba on my F15 box, but sometimes the other boxes cant see it. i check the status of smb and nmb and smb is running and active, but nmb status is "Running (exited)"
if i manually restart nmb then nmb status changes to "Running (active)" and the problem goes away. However i want it to start (and keep running) automatically as it should.

Im thinking maybe the problem is the way i set smb and nmb to start automatically. I used
$chkconfig smb on
and
$chkconfig nmb on
Is this the correct way? if not, what is it? maybe i need to be more specific about at wich runlevels i want the services to start?
I have googled, but found about 5 diferent methods to make this services start automatically, some with systemctrl, some editing files, chkconfig, and even the system-config-services app (wich seems broken in f15 btw) and dont know wich one to use.

il appreciate any help

Benzin
2nd July 2011, 08:05 AM
Still having this problem, nmb dies.
Anyone else having it? Any ideas of how i can fix it?
thanks.

Chilly Willy
2nd July 2011, 10:04 AM
I had a problem with NMB not starting in F14 (IIRC) & found that if I right clicked on the network icon (by the clock - gnome) & clicked edit connections, then clicked on the name under the wired tab, then edit & made sure that "available to all users" was checked then NMB would start as it should. Otherwise it would fail at boot & I had to start it manually. Not sure if this is what you are trying to say or not.

Also, not sure how much this may help YOU, but worth a check... (if what I THINK you are experiencing is correct)

Benzin
2nd July 2011, 11:33 AM
Thank you for your reply :)
when i login and i check the status of nmb i get this...

[root@enetbook ~]# systemctl status nmb.service
nmb.service - SYSV: Starts and stops the Samba smbd and nmbd daemons used to provide SMB network services.
Loaded: loaded (/etc/rc.d/init.d/nmb)
Active: active (exited) since Sat, 02 Jul 2011 05:19:54 -0500; 12min ago
Process: 989 ExecStart=/etc/rc.d/init.d/nmb start (code=exited, status=0/SUCCESS)
Main PID: 1007 (code=exited, status=1/FAILURE)
CGroup: name=systemd:/system/nmb.service

i will try your tip and report back here
thanks

EDIT: just checked it, the "enable for all users is checked" :(
man i really gotta get this fixed, i like fedora, but if i dont find a way to fix it, im gonna have to find another distro. it is IMPERATIVE for me to have a fully working samba server as soon as i login

Chilly Willy
2nd July 2011, 04:36 PM
Try looking at this:
http://forums.fedoraforum.org/showthread.php?t=259051&highlight=samba

Maybe it will have some info that will help.

Benzin
2nd July 2011, 08:57 PM
Hi Willy, i found something that seems to be working...
i ran systemctl enable network.service
restarted, and now systemctl status nmb.service reports Active (running) :)

Man, this is not a "small glitch" and for what ibe read, its not a new issue either, it goes back several versions.
I would assume that a distro with so much "prestige" and popularity would actually ADRESS such an important BUG, yes, BUG because every other distro ibe tried (and ibe tried all major ones) does its job and configures ITSELF so that it doesnt require a week of investigation just to get a BASIC service running.

Even tho this issue seems fixed (i hope it stays fix), i fear of what other "small issues" i might in the future.
im actually considering finding another distribution.
Not to mention that about "comunity support", this post is almost a month old,and you were the only person kind enough to try to help me.

Thanks willy, ill do some more testing in this issue, and let you know if the problem was really fixed.

Chilly Willy
3rd July 2011, 01:10 AM
Well don't feel bad with the site if you don't get help, sometimes others here just don't know & it 's usually better to say nothing then to "guess" & REALLY mess things up. If I hadn't at least had THIS experience with it, I probably would have passed on responding also.

As for distros, I too, have tried a lot & I kept coming back to Fedora. I also had to learn about 6 TOTALLY DIFFERENT OS's in my computer lifetime so I'm quite familiar with quirks of OS's & I can honestly say that I find Fedora to be one with the least. But that is MY opinion. & one has to choose what feels right for them (usually based on there own needs) I pretty much look at Fedora as a "late beta" or a "release candidate" & that pretty much puts things in a proper perspective, as it IS somewhat that for RED HAT.

Hope you get your problem fixed (if not already) I recall how much of a PITA that was for me as I'd get to the M$ machine & go to do something & remember I had to manually start the samba thing & have to stop what I was doing, go to my linux box & then back to the M$ box & then TRY TO REMEMBER what it was I was doing. (& I have medical problems with my memory as it is)

Benzin
3rd July 2011, 02:01 AM
Hello again, apparently the fix i mentioned (systemctl enable network) worked!
After i ran that command, i tested by rebooting the pc several times, and now smb status is allways...

[root@enetbook ~]# systemctl status nmb.service
nmb.service - SYSV: Starts and stops the Samba smbd and nmbd daemons used to provide SMB network services.
Loaded: loaded (/etc/rc.d/init.d/nmb)
Active: active (running) since Sat, 02 Jul 2011 19:52:55 -0500; 5min ago
Process: 1297 ExecStart=/etc/rc.d/init.d/nmb start (code=exited, status=0/SUCCESS)
Main PID: 1315 (nmbd)
CGroup: name=systemd:/system/nmb.service
└ 1315 nmbd -D

seems nmb is starting and keeping up ok now :)

thanks willy! :)

Chilly Willy
3rd July 2011, 02:41 AM
I DID forget about the problem with NETWORK MANAGER & this issue - I was told to switch to network (something or other - most likely what you did) & that would fix my problem, well I had reasons for wanting to stick with NM. But in the end, it looks like we BOTH got what we wanted, which is what LINUX is all about!

:dance: :D

Benzin
3rd July 2011, 03:12 AM
i need network manager too, cause its a laptop, the nice thing is that network manager continues to work as usual!
i can still use the network manager applet to connect to wifi, etc.

You know, a friend of mine has opensuse 11.4 installed in all his boxes, and he speaks wonders of opensuse. I think ill give it a try :)