PDA

View Full Version : Gnome multimedia problem



gizenshu
10th June 2011, 09:33 PM
While working fine in KDE, multimedia settings don't work in Gnome.

When I go to System/Preferences/Sound it pops up dialogue box after a while:


Waiting for sound system to respond
Cancel

SharpyWarpy
10th June 2011, 11:58 PM
Pardon me if I missed it but what version of Fedora are you using?

gizenshu
12th June 2011, 03:49 PM
if you have any ideas go ahead. F14

SharpyWarpy
12th June 2011, 07:16 PM
Do you have pulseaudio installed? I always remove that if it is installed. Open a terminal and type
rpm -qa|grep pulseaudio
If you see it there then do
yum remove pulseaudio
Then type this
alsamixer
and hit the F6 key to see what audio card your system is using. If you get "command not found" then install alsamixer with
yum install alsamixer
Do this too:
lspci
and give us the output of that. It will tell us more about your sound card.

gizenshu
13th June 2011, 04:19 PM
Same here - PA removed first thing.

$lspci|grep Creat
04:06.0 Multimedia audio controller: Creative Labs SB Audigy (rev 04)
$ lsmod|sort|grep snd
ac97_bus 1086 1 snd_ac97_codec
snd 56887 14 snd_emu10k1_synth,snd_emux_synth,snd_seq_virmidi,s nd_seq_midi_emul,snd_emu10k1,snd_rawmidi,snd_ac97_ codec,snd_seq,snd_pcm,snd_seq_device,snd_timer,snd _hwdep
snd_ac97_codec 110416 1 snd_emu10k1
snd_emu10k1 141552 2 snd_emu10k1_synth
snd_emu10k1_synth 6000 0
snd_emux_synth 36091 1 snd_emu10k1_synth
snd_hwdep 5926 2 snd_emux_synth,snd_emu10k1
snd_page_alloc 6905 2 snd_emu10k1,snd_pcm
snd_pcm 76211 2 snd_emu10k1,snd_ac97_codec
snd_rawmidi 19014 2 snd_seq_virmidi,snd_emu10k1
snd_seq 52132 4 snd_emux_synth,snd_seq_virmidi,snd_seq_midi_event, snd_seq_midi_emul
snd_seq_device 5149 5 snd_emu10k1_synth,snd_emux_synth,snd_emu10k1,snd_r awmidi,snd_seq
snd_seq_midi_emul 5760 1 snd_emux_synth
snd_seq_midi_event 5220 1 snd_seq_virmidi
snd_seq_virmidi 4196 1 snd_emux_synth
snd_timer 19017 3 snd_emu10k1,snd_seq,snd_pcm
snd_util_mem 2240 2 snd_emux_synth,snd_emu10k1
soundcore 5425 1 snd
$ modinfo snd_emu10k1
filename: /lib/modules/2.6.35.13/kernel/sound/pci/emu10k1/snd-emu10k1.ko
license: GPL
description: EMU10K1
author: Jaroslav Kysela <perex@perex.cz>
firmware: emu/emu1010_notebook.fw
firmware: emu/emu0404.fw
firmware: emu/micro_dock.fw
firmware: emu/emu1010b.fw
firmware: emu/audio_dock.fw
firmware: emu/hana.fw
srcversion: 7DF3CA9C8FBE8F5AB73F53A
alias: pci:v00001102d00000008sv*sd*bc*sc*i*
alias: pci:v00001102d00000004sv*sd*bc*sc*i*
alias: pci:v00001102d00000002sv*sd*bc*sc*i*
depends: snd-pcm,snd,snd-ac97-codec,snd-util-mem,snd-page-alloc,snd-rawmidi,snd-timer,snd-hwdep,snd-seq-device
vermagic: 2.6.35.13 SMP preempt mod_unload
parm: high_res_gpr_volume:GPR mixer controls use 31-bit range. (bool)
parm: index:Index value for the EMU10K1 soundcard. (array of int)
parm: id:ID string for the EMU10K1 soundcard. (array of charp)
parm: enable:Enable the EMU10K1 soundcard. (array of bool)
parm: extin:Available external inputs for FX8010. Zero=default. (array of int)
parm: extout:Available external outputs for FX8010. Zero=default. (array of int)
parm: seq_ports:Allocated sequencer ports for internal synthesizer. (array of int)
parm: max_synth_voices:Maximum number of voices for WaveTable. (array of int)
parm: max_buffer_size:Maximum sample buffer size in MB. (array of int)
parm: enable_ir:Enable IR. (array of bool)
parm: subsystem:Force card subsystem model. (array of uint)
parm: delay_pcm_irq:Delay PCM interrupt by specified number of samples (default 0). (array of uint)

gizenshu
15th June 2011, 07:16 PM
Why have you asked for information if you were not going to reply?

SharpyWarpy
15th June 2011, 07:29 PM
Why have you asked for information if you were not going to reply?

Fact is my ISP is in the process of updating the mail server and my emails have been arriving late.
That being said since you are rather rude I choose not to respond any further.

gizenshu
16th June 2011, 12:25 AM
I think you just have no clue, that's why you made up 'rudeness' where there was none.
There are many armchair quarterbacks on this forum, I just came across another one.

HeWhoWatches
16th June 2011, 12:35 AM
Removing pulseaudio can cause that error message.
See: http://www.fedoraforum.org/forum/showthread.php?t=232125

In particular:

Probably because you uninstalled the default sound system.

If you reinstall pulseaudio, does that message stop appearing?

SharpyWarpy
16th June 2011, 03:48 AM
I think you just have no clue, that's why you made up 'rudeness' where there was none.
There are many armchair quarterbacks on this forum, I just came across another one.

Well now, aren't you a bright one. It would appear that you have just proved my point concerning your rudeness. And you will do well to stop critizizing this forum if you expect to get any reliable help. Obiously you have not researched my profile or you would know I have contributed much. I've been here a lot longer than you and I've seen some rude people but you sir, are insufferable.

gizenshu
16th June 2011, 02:53 PM
Removing pulseaudio can cause that error message.
See: http://www.fedoraforum.org/forum/showthread.php?t=232125

In particular:


If you reinstall pulseaudio, does that message stop appearing?

Pulse Audio breaks a lot of functionality handled by ALSA perfectly well.
PA is a monstrosity, designed for god knows what and absolutely unnecessary on the low-latency workstations used for audio work, as in my labs, due to horrible latency and countless issues which are impossible to resolve due to uncooperative and incompetent developers, who do nothing but push their agenda.
Thus PA is always removed from our workstations first thing and will never be re-installed.
We don't care if it would fix Gnome issue or not. Worst case scenario, users will log into KDE, manage audio settings and switch back into Gnome.
I can imagine that there are lots of Linux users who have all time in the world for experimenting, signing up for dozens of support web sites, begging for help on their knees, but I don't.

So to re-cap, if Gnome can't manage audio settings w/o PA, it badly reflects on Gnome


but you sir, are insufferable.

You've just set rudeness threshold too low for participating in the internet forums. But your credentials are impressive, yeah.

GallComp
17th June 2011, 04:36 AM
I think you just have no clue, that's why you made up 'rudeness' where there was none.
There are many armchair quarterbacks on this forum, I just came across another one.




You've just set rudeness threshold too low for participating in the internet forums. But your credentials are impressive, yeah.

Please read the forum guidelines before you post again. No one here is getting paid for their time and effort, so don't patronize our members.

http://www.fedoraforum.org/?view=guide

Here are some of the points that apply to your behavior on this thread.


Do Not be Abusive
Abuse doesn't get you anywhere. It generates bad feelings and is very likely to get you suspended from the forum. We're here to help each other not fight.


Be polite. This is a user forum and we all do this as a hobby, in our free time. Please and thank you can get you a long way.


Details, details, details! Don't be brief. Include your Fedora version number, the architecture of your computer (i.e. AMD 64 or a Quad-Core, or in the case of video cards NVIDIA model or ATI model), the version of the component you're having trouble with and everything you think might help. If you're using 3rd party RPMs explain where you got them from. Attach screen shots or other files if you think it might be useful.

This is just a friendly warning.

gizenshu
17th June 2011, 06:32 PM
Well, Mr. sensitive soul accused me of being rude after writing this:


Why have you asked for information if you were not going to reply?

Why don't you go after him for stirring the pot?

Dan
17th June 2011, 06:39 PM
Free advice:

Drop it. Now.

HeWhoWatches
17th June 2011, 06:57 PM
http://fedoraunity.org/Members/fenris02/pulseaudio-fixes-and-workarounds

Suggests the following, though looks to be based on Fedora 12:



To really remove PulseAudio for some reason:

See https://fedoraproject.org/wiki/How_to_debug_PulseAudio_problems
Remove PulseAudio and all of it's dependencies:


su -c "yum remove alsa-plugins-pulseaudio pulseaudio padevchooser pavumeter paprefs pavucontrol"

Create a file ~/.asoundrc with these contents:


# For details, see http://www.alsa-project.org/main/index.php/Asoundrc
pcm.!default {
type plug
slave.pcm "dmixer"
}

# cat /proc/asound/cards to see which hardware device
pcm.dmixer {
type dmix
ipc_key 1024
slave {
pcm "hw:0,0"
period_time 0
period_size 1024
buffer_size 4096
rate 44100
}
bindings {
0 0
1 1
}
}

ctl.dmixer {
type hw
card 0
}

Logout or reboot.

File a bug report under "Fedora 12" and "PulseAudio" to explain the problems you were having and how this helped: https://bugzilla.redhat.com/

gizenshu
5th August 2011, 06:32 PM
HWW,

So if cat /proc/asound/cards returns

0 [Audigy2 ]: Audigy2 - SB Audigy 2 Platinum [SB0240P]
SB Audigy 2 Platinum [SB0240P] (rev.4, serial:0x10021102) at 0xbf00, irq 20

then

pcm "hw:0,0"

is the correct line, am I getting it right?
Well, the 1st part of your post was already done, yum did not find any of the mentioned packages to remove.
After creating ~/.asoundrc and rebooting I still get

Waiting for sound system to respond
Cancel

gizenshu
8th August 2011, 06:12 PM
After more testing I can confirm that creation of ~/.asoundrc as per above only changed one thing in this system: there was no sound in VirtualBOX machines and deleting ~/.asoundrc w/o reboot fixed the problem.