PDA

View Full Version : [SOLVED] no hdmi sound on fedora 15



MrErr
7th June 2011, 01:44 PM
Well almost no sound. The only way to get sound out is if i use the following command
speaker-test -D plughw:0,7 -c 2 /dev/urandom

I have the following line in /etc/pulse/default.pa
load-module module-alsa-sink device=plughw:0,7

But when i play any applications i hear no sound. For example "mplayer zion.mp3" results in silence.

When using pavucontrol, i see the sound bar moving for the hdmi hardware device. But i still hear nothing.

Does anyone know what could be wrong?

---------- Post added 7th June 2011 at 07:44 AM ---------- Previous post was 6th June 2011 at 09:37 PM ----------

I found my problem. The line "load-module module-alsa-sink device=plughw:0,7" was the last line in the file "/etc/pulse/default.pa". When i moved it to the correct section of that file, sound started to work.

livelong
30th July 2011, 03:51 PM
Well almost no sound. The only way to get sound out is if i use the following command
speaker-test -D plughw:0,7 -c 2 /dev/urandom

I have the following line in /etc/pulse/default.pa
load-module module-alsa-sink device=plughw:0,7

But when i play any applications i hear no sound. For example "mplayer zion.mp3" results in silence.

When using pavucontrol, i see the sound bar moving for the hdmi hardware device. But i still hear nothing.

Does anyone know what could be wrong?

---------- Post added 7th June 2011 at 07:44 AM ---------- Previous post was 6th June 2011 at 09:37 PM ----------

I found my problem. The line "load-module module-alsa-sink device=plughw:0,7" was the last line in the file "/etc/pulse/default.pa". When i moved it to the correct section of that file, sound started to work.

http://forums.nvidia.com/index.php?showtopic=192042
This worked for me. On line 45 mine was: load-module module-alsa-source device=hw:1,0(So, I switched it to 0,1 and my hdmi sound was working of course before setting my sound output to HDMI.) hope this helps.