View Full Version : Win XP Fedora Dual boot...

27th May 2004, 02:19 PM
Im trying to get this dul boot going and have installed as follows:
First Partition WINXP ~7gb
Second Partition Fedora ~10gb
Third Partition Shared ~60gb

WinXP was instaled correctly and boots fine. Fedora installs correctly but requires you to reboot before I could get into the system and get the location of the Linux boot sector. (I have dual booted this machine before with Win2k and mandrake and have done this successfully.) Any sugestions on how I can accomplish this? I tried to run the rescue disc from Fedora, as well as run the rescue feature from CD1, however this mounts the existing installation in a different location and does not give me the correct location for the boot sector. A boot floppy would be great but no Idea on how to make one for this. Thanks in advance.

27th May 2004, 06:52 PM
Are you looking for the /boot partition setup by Fedora? Is this where you wrote your bootloader to at install time?

If so, boot from the FC2 rescue disk and you'll have your system mounted at /mnt/sysimage. Following from this, your /boot partition should be at /mnt/sysimage/boot ..

If you want to copy your Linux bootsector to a file (to use with XP's bootloader, for example) - boot with the rescue disk and use..

chroot /mnt/sysimage
dd if=/dev/hda2 of=/bootsect.lnx bs=512 count=1

(Assuming your Fedora install created 3 partitions as standard - for /boot,/ and swap. Therefore assuming /boot is at /hda2 - adjust as appropriate)

Now you can copy bootsect.lnx to your XP C:\ drive and add the following to your C:\boot.ini

C:\bootsect.lnx="Fedora Core 2"

Now when you reboot, XP's bootloader will give you the choice to load FC2. Hopefully this is what you were asking, or I just wasted 5 minutes :)

28th May 2004, 03:31 PM
thanks for your post. Ya thats exactly what I have been doing and it doesnt seem to work. It appears that for whatever reason the location of the boot sector is not making it into the bootsect.lnx file. I even went so far as to pupposflly re-install and re-partition my drives all over again. Im at a loss.....

28th May 2004, 05:45 PM
shouldn't it be somthing like:

multi(0)disk(0)rdisk(0)partition(2)\bootsect.lnx="Fedora Core 2"


28th May 2004, 08:40 PM
How it is described above is EXACTLY how i managed to get win2K and Mandrake on the same machine. It seems to me that the location of the boot sector when you load fedora from the rescue disk is where the problem lies.

28th May 2004, 08:50 PM
I researched more, and you can use the C:\ reference... it refers to it as 'how to make a dos partition work'... I'd reckon that it points to the first partition of the first physical drive.

so... perhaps it requires that the first partition be FAT (maybe FAT32) to use the C:\ reference... if the first partition is NTFS, maybe it breaks...


31st May 2004, 08:12 PM
I had a similar problem, got the "GRUB" message when I tried to select
the LINUX partition.

I did several things at this point:
Booted under "linux rescue" (use this on the boot prompt); this eventually
dumps you into a root shell.
Did an "fdisk /dev/hda"
Verified that the LINUX partition had the "active boot flag" set (I *think* that's the terminology).
Double-checked the "grub/grub.conf" file.

Good luck. Let me know if this helps out (did for me).

Charlie (aka "CyberchuckTX")

2nd June 2004, 04:06 AM
I apprecitae all of your help. Still having a bit of trouble. I tried going through the fdisk routine setting the linux partition as boot and I ended up with an error on boot. Something to the effect of re-boot or enter a bootable disk. I used the rescue disk to reset the bootable sector to 1 (windows) and it booted fine. I then went in and looked at my grub.conf. I think I should have said earlier that I am using windows as my bootloader and not grub. after looking at grub however it looks like my root is on hd0/4 since it says windows is loaded on hd0/0 im going to try and use fdisk to set the boot to 4 and see what happens. no luck as of yet.

2nd June 2004, 04:32 AM
you'll all love this. This is what I currently am seeing when I boot my computer. "Invalid partition table" tried to change everything in linux but no joy. time to install everything again.

2nd June 2004, 01:38 PM
Maybe you hit the XP dual-boot Geometry bug? If so, you don't have to re-install...try this link:


3rd June 2004, 02:04 AM
Tried going through that recovery but I think when I used fdisk to set the bootable flags I overwrote the MBR on the windows partition. I am going to try something different and install Fedora on the first partions and then windows. THen Ill see if I can get grub to load windows. Im a glutton for punishment I know....thanks for all your help.

3rd June 2004, 01:49 PM
Regarding WinXP/Fedora C2 dual-boot issues...

My partition tables were corrupted on the first install, but then I followed the "prevention" section of the information presented in the link above, and it worked perfectly. :D

4th June 2004, 02:36 AM
well I had the dual boot setup and working for a short time until I realized that windows and linux would not recognise the remaining freespace that I was using as a shared partition. so I reinstalled windows and linux again. No joy. Last time I got it working I installed linux, then windows, then linux again. we'll see

8th June 2004, 04:49 AM
if i can ad a question!
i have fedora core1 burned into 3 cds.. i`m allready running xp from one primary partitions. how do a go about installing linux into my second partition. just boot from cd and linux setup would format partitions to ext3??
i use loadlin bootloader.

9th June 2004, 03:37 AM
In the avoidance/recovery blurb referenced above, it says to download and burn the Fedora Core 2 Rescue CD.. I admit that I'm probably stupid in addition to being a newbie, but I can't find this Fedora Core 2 Rescue CD anywhere. Where do I look?

9th June 2004, 04:14 AM
Is it ok to say, "never mind!"?? Just after I posted the last, I looked one more time, and found it. Thanks, anyway.