PDA

View Full Version : FC3 VERY slow hdd



rhodes187
9th November 2004, 03:53 PM
I have rebuilt my Dell c840 laptop (previously running FC2) to FC3 (not the test version). Everything seems okay, except my hard drive is VERY slow. It takes literally 5-10 minutes to load GNOME, starting Firefox takes another 5-10 minutes. Any suggestions?

Dog-One
9th November 2004, 04:40 PM
Sounds like the kernel has turned off UDMA support and is running in PIO mode for some reason. You may try using hdparm to see if you can verify and possibly override it.

rhodes187
9th November 2004, 04:45 PM
Sorry, not too experienced with hdparm... How would I check if UDMA was disabled? Is there a way to reenable it? How would I set this at boot time? Thanks in advance...

tirespeed
9th November 2004, 05:03 PM
as root
/sbin/hdparm /dev/hda
This will show you settings on the hard drive. If it shows DMA 0 (off) then change it with
/sbin/hdparm -d 1 /dev/hda

To keep the settings after boot, edit the /etc/sysconfig/harddisks file

rhodes187
9th November 2004, 05:22 PM
/sbin/hdparm /dev/hda show dma as being on (it was set to 1). How would I check if UDMA is disabled? (as mentioned in an earlier post). Thanks for such quick responses...

rhodes187
9th November 2004, 05:43 PM
I should probably post these as well...

hdparm /dev/hda
/dev/hda:
multcount = 16 (on)
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 256 (on)
geometry = 38760/16/63, sectors = 20003880960, start = 0

hdparm -tT /dev/hda

/dev/hda:
Timing cached reads: 1008 MB in 2.00 seconds = 503.32 MB/sec
Timing buffered disk reads: 26 MB in 6.21 seconds = 4.19 MB/sec

This is real frustrating, I really like FC3 otherwise, but it's completely unusable at these speeds. Am I missing something?

Dog-One
9th November 2004, 11:01 PM
I concur with your slow disk performance < 5MB/s is pretty poor.

When I do
[root@fedora64 root]# hdparm -iI /dev/hda

/dev/hda:

Model=Maxtor 6E030L0, FwRev=NAR61590, SerialNo=E10PEALE
Config={ Fixed }
RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=57
BuffType=DualPortCache, BuffSize=2048kB, MaxMultSect=16, MultSect=16
(maybe): CurCHS=65535/16/0, CurSects=0, LBA=yes, LBAsects=60058656
IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6
AdvancedPM=yes: disabled (255) WriteCache=enabled
Drive conforms to: (null):

* signifies the current active mode


ATA device, with non-removable media
Model Number: Maxtor 6E030L0
Serial Number: E10PEALE
Firmware Revision: NAR61590
Standards:
Supported: 7 6 5 4
Likely used: 7
Configuration:
Logical max current
cylinders 16383 16383
heads 16 16
sectors/track 63 63
--
CHS current addressable sectors: 16514064
LBA user addressable sectors: 60058656
device size with M = 1024*1024: 29325 MBytes
device size with M = 1000*1000: 30750 MBytes (30 GB)
Capabilities:
LBA, IORDY(can be disabled)
Queue depth: 1
Standby timer values: spec'd by Standard, no device specific minimum
R/W multiple sector transfer: Max = 16 Current = 16
Advanced power management level: unknown setting (0x0000)
Recommended acoustic management value: 192, current value: 254
DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 udma5 *udma6
Cycle time: min=120ns recommended=120ns
PIO: pio0 pio1 pio2 pio3 pio4
Cycle time: no flow control=120ns IORDY flow control=120ns
Commands/features:
Enabled Supported:
* NOP cmd
* READ BUFFER cmd
* WRITE BUFFER cmd
* Host Protected Area feature set
* Look-ahead
* Write cache
* Power Management feature set
Security Mode feature set
* SMART feature set
* FLUSH CACHE EXT command
* Mandatory FLUSH CACHE command
* Device Configuration Overlay feature set
* Automatic Acoustic Management feature set
SET MAX security extension
Advanced Power Management feature set
* DOWNLOAD MICROCODE cmd
* SMART self-test
* SMART error logging
Security:
Master password revision code = 65534
supported
not enabled
not locked
not frozen
not expired: security count
not supported: enhanced erase
HW reset results:
CBLID- above Vih
Device num = 0 determined by CSEL
Checksum: correctNotice * next to udma6 for the DMA info in the Capabilities section. That indicates that my drive can do Ultra DMA 133 and is set to use it.

So in your case, check as I did above and if the highest setting isn't selected, do a hdparm -X udma5 /dev/hda then verify if it took. If it did take, try the speed test again to see if the speedtest shows improvement. If that's a go, you can edit /etc/sysconfig/harddisks and where you find EXTRA_PARAMS=, add -X udma5.

rhodes187
10th November 2004, 01:48 AM
None of my entries are starred.....
/dev/hda:

Model=IC25N060ATMR04-0, FwRev=MO3OAD0A, SerialNo=MRG387KCGGPPAH
Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs }
RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=4
BuffType=DualPortCache, BuffSize=7884kB, MaxMultSect=16, MultSect=16
CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=117210240
IORDY=on/off, tPIO={min:240,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2
AdvancedPM=yes: mode=0x80 (128) WriteCache=enabled
Drive conforms to: ATA/ATAPI-6 T13 1410D revision 3a:

* signifies the current active mode

Should 1 be? I really appreciate all the help so far, thank you....

Dog-One
10th November 2004, 04:03 PM
Yes, udma2 should be set, but your BIOS didn't do it's job, so you'll have to set it manually as I mentioned above.

If anyone is from the Windows side of the house, using hdparm to set your maximum drive performance is similar to Intel's Application Accelerator which is usually recommend on a fresh load of Windows.

rhodes187
10th November 2004, 11:38 PM
I've set dma to 2 using dirstions above.... I issued hdparm -X udma2 /dev/hda, it shows set as this noe when I do hdparm -iT /dev/hda. This however had little or no effect. I also put this in /etc/sysconfig/harddisk as you mentioned and rebooted. Still the system is painfully slow. The strange thing is, the machine seems to boot up at normal speed and shutdown at normal speed, just using it in init3 or init5 makes the hard drive VERY slow.

rhodes187
10th November 2004, 11:54 PM
Okay I got it!!!! For some reason a deamon named haldaemon for whaever reason was really slowing down my system. The description says this is a daemon for collecting information about hardware from several sources. As soon as I turn this off everything works fine (getting 18MB/s now. Why would this cause such problems? It's enabled by default, is it for anyone else? What is this even for? The description was too vague... Anyone else seeing this issue? Think it's because I'm on a laptop....?

Dog-One
13th November 2004, 04:29 AM
I know HAL stands for Hardware Abstraction Layer, whether the new FC3 HAL is the same as Windows HAL, who knows. I think Linux added this to better deal with hotplug devices so I doubt it's had much field testing.

Glad you found the problem though! Now I'll know where to look when I install FC3 on my laptop and it's dog slow. ;)

rhodes187
13th November 2004, 04:06 PM
I read up on HAL, yeah it's similar to the MS version. The problem occurs because my laptop has both the harddrive and cdrom on the same IDE channel/cable. HAL constantly probes the cdrom for media check, thus monopolizes the channel with checks (chocking access to the harddrive). Many laptops do not do this (share channel), but the dell c840 does. Thanks for all your help and troubleshooting, I've learned a lot about hdparm doing this.