PDA

View Full Version : httpd error 98 on fresh install



Kameraad Pjotr
15th May 2011, 04:12 PM
Sometimes httpd (the apache web server) fails to start and displays an error (98: Address already in use: make_sock: could not bind to address xxx.xxx.xxx.xxx:80). This happens even when no other service is listening on port 80, as evident from the output of "lsof -i :80" and "netstat -A inet -lnp". This is due to a configuration file mixup. Both /etc/httpd/conf/httpd.conf and /etc/httpd/conf.d/system-config-httpd.conf contain the directive "Listen :80". If you comment out the "Listen 80" in /etc/httpd/conf.d/system-config-httpd.conf, httpd will again start.

This might not be a gigantic problem, but it might save you some day ;)

pete_1967
15th May 2011, 04:42 PM
It's an issue that has existed for numerous years.

For some reason Red Hat has never corrected it and it is caused if you install the GUI for HTTPD configuration and use it to configure your server. Another problem is (or used to be, haven't used the GUI tool for ages) that the GUI tool just enables every single module, whether they are installed or not causing, of course, server to crash and giving headache to poor guy who tries to run his server and now has to go and disable all non-installed and needed modules from httpd.conf. You probably also noticed that they are in all respects, duplicates of each other.