PDA

View Full Version : [SOLVED] Bootup Failure in Fedora 14.



cd10anil
15th May 2011, 10:37 AM
I am facing bootup issue in Fedora 14.
I troubleshoot the bootup issue i m facing probably because I have done change the name of volumes from disk utiltiy. I read somewhere that it should be done from another place (administration option, the last menu of fedora and there is some volume/disk management..like thing that give rod like blue/red picture of disk=>System-config-lvm) rather then disk utility under system tools.

I think that my LVM path is not setup..due to rename of volume..it is mismatched somewhere...that includes path...finally using rescue disk i enter in shell prompt and mounted my system using
chroot /mnt/sysimage
then found that my /home is empty, so done some readings and found that using
mount /dev/vg_brs/home /home
i am able to get my home fixed that now appeared my user and whole data.

but that is till i m in shell prompt. Don't know where and how to fix/add this line so that boot loader of fedora will take this instead of something other that it is taking and not founding resulting in failure to boot with message (in between lines):

==================================
checking filesystem
/dev/mapper/vg_brs-lv_root, clean..blah blah...
/dev/sd1: clean, blah , blah
fsk-ext4: No such file or directory while trying to open /dev/mapper/vg_brs-lv_home
/dev/mapper/vg_brs-lv_home: The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>
[FAILED]

===========================

Not sure how to fix it ?
Any tips please?

PS: How I reached here, the details are with this thread http://forums.fedoraforum.org/showthread.php?t=262769 that explains why i need to change the volume name.

Any suggestion, I am curiously waiting for some reply...

---------- Post added at 07:12 AM ---------- Previous post was at 01:26 AM ----------

Using rescue mode, in shell prompt, i browse the files after
chroot /mnt/sysimage

to browse the location
/dev/mapper/vg_brs-lv_home

The #pwd command result in
/dev/mapper

The command
ls -l
gives below output

total 0
crw-------. 1 root root 10, 62 May 15 00:11 control
lrwxrwxrwx. 1 root root 7 May 15 06:04 vg_brs-lv_home -> ../dm-1
lrwxrwxrwx. 1 root root 7 May 15 06:04 vg_brs-lv_root -> ../dm-0
lrwxrwxrwx. 1 root root 7 May 15 06:05 vg_brs-lv_swap -> ../dm-2

So while the contents for vg_brs-lv_home are mismatched...
it is looking for

/dev/mapper/vg_brs/home

but the contents are in

vg_brs-lv_home

Also, out put of some other commands if it helps, taken from rescue mode shell prompt. (... shows contents not relevant, so i skipped them)
sfdisk -l /dev/sda
Disk /dev/sda: ...
Units = CYLINDERS OF ... counting from 0

Device Boot Start End #cyls #blocks Id System
/dev/sda1 * 0+ 63- 64- 512000 83 Linux
/dev/sda2 63+ 121601- 121538- 976248832 8e Linux LVM
/dev/sda3 0 - 0 0 0 Empty
/dev/sda4 0 - 0 0 0 Empty

#vgscan
Reading all phsical volumes. This may take a while..
Found volume group "vg_brs" using metadata type lvm2

When live cd login, i checked,
1. The disk content of vg_brs with disk utilty, i found
volume name Device Label
lv_root /dev/dm-2 lv_root
lv_home /dev/dm-3 home
lv_swap /dev/dm-4

2. The disk when selected shows
Device PartionFlag Type Label PartionType PartitionLabel
/dev/sda1 Bootable Linux(0x83) lv_root Ext4(version 1.0) -
/dev/sda2 Linux LVM(0x8e) -

Any fedora Guru :confused: to rescue ???

---------- Post added at 03:07 PM ---------- Previous post was at 07:12 AM ----------

Thanks in advance...

glennzo
15th May 2011, 01:54 PM
Please post the content of /boot/grub/grub.conf.

cd10anil
15th May 2011, 02:20 PM
The content of /boot/grub/grub.conf is as follows: (I use fedora full dvd and logged on for rescue installation then mount chroot /mnt/sysimage, in shell start. go to /boot/grub and cat grub.conf. The contents are typed below *may contain typographic error & hope i didnt missed any line*
#grub.conf generated by anaconda
#
#Note that your do not have to rerun grub after making changes to this file
#Notice: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/mapper/vg_brg-lv_root
# initrd /initrd-[generic-]version.img
#boot=/dev/sda
default=0
timeout=0
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
titile Fedora (2.6.35.13-91.fc14.i686)
root (hd0,0)
kernel /vmlinuz-2.6.35.13-91.fc14.i686 ro root=/dev/mapper/vg_brs-lv_root rd_LVM_LV=vg_brs/lv_root rd_LVM_LV=vg_brs/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quite
initrd /initramfs-2.6.35.13-91.fc14.i686.img
title Fedora (2.6.35.6-45.fc14.i686)
root (hd0,0)
kernel /vmlinuz-2.6.35.6-45.fc14.i686 ro root=/dev/mapper/vg_brs-lv_root rd_LVM_LV=vg_brs/lv_root rd_LVM_LV=vg_brs/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quite
initrd /initramfs-2.6.35.6-45.fc14.i686.img

glennzo
15th May 2011, 02:39 PM
OK. Hopefully these postings got the thread to the top of the list and someone with LVM experience will come along and offer help.

cd10anil
15th May 2011, 03:03 PM
Here's the quick backstory:
http://forums.fedoraforum.org/showthread.php?t=262769

glennzo
15th May 2011, 03:09 PM
Right. Well, as I said in your PM to me I have very little experience with LVM. My main goal in replying to this thread was to get it back to the top of the list, as this reply will do. Believe me, if I could help I would.

cd10anil
15th May 2011, 05:54 PM
Some more information below in bugzilla that states that this (bootup failure due to rename) is not a bug
https://bugzilla.redhat.com/show_bug.cgi?id=230190

---------- Post added at 09:21 PM ---------- Previous post was at 08:20 PM ----------


Some more information below in bugzilla that states that this (bootup failure due to rename) is not a bug
https://bugzilla.redhat.com/show_bug.cgi?id=230190

I am bit confuse to follow these steps in doubt to further :doh: complicate the problem :Y ..so will follow with some experts advise. :rolleyes:

---------- Post added at 10:24 PM ---------- Previous post was at 09:21 PM ----------

The output of /etc/fstab is below:

#/etc/fstab
#Created by anaconda on Tue May 10 19:09:33 2011
#
#Accessible filesystems, by reference, are maintained under '/dev/disk'
#See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/mapper/vg_brs-lv_root / ext4 defaults 1 1
UUID=<UUID GOES HERE> /boot ext4 defaults 1 2
/dev/mapper/vg_brs/home /home ext4 defaults 1 2
/dev/mapper/vg_brs-lv_swap swap swap defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0

erroneus
15th May 2011, 06:00 PM
LVM is a pretty picky beast. If it is part of a live installation, don't change it!! I guess you know that by now. And changing the volume names will automatically break LVM's structure. It uses UUIDs and volume names to link and associate members of groups, logical volumes and physical volumes. I have been inside of it before and have learned that it's simply best to avoid it unless you have good reason to use it.

Even most Linux recovery utilities do not easily handle LVM when trying to recover data. So with all that said, I recommend renaming the volumes BACK the way they were and try to recover that way. If there is data you need from the drive(s), do the recovery and then reinstall with manual partitioning and avoid the use of LVM in the future.

The proper use, care and feeding of LVM is ridiculously complicated but the purpose of LVM is also rather important for certain uses and applications -- so it's not all junk -- I have actually put it to very good use in VMs that needed more space added to them where LVM enabled me to expand a volume LIVE without shutting down or rebooting or anything. It was pretty sweet. It definitely has its uses.

I think it would be best for you, moving forward, to recover what you can and start over. Avoid LVM if you don't want to mess with it now or in the future. This is especially true for desktop/laptop uses.

cd10anil
15th May 2011, 06:54 PM
Thanks erroneus, Thanks glennzo... u know what..

Finally we resolved the issue :) , I am able to successfully boot the system. Hurray...

After going through these link and reading it many times... (dont remember how many time i have gone through this posting.. https://bugzilla.redhat.com/show_bug.cgi?id=230190 , These below line from this link ticks me...
==============================
Bryn M. Reeves 2007-07-20 06:47:38 EDT

Dumb question, but did you update /etc/fstab with the new VG name?
===============================

That is why i just updated the fstab above....and note this line

/dev/mapper/vg_brs/home /home ext4 defaults 1 2

and my first posting that states
then found that my /home is empty, so done some readings and found that using
mount /dev/vg_brs/home /home
i am able to get my home fixed that now appeared my user and whole data.

but that is till i m in shell prompt. Don't know where and how to fix/add this line so that boot loader of fedora will take this instead of something other that it is taking and not founding resulting in failure to boot with message (in between lines):

==================================
checking filesystem
/dev/mapper/vg_brs-lv_root, clean..blah blah...
/dev/sd1: clean, blah , blah
fsk-ext4: No such file or directory while trying to open /dev/mapper/vg_brs-lv_home
/dev/mapper/vg_brs-lv_home: The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>
[FAILED]

===========================

Not sure how to fix it ?
Any tips please?

DONE !!!

Thanks to erroneus and glennzo, without whome I am not able to resolve this issue.

just for reference, that helped to resolve this
http://forums.fedoraforum.org/archive/index.php/t-101931.html
http://www.server-world.info/en/note?os=Fedora_14&p=lvm

---------- Post added at 11:24 PM ---------- Previous post was at 10:55 PM ----------


Step to fix the problem:
1. Using DVD of fedora to login with rescue mode.
2, Go to shell prompt
3. Enter below command as suggested by rescue mode
chroot /mnt/sysimage
4. Go to folder
/etc
5, Edit the fstab file using vi
vi fstab
6. Change the line
/dev/mapper/vg_brs/home /home

with this one

/dev/maper/vg_brs-lv_home /home

7. save file.
8. Reboot without rescue disk...
Result: bootup successfully.

erroneus
15th May 2011, 07:39 PM
Not sure what I said that was helpful but you're welcome. There are a lot of threads that I never see as I only watch a select few ... I get email notices on the ones I have responded to. Glad to be of help.

You are not only getting help here, you are also contributing to the pool of knowledge in these forums. Thanks for describing your solution so that the next person with the same or similar problem will not have to work as hard as you did.