View Full Version : Apire One A0521 Keyboard/touchpad not responding

8th May 2011, 05:45 AM
My first post to a fedora forum so hello for starters!
I looked everywhere, did every kind of search possible and came across ny guides on inslling fedora on an acer aspire one, none of which address my specific model A0521-3530 has the k125 processor at 1.7Ghz, as well as the 387 mb of dedicated graphics on an amd GPU. I originally wanted to install fedora 12 but during the install where it asked to check media or skip my keyboard does not respond, only if I have a USB keyboard does it allow me to continue. Then when it runs anaconda it freezes immediately upon finishing.

That being said I loaded up F14 instead which im typing on right now, but even on f14 my netbooks keyboard and touchpad wouldn't respond, forcing me to use a usb keyboard and mouse. Even using the usb keyboard and mouse however, F14 is running EXTREMELY slowly and every key i type has about a second of lag, same with any mouse movements. I am dual booting this with W7 on the other half of the partition. I have a SATA HDD 320 gb. I have tried updating, also checking the xorg file (though admittedly I had no idea what I was looking for).

I would prefer a clean install of F12 WITH use of my laptops keyboard/touchpad. but if I have to I'll use F14 If someone can telll me how exactly to fix the lag, and how to get my keyboard and touchpad working.

Thank you VERY much in advance for any help/advice you can provide, I've been doing this for days and need it working right for my Red Hat training course.

---------- Post added at 09:45 PM ---------- Previous post was at 03:46 PM ----------

Anyone have any ideas? I just tried CentOS as well and it froze before it even got to the desktop.

15th May 2011, 03:30 PM
Hum more investigating is needed but does the keyboard work if drop out of gui. Not sure how new you are but this can be done by going to terminal and doing init 3. See if it works their. This my be dumb question does it work other os like windows and or the bios.

15th May 2011, 04:34 PM
Fixed all issues and I'm embarrassed to say all it needed was a BIOS update called "Linux fix" thanks a lot for your help though. The update was on Acer's website.

---------- Post added at 08:34 AM ---------- Previous post was at 08:33 AM ----------

And no the keyboard pre-bios update didn't work anywhere other than windows. The bios update fixed EVERYTHING. Runs like a dream now.