PDA

View Full Version : software update hangs



martypants
7th May 2011, 05:18 AM
I just installed F14 last week and today I updated 2 modules. When those installed, the software update wanted to install another 477 modules. I tried to let it update, but it hangs on "Checking for Applications in Use"

Any methodology you'd suggest for paring down the list to something more manageable and updateable?

---------- Post added at 01:18 PM ---------- Previous post was at 01:04 PM ----------

Just tried trying to install only security updates. What a f*&king pain in the a$$ to click through 400+ modules. Is there not even a "select/deselect all" option?

Anyway, that hangs, too.

osce0
7th May 2011, 05:24 AM
I'd try using the command line yum update preferably in init mode 3 (no Xorg graphics).

Another way is to figure out which package collections take up the large part of the update (like KDE collections or OpenOffice.org) and just do piecemeal yum update package until remaining updates are small enough for the GUI to handle.

martypants
7th May 2011, 08:53 AM
I installed all the "enhancement" updates and that worked fine. But still going back to install security updates hangs.

I'm not a n00b, but if I were, telling someone to do something in init mode 3 is pretty f-ing cryptic. It's sad if that's the only way for someone new to Fedora to get all the updates done the system wants, or worse, to update each (of the 400 or so remaining modules) by hand.

---------- Post added at 04:53 PM ---------- Previous post was at 01:33 PM ----------

turns out a simple 'yum update' works.

Tquilha
7th May 2011, 09:47 AM
No need to go into init 3.
just open a console and use "yum update".
Works a lot better than packagekit...
:)