PDA

View Full Version : Problems mounting /var during boot



TylerD75
7th November 2004, 02:46 AM
Hi

I've got a reoccuring problem each time I try to install Fedora Core 2 Final.
The installation goes just fine, and so do the config. No problems for quite some time. But sometimes when I reboot the computer the boot stops while mounting /var. There's no error msg in logs or in the boot window. It just stops. Then I get a msg telling me to hit CTRL-D or type the root password to log on. So I've done. I've run fsck.ext3 /dev/hda7 (which is my /var folder) with no problems reported.

After this problem occures, there's no way I can ever boot up normally again. I've tried reinstalling, repartitioning and reformating, but the problem always comes back.
I've also noticed once, that the /tmp partition just disconnected (of lack of a better word) and a new /tmp folder was created automatically in / (which also is a problem, since I've kept / very small).

As mentioned above, after the problem occures I will never be able to boot normalliy, but I can type the root passwd and mount the partitions manually without problems. This means I can start all the services I need (since this is mainly a GW/Firewall), but not mount usb drives etc...

I understand that it could be a problem with my HD, but that one is a very new 120GB HD. But if there where any bad sectors etc. on the HD, shouldn't it be reported with fsck.ext3?

The system:
KT7-Turbo2 mobo
AMD XP1200
Kernel 2.6.5-1.358 (standard Fedora Core 2 kernel [not recompiled in any way])
ATI Radeon 9200
Using primarily Gnome if working locally, but I can never get Gnome to run after the /var problem

PS!: One more question. How can I manually start USB (deamon?) support? Since It's not completing the boot, I can't connect my usb drives. Is it enough to modprobe the usb modules?

Cheers,
TylerD

Dog-One
7th November 2004, 05:16 AM
I know the original stock FC2 kernel that you are running has some bugs. If you can manually get things running, I'd try to update to the 2.6.8-1.521 kernel and see if that takes care of the problem.

TylerD75
7th November 2004, 05:59 AM
Thanks for the reply!

I'll try this, but I've deliberetly stayed away from the 2.6.8 kernels due to the audio/cdburning bug. But I think I'll try the 2.6.9 kernel. Thanks though, I wasn't sure if it was related to the kernel or software. I also see that Fedora Core 3 will be released tomorrow... Maybe I'll just install that one... Do you happen to know what kernel it uses?

Cheers,
TylerD

Dog-One
7th November 2004, 06:38 AM
I'm using a 2.6.9 kernel with FC2 currently--seems to work well and it supports the on-demand power management feature.

I'm not exactly sure what kernel version will be in the FC3 release. I do know that FC3 RC3 had a 2.6.9-something kernel.

I wish that Fedora would use slipstreaming of their releases, so that you could download ISOs with all the latest patches pre-applied--at least when there are serious bugs in the kernel. With any luck, FC3 will be stable so that anyone can start from there without major installation problems.

bobp
7th November 2004, 08:03 AM
I'm thinking that it's a hard drive problem. The same thing happened to me and it drove me crazy. In the end I took out the hard drive it wouldn't install on, installed FC2 on a different one, and it worked fine. After FC2 was installed, I attached the broken one and tried to boot, but it wouldn't work, even though FC2 had been succesfully installed on a dif HD. Then I took out the broken hard drive, and it booted fine off the working hard drive. If you have a spare HD around I would suggest trying to install FC2 on that, to see if it's a hardware problem.

TylerD75
8th November 2004, 03:37 AM
Thanks for the replies!

I've now tried installing kernel 2.6.9, without much luck. It still hangs when trying to mount /var. I've tried fsck -c (for bad sectors), but are unable to find anything wrong with the HD. The strange thing is that I'm fully able to mount the partition manually, but not automatically... Argh...

But I do have one 200GB disc in an external USB casing, so maybe I'll try switching those discs and install FC3. Thanks for all the responses though! I'll post a new msg if the same problem occurs on the new disc... Now I'm just waiting for the da*n ftp access to open ;)

Cheers all!
TylerD