PDA

View Full Version : Installing FireFox 1.0



Code XYZ
6th November 2004, 03:56 PM
Greetings Gentlemen, I'm new to Fedora Core 2 and Linux and I would be greatfull if some one can help installing FireFox, I have down loaded "Firefox-0.10-0.1.fc2.fr.src.rpm " and tried installing it from my Terminal with this command : rpm -Uvh firefox-0.10-0.1.fc2.fr.src.rpm but every time I try I keep getting this message in my Terminal : warning:

firefox-0.10-0.1.fc2.fr.src.rpm: V3 DSA signature: NOKEY, key ID e42d547b
1:firefox warning: user machbuild does not exist - using root
warning: group machbuild does not exist - using root

has anybody else had the same problem, how can fix it so it will install also How is the best way to install RPM files ?

deuch
6th November 2004, 04:39 PM
not problem, packager used his own user to create the rpm (machbuild). When you are installing the source, the package detects that machbuild user doesn't exist and used root instead.

Be careful, you installed source package, you have to compile it to use firefox

hope it helps,

deuch

bob
6th November 2004, 04:42 PM
I'd go back to mozilla.org and download this file: firefox-1.0PR-i686-linux-gtk2+xft-installer.tar.gz . You can then simply browse to the directory and extract it, which will give you a firefox-installer. Once it's installed, inside firefox-installer you'll find the 'firefox' file to run it. You can drag that file over to the desktop and 'link here'.

As far as the rpm files, you can check out this link: http://www.rpm.org/max-rpm/s1-intro-to-rpm-lets-get-started.html
which will give you all the details you need.

Code XYZ
7th November 2004, 03:41 AM
Thank you very much for your reply and help justol'bob I already had firefox-1.0PR-i686-linux-gtk2+xft-installer.tar.gz downloaded and I tried it before and I can open up the firefox-installer file after I unTared it and then when I click on the firefox-installer in the file nothing happens, so that's why I thought I will try and use the RPM version but that didn't work either. I will keep trying and see if I can work out the problem why it don't want to install. Also thank you for the link to the how to on RPM, it's very interesting and there is a lot of information, all the reading will keep me of the streets and out of trouble.

Thank you again both justol'bob and deuch for your time to help me, it's been a help and now I know something about RPM and how it works.

bob
7th November 2004, 05:24 PM
Code, I'd delete the extracted files and try simply browsing to the tar.gz file, which is probably in your /home directory and right-clicking and 'extract here'. Then try clicking on the installer and see if it works. If not, delete the whole thing and download again, because something went wrong with the download. But....if you can wait until 11/9 the final version of firefox 1.0 is supposed to be released, so it might be just as easy to wait and give it a try then.

As info, I just had to reinstall firefox yesterday as my version no longer downloaded files. This has happened twice in the last 2 weeks and the re-installed version works fine. Just didn't want you to feel alone being frustrated.

Tru
7th November 2004, 09:35 PM
I just use the yum.conf from www.fedorafaq.org and then just su - into root and type this " yum install firefox " man you goto love fedorafaq.org that website has helped me out a ton. Thank you to who ever keeps that site going your doing a good job :)