PDA

View Full Version : F-14 and Firefox on Citrix



One Way Dave
14th April 2011, 12:43 AM
Give credit where credit is due:

http://kenfallon.com/?p=808

But I still didn't get Citrix to work. This has been an issue with Citrix at least since 2005 and there are several "fixes" online. But none of them worked for me, so I summarize, here, what worked for me. I'm using Fedora-14 and Firefox 3.6.16

Go to Citrix download site and download the RPM for the current version.

http://citrix.com/English/SS/downloads/details.asp?downloadID=3323&productID=-1

Open a terminal on your computer and type

yum install –nogpgcheck ./ICAClient...386.rpm

Next, open Firefox and go to Edit>Preferences>Advanced>Encryption Tab>View Certificates

Scroll down to the Equifax sections and highlight them all (use the control+enter trick to highlight more that one at a time) and select export.

Export to Desktop (and later move using a terminal and “mv” command) or directly to the folder they belong in.

/usr/lib/ICAClient/keystore/cacerts

Now change the file type by (I had to become root and do this in the /cacerts folder)

rename .der .crt *der
rename .cer .crt *cer

Now open Firefox and go to your server site and click to open the Citrix server. A window will open asking you what program to use Click the “do this every time” box then select browse and go to

/usr/lib/ICAClient/wfica

and double click on wfica

You should now be there! At least it worked for me.