PDA

View Full Version : [SOLVED] Broadcom BCM32225 [14e4:4357] wireless card cannot scan networks



ddreggors
14th April 2011, 03:45 AM
I have tried many times now to get this card working under Fedora 14. I have seen many forum posts regarding similar cards that use the same driver (broadcom-wl) and tried all ways, but still no luck.


Here are my symptoms:

1. Driver loads
2. Device eth1 is created
3. iwconfig sees eth1 as a wireless device
4. iwlist eth1 scan and NetworkManager show no networks

Here is an oddity, I have this card working with the same drivers when I install F14 to USB with persistant overlay. I am using the same versions of kernel, kernel-devel, kmod-wl on the USB install as I am in HD install.



[root@mobile-tek ~]# uname -r
2.6.35.12-88.fc14.x86_64
[root@mobile-tek ~]# rpm -qa |grep -e kernel -e broadcom-wl -e kmod |sort
abrt-addon-kerneloops-1.1.17-1.fc14.x86_64
akmods-0.3.6-3.fc12.noarch
akmod-wl-5.100.82.38-1.fc14.x86_64
broadcom-wl-5.100.82.38-1.fc14.noarch
kernel-2.6.35.12-88.fc14.x86_64
kernel-2.6.35.6-45.fc14.x86_64
kernel-devel-2.6.35.12-88.fc14.x86_64
kernel-headers-2.6.35.12-88.fc14.x86_64
kmodtool-1-18.fc11.noarch
kmod-wl-2.6.35.12-88.fc14.x86_64-5.100.82.38-1.fc14.2.x86_64
kmod-wl-5.100.82.38-1.fc14.2.x86_64



I have the live USB key now and it is working great. I need this to work when I boot from HD though.

Another odd thing is USB keys boots just fine but to boot from HD I have to add "acpi=off" to kernel line or I get just the tail end of a kernel stack trace before I see anything else and the machine locks up.

The steps I used to install on live USB and on my HD are from:
http://fedoramobile.org/fc-wireless/broadcom-linux-sta-driver

here are the steps:


su -c 'yum update'


Then setup rpmfusion, and continue on too...



su -c 'yum install akmod-wl'
su -c 'akmods --akmod wl'
su -c 'reboot'



Results:


[root@mobile-tek ~]# iwconfig eth1
eth1 IEEE 802.11bgn ESSID:"" Nickname:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Bit Rate:144 Mb/s Tx-Power:24 dBm
Retry min limit:7 RTS thr:off Fragment thr:off
Power Managementmode:All packets received
Link Quality=5/5 Signal level=0 dBm Noise level=0 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

[root@mobile-tek ~]# ifconfig eth1
eth1 Link encap:Ethernet HWaddr 5C:AC:4C:08:C8:9C
inet6 addr: fe80::5eac:4cff:fe08:c89c/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:17

[root@mobile-tek ~]# iwlist eth1 scan
eth1 No scan results


---------- Post added at 10:45 PM ---------- Previous post was at 05:23 PM ----------



I decided to dig deeper and noticed a message in the logs (/var/log/messages) like:


kernel: [ 377.850223] irq 19: nobody cared (try booting with the "irqpoll" option)


so I rebooted and edited the kernel line while booting to append "irqpoll" to the end and once loaded into my desktop I could now see networks in NetworkManager again!

To clarify for others, this is an eMachine E528, and the trick to make it boot and see wireless networks is adding these 2 options to the end of your kernel line in grub.conf:

acpi=off irqpoll