PDA

View Full Version : Hide /dev/dm-0 in gnome places menu



Snarfster
1st April 2011, 11:11 PM
Hello there.

I have Fedora 14 installed on a Asus EeePC 1005 HA. At install I used full disk encryption.

For some reason I have a unmounted LVM disk in my places menu in gnome. I don't like it being there, so I am trying to remove it.

After some searching on the net I learned I should hide it through udev.

udevadm gives me the following info about the partition:


>udevadm info -a -p $(udevadm info -q path -n /dev/dm-0)

Udevadm info starts with the device specified by the devpath and then
walks up the chain of parent devices. It prints for every device
found, all possible attributes in the udev rules key format.
A rule to match, can be composed by the attributes of the device
and the attributes from one single parent device.

looking at device '/devices/virtual/block/dm-0':
KERNEL=="dm-0"
SUBSYSTEM=="block"
DRIVER==""
ATTR{range}=="1"
ATTR{ext_range}=="1"
ATTR{removable}=="0"
ATTR{ro}=="0"
ATTR{size}=="301197368"
ATTR{alignment_offset}=="0"
ATTR{discard_alignment}=="0"
ATTR{capability}=="10"
ATTR{stat}==" 11578 0 521908 465319 46465 0 362608 18904589 0 135402 19369910"
ATTR{inflight}==" 0 0"



I then tried to hide it by placing a file in /etc/udev/rules.d.

It contains:

>cat 10-ignored-disks.rules
KERNEL=="dm-0", OPTIONS+="ignore_device"


Unfortunately, this doesn't work. :(

Any ideas on how to solve this?

Thanks in advance.