PDA

View Full Version : Can't launch X-window



Breeze
29th March 2011, 03:52 PM
I moved / from /dev/sda6 to /dev/sda1 and then I can't launch x-window in normal user.But I can launch x-window in root which I use Alt+Ctrl+R2 and startx.Help me,Thanks!

---------- Post added at 10:52 PM ---------- Previous post was at 10:50 PM ----------

/var/log/boot.log


Welcome to Fedora
Starting udev: udevd[467]: BUS= will be removed in a future udev version, please use SUBSYSTEM= to match the event device, or SUBSYSTEMS= to match a parent device, in /etc/udev/rules.d/10-usrp.rules:3

udevd[467]: SYSFS{}= will be removed in a future udev version, please use ATTR{}= to match the event device, or ATTRS{}= to match a parent device, in /etc/udev/rules.d/10-usrp.rules:3

[ OK ]
Setting hostname winner-fc: [ OK ]
Setting up Logical Volume Management: No volume groups found
[ OK ]
Checking filesystems
/dev/sda1: clean, 577269/1831424 files, 4754800/7325632 blocks
/dev/sda9: clean, 87/122880 files, 85377/489916 blocks
/dev/sda8: clean, 205604/5160960 files, 10618062/20620800 blocks
[ OK ]
Remounting root filesystem in read-write mode: [ OK ]
Mounting local filesystems: [ OK ]
Enabling local filesystem quotas: [ OK ]
Enabling /etc/fstab swaps: [ OK ]
Entering non-interactive startup
Checking kmods exist for 2.6.35.11-83.fc14.x86_64 [ OK ]
iptables: Applying firewall rules: [ OK ]
Starting capi4linux: udevd-work[1140]: kernel-provided name 'capi' and NAME= 'capi20' disagree, please use SYMLINK+= or change the kernel to provide the proper name

[ OK ]
Starting portreserve: [ OK ]
Starting system logger: [ OK ]
Enabling ondemand cpu frequency scaling: [ OK ]
Starting irqbalance: [ OK ]
Starting rpcbind: [ OK ]
Starting mdmonitor: [ OK ]
Starting system message bus: [ OK ]
Setting network parameters... [ OK ]
Starting NetworkManager daemon: [ OK ]
Starting Avahi daemon... Timeout reached while wating for return value
Could not receive return value from daemon process.
[FAILED]
Starting NFS statd: [ OK ]
Starting RPC idmapd: [ OK ]
Starting cups: [ OK ]
Mounting other filesystems: [ OK ]
Starting acpi daemon: [ OK ]
Starting HAL daemon: [FAILED]
Starting lm_sensors: loading module coretemp [ OK ]
Retrigger failed udev events [ OK ]
Starting PC/SC smart card daemon (pcscd): [FAILED]
Starting VirtualBox kernel modules [ OK ]
Registering binary handler for qemu applications
ipsec_setup: Starting Openswan IPsec U2.6.33/K2.6.35.11-83.fc14.x86_64...
Starting sshd: [ OK ]
Starting xinetd: [ OK ]
MySQL Daemon failed to start.
Starting mysqld: [FAILED]
Starting abrt daemon: [ OK ]
Starting ksm: [ OK ]
Starting console mouse services: [ OK ]
Starting ksmtuned: [ OK ]
Starting crond: [ OK ]
Enabling monthly Smolt checkin: [ OK ]
Starting SMB services: [ OK ]
Starting atd: [ OK ]
Starting libvirtd daemon: [ OK ]

PatMcLJr
29th March 2011, 03:57 PM
dunno?

maybe log in as your user and try
su -c gdm

Pat Jr.

jpollard
29th March 2011, 04:01 PM
How did you move the filesystem?

It is possible you lost the security labels, but I would have expected additional failures first. IF all you did was loose the labels then a "touch /.autorelabel" will cause the system to relabel itself on the next boot.

Breeze
30th March 2011, 05:29 AM
How did you move the filesystem?

It is possible you lost the security labels, but I would have expected additional failures first. IF all you did was loose the labels then a "touch /.autorelabel" will cause the system to relabel itself on the next boot.

I just use
cp,Thanks for your answer.How can I do with that?

jpollard
30th March 2011, 12:40 PM
cp -r -preserve=all <source> <destination>

Breeze
31st March 2011, 12:38 PM
cp -r -preserve=all <source> <destination>

Not work,as the same problem before.

---------- Post added at 07:38 PM ---------- Previous post was at 11:28 AM ----------

Thanks! I used GParted and I have done it.Thanks!