PDA

View Full Version : How to connect to Windows share?



PseudoPsyche
27th March 2011, 04:36 PM
Ok, I'm running Fedora 13 on my laptop and am trying to share out a folder from a Win7 computer.

Folder on Win7 machine is set to allow access to everyone.

In Fedora, I have SELinux disable, I've made sure samba is allowed in the firewall, and that the smb service is running. There's no password on the Win7 computer, so in the Windows Share setting on Fedora I just put the username and left the pass field blank.

I've seen some things say all you have to do is go the the "Network" place...but somehow that seems to have become non-existent and I don't know how to get it back.

Also, trying to connect to smb://WinShare/Share results in it saying that the server has timed out.

Sorry if this is a stupid question, but even though I've been using Fedora for awhile I'm still rather noobish about certain things.

Thanks for any help!

~PseudoPsyche

Keldorn
27th March 2011, 05:26 PM
What about firewall on windows PC?
Run

nmap windows-pc-ip
Also, if you haven't nmap installed, you can install it running command:

su -c 'yum install nmap'

PseudoPsyche
27th March 2011, 05:58 PM
EDIT: Ok, it worked when trying to connect to that IP/Share! I guess I didn't wait long enough after disabling the firewall. How can I set the Windows firewall to allow me to connect then? I still want the firewall enabled. Thanks!

I just disabled Windows firewall, no change.

Maybe I'm doing something wrong. How should I be trying to connect to the Windows share? Settings, steps...etc...

Output of nmap:



Starting Nmap 5.21 ( http://nmap.org ) at 2011-03-27 13:02 EDT
Nmap scan report for 192.168.***.***
Host is up (0.036s latency).
Not shown: 989 closed ports
PORT STATE SERVICE
135/tcp open msrpc
139/tcp open netbios-ssn
445/tcp open microsoft-ds
2869/tcp open unknown
5357/tcp open unknown
49152/tcp open unknown
49153/tcp open unknown
49154/tcp open unknown
49155/tcp open unknown
49156/tcp open unknown
49157/tcp open unknown

Nmap done: 1 IP address (1 host up) scanned in 3.09 seconds

Keldorn
27th March 2011, 07:19 PM
Ok, what about

smbclient //windows-ip/sharename/
?

How can I set the Windows firewall to allow me to connect then? I still want the firewall enabled. Thanks!
Really don't remeber I am not using windows at home and default windows firewall ot work, sorry.
upd:
Also, there is nice option in gnome "connect to" where you can choose windows share and enter params in gui.

PseudoPsyche
27th March 2011, 07:40 PM
Ok, what about

?

Really don't remeber I am not using windows at home and default windows firewall ot work, sorry.
upd:
Also, there is nice option in gnome "connect to" where you can choose windows share and enter params in gui.

Yes, smb://win-ip/Share works perfectly, thanks! I don't know why the Windows firewall was blocking it, but I browsed through the connection rules in the firewall and found it

For anyone else having the Windows firewall block you:
In Windows 7 go to Control Panel and click on Windows Firewall. On the left side click on Advanced Settings. A new window will come up, in the left pane select Inbound Rules. Scroll down the list until you see "File and Printer Sharing (SMB-In)", right click on it and select Enable Rule.
If that rule is already enabled, then something else is most likely blocking you.

There, now Windows Firewall should leave you alone :)

Thanks for the help!!!