PDA

View Full Version : [SOLVED] Wine cannot find libgl.so



J4yJ4y
20th March 2011, 06:22 PM
Hi everybody,

I just installed Fedora 14 on my computer and I must say that I really like it. :)
Yet wine has a small problem

err:wgl:has_opengl Failed to load libGL: libGL.so.1: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
err:wgl:has_opengl OpenGL support is disabled.
err:d3d_caps:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat.
err:d3d:InitAdapters Failed to get a gl context for default adapter
Direct3D9 is not available without OpenGL.
I already read som forum topic about that and i guess that the problem is that wine is not able to find that opengl libary on my system. Apparently that is a problem of my 64bit version because libgl.so is located in

/usr/lib64/
Would it be enough to link that file into the folder where wine is looking for it. Then I'd like to know which directory this is :rolleyes:
Or has somenone another idea for fixing that problem.
Btw my graphics card is Nvidia gt 320m and i have installed the newest .rpm driver that i could find for that (version 195.*)

Hope my english is not too bad :)

Smoking Tux
20th March 2011, 06:56 PM
Try to install the the graphics driver this way (http://forums.fedoraforum.org/showthread.php?t=204752). I think after installing the suggested .i686 libs your problem should disappear.

J4yJ4y
21st March 2011, 05:12 PM
Hi,

thank you for the fast answer. I now have reinstalled my graphics driver.
The problem is now solved but the application still doesn't start


fixme:win:EnumDisplayDevicesW ((null),0,0x296f5f4,0x00000000), stub!
fixme:d3d:swapchain_init Add OpenGL context recreation support to context_validate_onscreen_formats
fixme:d3dx:D3DXGetImageInfoFromFileInMemory (0x2ffdbf0, 4140, 0x296f978): partially implemented
fixme:d3dx:D3DXCreateFontIndirectW (0x69406a8, 0x296f948, 0x30491a8): stub
fixme:d3dx:D3DXCreateFontIndirectW (0x69406a8, 0x296f948, 0x30491ac): stub
fixme:d3dx:D3DXCreateEffectCompiler (0x30015d8, 8870, 0x296f814, 0x3049b14, 0, 0x296f80c, 0x296f7fc): stub
fixme:dbghelp:elf_search_auxv can't find symbol in module

This is the output when i am trying to start it.
Has someone an idea what could be the cause?

Defolos
21st March 2011, 05:51 PM
I would recommend to look in the wine ap-dp (http://appdb.winehq.org/) and search for your application, often there are tips how to get your program working. Also you could tell us which program you are trying to start and which wine version (and whether x86_64 or i686).

J4yJ4y
21st March 2011, 07:59 PM
D'oh i almost forgot this site :doh:
Due to the posts of that webiste my problem is a common problem with that application.. and still not solved.

Thank you for your fast help your forum made a great first impression to me :)